aboutsummaryrefslogtreecommitdiff
path: root/sysutils/py-salt
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2020-06-18 15:03:31 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2020-06-18 15:03:31 +0000
commit770c4bc3cf82a48a113d0e3af61c584a6ab1d785 (patch)
tree6fcfd01e18bb6b62aaa81c2299dca5385bea6430 /sysutils/py-salt
parentdc6f6aa45734e7833408a26b986b3e432ece5f7c (diff)
downloadports-770c4bc3cf82a48a113d0e3af61c584a6ab1d785.tar.gz
ports-770c4bc3cf82a48a113d0e3af61c584a6ab1d785.zip
Notes
Diffstat (limited to 'sysutils/py-salt')
-rw-r--r--sysutils/py-salt/Makefile2
-rw-r--r--sysutils/py-salt/distinfo6
-rw-r--r--sysutils/py-salt/files/patch-salt_loader.py12
-rw-r--r--sysutils/py-salt/files/patch-setup.py10
4 files changed, 16 insertions, 14 deletions
diff --git a/sysutils/py-salt/Makefile b/sysutils/py-salt/Makefile
index ab9fcbe85a34..55e4e42d111f 100644
--- a/sysutils/py-salt/Makefile
+++ b/sysutils/py-salt/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= salt
-PORTVERSION= 3000.3
+PORTVERSION= 3001
CATEGORIES= sysutils python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/sysutils/py-salt/distinfo b/sysutils/py-salt/distinfo
index 28d70fb0f028..bd041e9d1f59 100644
--- a/sysutils/py-salt/distinfo
+++ b/sysutils/py-salt/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1590047008
-SHA256 (salt-3000.3.tar.gz) = fcca49985e697d914e5a7f34b2fd8bbd833bcf7779d30174a279a4de2294cea7
-SIZE (salt-3000.3.tar.gz) = 15237557
+TIMESTAMP = 1592464695
+SHA256 (salt-3001.tar.gz) = 5ca60d1b2cc8e63db50995bd8b117914eeaf57c48ce2b3a3731ee57163adf154
+SIZE (salt-3001.tar.gz) = 14448043
diff --git a/sysutils/py-salt/files/patch-salt_loader.py b/sysutils/py-salt/files/patch-salt_loader.py
index 1578e73b9df7..f889f3c70adb 100644
--- a/sysutils/py-salt/files/patch-salt_loader.py
+++ b/sysutils/py-salt/files/patch-salt_loader.py
@@ -1,11 +1,13 @@
---- salt/loader.py
+--- salt/loader.py.orig 2020-06-18 07:20:08 UTC
+++ salt/loader.py
-@@ -1240,7 +1240,7 @@
+@@ -1383,9 +1383,7 @@ class LazyLoader(salt.utils.lazy.LazyDict):
try:
pycache_files = [
- os.path.join('__pycache__', x) for x in
-- sorted(os.listdir(os.path.join(mod_dir, '__pycache__')))
-+ sorted(os.listdir(os.path.join(mod_dir, '__pycache__'))) if not x.endswith('opt-1.pyc') and not x.endswith('opt-2.pyc')
+ os.path.join("__pycache__", x)
+- for x in sorted(
+- os.listdir(os.path.join(mod_dir, "__pycache__"))
+- )
++ for x in sorted(os.listdir(os.path.join(mod_dir, '__pycache__'))) if not x.endswith('opt-1.pyc') and not x.endswith('opt-2.pyc')
]
except OSError:
pass
diff --git a/sysutils/py-salt/files/patch-setup.py b/sysutils/py-salt/files/patch-setup.py
index e1516c3225de..57f656f3b492 100644
--- a/sysutils/py-salt/files/patch-setup.py
+++ b/sysutils/py-salt/files/patch-setup.py
@@ -1,13 +1,13 @@
---- setup.py.orig 2018-04-02 16:35:13 UTC
+--- setup.py.orig 2020-06-18 07:24:31 UTC
+++ setup.py
-@@ -992,8 +992,8 @@ class SaltDistribution(distutils.dist.Di
+@@ -1119,8 +1119,8 @@ class SaltDistribution(distutils.dist.Distribution):
def _property_data_files(self):
# Data files common to all scenarios
data_files = [
-- ('share/man/man1', ['doc/man/salt-call.1', 'doc/man/salt-run.1']),
-- ('share/man/man7', ['doc/man/salt.7'])
+- ("share/man/man1", ["doc/man/salt-call.1", "doc/man/salt-run.1"]),
+- ("share/man/man7", ["doc/man/salt.7"]),
+ ('man/man1', ['doc/man/salt-call.1', 'doc/man/salt-run.1']),
+ ('man/man7', ['doc/man/salt.7'])
]
if self.ssh_packaging or PACKAGED_FOR_SALT_SSH:
- data_files[0][1].append('doc/man/salt-ssh.1')
+ data_files[0][1].append("doc/man/salt-ssh.1")