aboutsummaryrefslogtreecommitdiff
path: root/sysutils/py-tarsnapper
diff options
context:
space:
mode:
authorPhilip Paeps <philip@FreeBSD.org>2018-11-18 17:15:44 +0000
committerPhilip Paeps <philip@FreeBSD.org>2018-11-18 17:15:44 +0000
commit373ad6f245d5f13b0091a4e545bf72b1d6eb160c (patch)
tree81b85c82e0cad0365d0e6fdb279b45fd45346b0f /sysutils/py-tarsnapper
parent57fa8182e532a3a6a11b38d3dd87ab0ec73c2e67 (diff)
downloadports-373ad6f245d5f13b0091a4e545bf72b1d6eb160c.tar.gz
ports-373ad6f245d5f13b0091a4e545bf72b1d6eb160c.zip
Add sysutils/py-tarsnapper 0.4
A wrapper around tarsnap which does two things: * Lets you define "backup jobs" (tarsnap invocations) in a config file, though on its own this has little advantage over just using a a shell script. * The ability to expire old backups using a Grandfather-father-son backup scheme. This feature can be used in conjunction with tarsnapper backup jobs, or standalone, to be applied to any existing set of tarsnap backup archives, regardless of how they have been created. WWW: https://github.com/miracle2k/tarsnapper
Notes
Notes: svn path=/head/; revision=485233
Diffstat (limited to 'sysutils/py-tarsnapper')
-rw-r--r--sysutils/py-tarsnapper/Makefile28
-rw-r--r--sysutils/py-tarsnapper/distinfo3
-rw-r--r--sysutils/py-tarsnapper/pkg-descr11
3 files changed, 42 insertions, 0 deletions
diff --git a/sysutils/py-tarsnapper/Makefile b/sysutils/py-tarsnapper/Makefile
new file mode 100644
index 000000000000..2075213a5f11
--- /dev/null
+++ b/sysutils/py-tarsnapper/Makefile
@@ -0,0 +1,28 @@
+# Created by: philip@FreeBSD.org
+# $FreeBSD$
+
+PORTNAME= tarsnapper
+PORTVERSION= 0.4
+CATEGORIES= sysutils python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= philip@FreeBSD.org
+COMMENT= Tarsnap wrapper which expires backups using a gfs-scheme
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python
+USE_PYTHON= distutils autoplist
+USE_GITHUB= yes
+
+GH_ACCOUNT= miracle2k
+GH_PROJECT= tarsnapper
+
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}argparse>0:devel/py-argparse@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dateutil>0:devel/py-dateutil@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pexpect>0:misc/py-pexpect@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyaml>0:textproc/py-pyaml@${PY_FLAVOR} \
+ tarsnap>=0:sysutils/tarsnap
+
+.include <bsd.port.mk>
diff --git a/sysutils/py-tarsnapper/distinfo b/sysutils/py-tarsnapper/distinfo
new file mode 100644
index 000000000000..fd419327fb14
--- /dev/null
+++ b/sysutils/py-tarsnapper/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1542542883
+SHA256 (miracle2k-tarsnapper-0.4_GH0.tar.gz) = 94ac22c3ed72e6321596f7d229b34fd21b59a00035162c5b22f2a1ee64dc6d01
+SIZE (miracle2k-tarsnapper-0.4_GH0.tar.gz) = 19204
diff --git a/sysutils/py-tarsnapper/pkg-descr b/sysutils/py-tarsnapper/pkg-descr
new file mode 100644
index 000000000000..735843ae4d7e
--- /dev/null
+++ b/sysutils/py-tarsnapper/pkg-descr
@@ -0,0 +1,11 @@
+A wrapper around tarsnap which does two things:
+
+* Lets you define "backup jobs" (tarsnap invocations) in a config file,
+ though on it's own this has little advantage over just using a a
+ shell script.
+* The ability to expire old backups using a Grandfather-father-son
+ backup scheme. This feature can be used in conjunction with tarsnapper
+ backup jobs, or standalone, to be applied to any existing set of
+ tarsnap backup archives, regardless of how they have been created.
+
+WWW: https://github.com/miracle2k/tarsnapper