aboutsummaryrefslogtreecommitdiff
path: root/sysutils/py-upt-pypi
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2019-12-27 07:14:31 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2019-12-27 07:14:31 +0000
commit66f25d9d10797a0ff490b4fbee1f1fa92ab336e5 (patch)
treeb931ae8f2d9d2ac5ab6bc181a850d914287f2f89 /sysutils/py-upt-pypi
parentb69057eb78008ba973b724504ec44d48f1921c45 (diff)
downloadports-66f25d9d10797a0ff490b4fbee1f1fa92ab336e5.tar.gz
ports-66f25d9d10797a0ff490b4fbee1f1fa92ab336e5.zip
[NEW PORTS] sysutils/py-upt{-pypi,-freebsd}: Universal Packaging Tool
A unified CLI tool that converts a package from a language-specific package manager (such as PyPI or NPM) to an almost ready-to-use package for Free Unix-based operating systems (such as a GNU/Linux distribution or *BSD). This commit includes the PyPI frontend and FreeBSD (Ports) backend packages as sysutils/py-upt-pypi and sysutils/py-upt-freebsd, respectively. WWW: https://framagit.org/upt/upt PR: 242241 Submitted by: Cyril Roelandt <cyril.roelandt aquilenet fr>
Notes
Notes: svn path=/head/; revision=520970
Diffstat (limited to 'sysutils/py-upt-pypi')
-rw-r--r--sysutils/py-upt-pypi/Makefile26
-rw-r--r--sysutils/py-upt-pypi/distinfo3
-rw-r--r--sysutils/py-upt-pypi/pkg-descr5
3 files changed, 34 insertions, 0 deletions
diff --git a/sysutils/py-upt-pypi/Makefile b/sysutils/py-upt-pypi/Makefile
new file mode 100644
index 000000000000..707031849a0b
--- /dev/null
+++ b/sysutils/py-upt-pypi/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= upt-pypi
+DISTVERSION= 0.5
+CATEGORIES= sysutils python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= tipecaml@gmail.com
+COMMENT= PyPI frontend for upt
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}upt>=0.9:sysutils/py-upt@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+do-test:
+ @cd ${WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} -m unittest -v
+
+.include <bsd.port.mk>
diff --git a/sysutils/py-upt-pypi/distinfo b/sysutils/py-upt-pypi/distinfo
new file mode 100644
index 000000000000..1ad8a3b45355
--- /dev/null
+++ b/sysutils/py-upt-pypi/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1574701220
+SHA256 (upt-pypi-0.5.tar.gz) = 6cfe91ab916ab190d4d6440b829c2c13d42855724f681c39483e98a506cd9c94
+SIZE (upt-pypi-0.5.tar.gz) = 12414
diff --git a/sysutils/py-upt-pypi/pkg-descr b/sysutils/py-upt-pypi/pkg-descr
new file mode 100644
index 000000000000..50aa5df35e44
--- /dev/null
+++ b/sysutils/py-upt-pypi/pkg-descr
@@ -0,0 +1,5 @@
+Universal Packaging Tool: PyPI frontend
+
+This is a PyPI frontend for upt.
+
+WWW: https://framagit.org/upt/upt-pypi