aboutsummaryrefslogtreecommitdiff
path: root/sysutils/qjail2
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-06-04 15:08:02 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-06-04 15:08:02 +0000
commit621d24ea7ebd2fe896ea448cd8b34bbd87145a9b (patch)
treed5e14ddc859bd47966e78bd4f72d56d3c7ece44d /sysutils/qjail2
parente9d5eb737803cba30a0107206093a2e9651eeadc (diff)
downloadports-621d24ea7ebd2fe896ea448cd8b34bbd87145a9b.tar.gz
ports-621d24ea7ebd2fe896ea448cd8b34bbd87145a9b.zip
Notes
Diffstat (limited to 'sysutils/qjail2')
-rw-r--r--sysutils/qjail2/Makefile44
-rw-r--r--sysutils/qjail2/distinfo2
-rw-r--r--sysutils/qjail2/pkg-descr25
-rw-r--r--sysutils/qjail2/pkg-message6
-rw-r--r--sysutils/qjail2/pkg-plist57
5 files changed, 134 insertions, 0 deletions
diff --git a/sysutils/qjail2/Makefile b/sysutils/qjail2/Makefile
new file mode 100644
index 000000000000..03312bc072f0
--- /dev/null
+++ b/sysutils/qjail2/Makefile
@@ -0,0 +1,44 @@
+# Created by: Joe Barbish
+# $FreeBSD$
+
+PORTNAME= qjail
+PORTVERSION= 2.2
+CATEGORIES= sysutils
+MASTER_SITES= SF/${PORTNAME}
+
+MAINTAINER= qjail@a1poweruser.com
+COMMENT= Utility to quickly deploy and manage jails
+
+USE_BZIP2= yes
+NO_BUILD= yes
+LATEST_LINK= ${PORTNAME}2
+
+MAN8= qjail.8 qjail-intro.8 qjail.conf.8 qjail-howto.8
+
+CONFLICTS_INSTALL= qjail-3.*
+
+post-patch:
+ @${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} \
+ -e 's|/usr/local|${PREFIX}|'
+ @${FIND} ${WRKSRC}/examples -name '*.bak' -delete
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/qjail ${PREFIX}/bin
+ @${INSTALL_SCRIPT} ${WRKSRC}/qjail2 ${PREFIX}/etc/rc.d
+ @${INSTALL_SCRIPT} ${WRKSRC}/qjail-jail2 ${PREFIX}/etc/rc.d
+ @${INSTALL_DATA} ${WRKSRC}/qjail.conf.sample ${PREFIX}/etc
+ @${INSTALL_DATA} ${WRKSRC}/qjail.portsnap.conf ${PREFIX}/etc
+.for i in qjail qjail-intro qjail.conf qjail-howto
+ @${INSTALL_MAN} ${WRKSRC}/${i}.8 ${MAN8PREFIX}/man/man8
+.endfor
+# note examples are mandatory. qjail will not function without them
+ @${MKDIR} ${EXAMPLESDIR}
+ @(cd ${WRKSRC}/examples/ \
+ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
+
+post-install:
+ @${ECHO_MSG} "#"
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG} "#"
+
+.include <bsd.port.mk>
diff --git a/sysutils/qjail2/distinfo b/sysutils/qjail2/distinfo
new file mode 100644
index 000000000000..af082a7c3314
--- /dev/null
+++ b/sysutils/qjail2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (qjail-2.2.tar.bz2) = ae7b64b3ecfa2b3db5880e3e7e38fc5e6f4ad8e51353d4343e37ef4c0dab1912
+SIZE (qjail-2.2.tar.bz2) = 56888
diff --git a/sysutils/qjail2/pkg-descr b/sysutils/qjail2/pkg-descr
new file mode 100644
index 000000000000..8fc2c777286e
--- /dev/null
+++ b/sysutils/qjail2/pkg-descr
@@ -0,0 +1,25 @@
+This is the last version that handles both the 8.x and 9.x install
+media formats.
+
+Qjail [ q = quick ] is a 4th generation wrapper for the basic chroot jail
+system that includes security and performance enhancements. Plus a new level
+of "user friendliness" enhancements dealing with deploying just a few jails or
+large jail environments consisting of 100's of jails.
+
+Qjail requires no knowledge of the jail command usage. It uses "nullfs" for
+read-only system binaries, sharing one copy of them with all the jails.
+
+Uses "mdconfig" to create sparse image jails. Sparse image jails provide a
+method to limit the total disk space a jail can consume, while only occupying
+the physical disk space of the sum size of the files in the image jail.
+
+Ability to assign ip address with their network device name,
+so aliases are auto created on jail start and auto removed on jail stop.
+
+Ability to create "ZONE"s of identical qjail systems, each with their own
+group of jails.
+
+Ability to designate a portion of the jail name as a group prefix so the
+command being executed will apply to only those jail names matching that prefix.
+
+WWW: http://qjail.sourceforge.net/
diff --git a/sysutils/qjail2/pkg-message b/sysutils/qjail2/pkg-message
new file mode 100644
index 000000000000..dfdfe11bb684
--- /dev/null
+++ b/sysutils/qjail2/pkg-message
@@ -0,0 +1,6 @@
+Use the qjail utility to deploy small or large numbers of jails quickly.
+
+First issue "rehash" command to enable the qjail command (if using csh).
+Then issue "man qjail-intro" to read the qjail introduction.
+After reading that do "man qjail" for the usage details.
+For the BIG PICTURE issue "man qjail-howto".
diff --git a/sysutils/qjail2/pkg-plist b/sysutils/qjail2/pkg-plist
new file mode 100644
index 000000000000..f8106ab5b8f7
--- /dev/null
+++ b/sysutils/qjail2/pkg-plist
@@ -0,0 +1,57 @@
+bin/qjail
+etc/qjail.conf.sample
+etc/qjail.portsnap.conf
+etc/rc.d/qjail-jail2
+etc/rc.d/qjail2
+%%EXAMPLESDIR%%/default/etc/make.conf
+%%EXAMPLESDIR%%/default/etc/motd
+%%EXAMPLESDIR%%/default/etc/periodic.conf
+%%EXAMPLESDIR%%/default/etc/rc.conf
+%%EXAMPLESDIR%%/default/root/.cshrc
+%%EXAMPLESDIR%%/default/usr/local/etc/sudoers
+%%EXAMPLESDIR%%/nullmailer-example/etc/mail/mailer.conf
+%%EXAMPLESDIR%%/nullmailer-example/etc/rc.conf
+%%EXAMPLESDIR%%/nullmailer-example/usr/local/etc/nullmailer/remotes
+%%EXAMPLESDIR%%/ssh-default/etc/group
+%%EXAMPLESDIR%%/ssh-default/etc/make.conf
+%%EXAMPLESDIR%%/ssh-default/etc/master.passwd
+%%EXAMPLESDIR%%/ssh-default/etc/motd
+%%EXAMPLESDIR%%/ssh-default/etc/passwd
+%%EXAMPLESDIR%%/ssh-default/etc/periodic.conf
+%%EXAMPLESDIR%%/ssh-default/etc/pwd.db
+%%EXAMPLESDIR%%/ssh-default/etc/rc.conf
+%%EXAMPLESDIR%%/ssh-default/etc/spwd.db
+%%EXAMPLESDIR%%/ssh-default/etc/ssh/sshd_config
+%%EXAMPLESDIR%%/ssh-default/root/.cshrc
+%%EXAMPLESDIR%%/ssh-default/usr/home/qjail/.cshrc
+%%EXAMPLESDIR%%/ssh-default/usr/home/qjail/.login
+%%EXAMPLESDIR%%/ssh-default/usr/home/qjail/.login_conf
+%%EXAMPLESDIR%%/ssh-default/usr/home/qjail/.mail_aliases
+%%EXAMPLESDIR%%/ssh-default/usr/home/qjail/.mailrc
+%%EXAMPLESDIR%%/ssh-default/usr/home/qjail/.profile
+%%EXAMPLESDIR%%/ssh-default/usr/home/qjail/.rhosts
+%%EXAMPLESDIR%%/ssh-default/usr/home/qjail/.shrc
+%%EXAMPLESDIR%%/ssh-default/usr/local/etc/sudoers
+@dirrm %%EXAMPLESDIR%%/ssh-default/usr/home/qjail
+@dirrm %%EXAMPLESDIR%%/ssh-default/usr/home
+@dirrm %%EXAMPLESDIR%%/ssh-default/usr/local/etc
+@dirrm %%EXAMPLESDIR%%/ssh-default/usr/local
+@dirrm %%EXAMPLESDIR%%/ssh-default/usr
+@dirrm %%EXAMPLESDIR%%/ssh-default/root
+@dirrm %%EXAMPLESDIR%%/ssh-default/etc/ssh
+@dirrm %%EXAMPLESDIR%%/ssh-default/etc
+@dirrm %%EXAMPLESDIR%%/ssh-default
+@dirrm %%EXAMPLESDIR%%/nullmailer-example/usr/local/etc/nullmailer
+@dirrm %%EXAMPLESDIR%%/nullmailer-example/usr/local/etc
+@dirrm %%EXAMPLESDIR%%/nullmailer-example/usr/local
+@dirrm %%EXAMPLESDIR%%/nullmailer-example/usr
+@dirrm %%EXAMPLESDIR%%/nullmailer-example/etc/mail
+@dirrm %%EXAMPLESDIR%%/nullmailer-example/etc
+@dirrm %%EXAMPLESDIR%%/nullmailer-example
+@dirrm %%EXAMPLESDIR%%/default/usr/local/etc
+@dirrm %%EXAMPLESDIR%%/default/usr/local
+@dirrm %%EXAMPLESDIR%%/default/usr
+@dirrm %%EXAMPLESDIR%%/default/root
+@dirrm %%EXAMPLESDIR%%/default/etc
+@dirrm %%EXAMPLESDIR%%/default
+@dirrm %%EXAMPLESDIR%%