aboutsummaryrefslogtreecommitdiff
path: root/sysutils/qjail
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2014-05-15 10:40:19 +0000
committerKurt Jaeger <pi@FreeBSD.org>2014-05-15 10:40:19 +0000
commit2a30cce248262e373a623d3ecb2eebb2b918124a (patch)
tree818238deae6b9e25776db3e863d916d485cb3c86 /sysutils/qjail
parent1e92898cab75f62a035ce41c829c929cb6631b98 (diff)
Notes
Diffstat (limited to 'sysutils/qjail')
-rw-r--r--sysutils/qjail/Makefile45
-rw-r--r--sysutils/qjail/distinfo4
-rw-r--r--sysutils/qjail/pkg-descr13
-rw-r--r--sysutils/qjail/pkg-message (renamed from sysutils/qjail/files/pkg-message.in)8
-rw-r--r--sysutils/qjail/pkg-plist8
5 files changed, 40 insertions, 38 deletions
diff --git a/sysutils/qjail/Makefile b/sysutils/qjail/Makefile
index 1491261130a1..bdf5e35a86be 100644
--- a/sysutils/qjail/Makefile
+++ b/sysutils/qjail/Makefile
@@ -2,44 +2,39 @@
# $FreeBSD$
PORTNAME= qjail
-PORTVERSION= 3.2
+PORTVERSION= 3.3
CATEGORIES= sysutils
MASTER_SITES= SF/${PORTNAME}
MAINTAINER= qjail@a1poweruser.com
COMMENT= Utility to quickly deploy and manage jails
-USE_BZIP2= yes
+USES= tar:bzip2
NO_BUILD= yes
-SUB_FILES= pkg-message
+NEED_ROOT= yes
-MAN8= qjail.8 qjail-intro.8 qjail-howto.8
-
-CONFLICTS_INSTALL= qjail-2.*
-
-NO_STAGE= yes
-post-patch:
- @${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} \
- -e 's|/usr/local|${PREFIX}|'
- @${FIND} ${WRKSRC}/examples -name '*.bak' -delete
+CONFLICTS_INSTALL= qjail-2.* qjail-3.0 qjail-3.1
do-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/qjail ${PREFIX}/bin
- @${INSTALL_SCRIPT} ${WRKSRC}/qjail.vnet.be ${PREFIX}/bin
- @${INSTALL_SCRIPT} ${WRKSRC}/qjail.vnet.ng ${PREFIX}/bin
- @${INSTALL_SCRIPT} ${WRKSRC}/qjail.bootime ${PREFIX}/etc/rc.d
- @${INSTALL_DATA} ${WRKSRC}/qjail.portsnap.conf ${PREFIX}/etc
+.for i in qjail qjail.vnet.be qjail.vnet.ng
+ ${INSTALL_SCRIPT} ${WRKSRC}/${i} ${STAGEDIR}${PREFIX}/bin
+.endfor
+ ${INSTALL_SCRIPT} ${WRKSRC}/qjail.bootime \
+ ${STAGEDIR}${PREFIX}/etc/rc.d
+ ${INSTALL_DATA} ${WRKSRC}/qjail.portsnap.conf \
+ ${STAGEDIR}${PREFIX}/etc
.for i in qjail qjail-intro qjail-howto
- @${INSTALL_MAN} ${WRKSRC}/${i}.8 ${MAN8PREFIX}/man/man8
+ ${INSTALL_MAN} ${WRKSRC}/${i}.8 ${STAGEDIR}${MAN8PREFIX}/man/man8
.endfor
+
+# @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+# ${INSTALL_DATA} ${WRKSRC}/jail-primer.html \
+# ${STAGEDIR}${DOCSDIR}
+
+
# note examples are mandatory. qjail will not function without them
- @${MKDIR} ${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
@(cd ${WRKSRC}/examples/ \
- && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
-
-# Note: Has to be done this way or package version will not contain any
-# comments added with @${ECHO_MSG} command.
-post-install:
- @${CAT} ${PKGMESSAGE}
+ && ${COPYTREE_SHARE} \* ${STAGEDIR}${EXAMPLESDIR})
.include <bsd.port.mk>
diff --git a/sysutils/qjail/distinfo b/sysutils/qjail/distinfo
index 89c193aa8237..59140a821943 100644
--- a/sysutils/qjail/distinfo
+++ b/sysutils/qjail/distinfo
@@ -1,2 +1,2 @@
-SHA256 (qjail-3.2.tar.bz2) = 3088c1946e720ddc3fb6f78254f8616951de3a90f0e6e0dfbd4d49c16febe697
-SIZE (qjail-3.2.tar.bz2) = 121560
+SHA256 (qjail-3.3.tar.bz2) = 263bf7ff60a2d266ff3a4b39c1ccaf6a1114e22128fa0110351bc6c5d782c525
+SIZE (qjail-3.3.tar.bz2) = 61485
diff --git a/sysutils/qjail/pkg-descr b/sysutils/qjail/pkg-descr
index 479ada61e5a6..0a72113407a3 100644
--- a/sysutils/qjail/pkg-descr
+++ b/sysutils/qjail/pkg-descr
@@ -1,16 +1,17 @@
Qjail [ q = quick ] is a 4th generation wrapper for the basic chroot jail
system that includes security and performance enhancements. Plus a new level
of "user friendliness" enhancements dealing with deploying just a few jails or
-large jail environments consisting of 100's of jails.
+large scale jail environments consisting of 100's of jails.
This version of qjail has been converted from using the legacy rc.d-method as
used in all previous versions of qjail, to using the jail(8) jail.conf-method
-available in RELEASE-9.1. This upgrade provides the ability to enable the
-following new options on a per-jail basis. exec.fib, allow.raw_sockets,
-allow.quotas, allow.mount.nullfs, allow.mount.zfs, cpuset.id, securelevel,
+available in RELEASE-9.1 which contained many bugs, some that were fixed in
+RELEASE-9.2 and others fixed in RELEASE-10.0. This upgrade provides the ability
+to enable the following new options on a per-jail basis. exec.fib, securelevel,
+allow.raw_sockets, allow.quotas, allow.mount.nullfs, allow.mount.zfs, cpuset.id,
vnet.interface, and vnet. The vnet option gives a jail its own network stack
-using the experimental vimage software. This qjail version is not functional
-for RELEASES older than RELEASE-9.1. The vnet option has only been tested on
+using the experimental vimage software. This qjail version is not intended
+for RELEASES older than RELEASE-10.0. The vnet option has only been tested on
i386 and amd64 equipment.
Qjail requires no knowledge of the jail command usage. It uses "nullfs" for
diff --git a/sysutils/qjail/files/pkg-message.in b/sysutils/qjail/pkg-message
index 71a42e4cc3f5..db65419d9c5a 100644
--- a/sysutils/qjail/files/pkg-message.in
+++ b/sysutils/qjail/pkg-message
@@ -10,9 +10,13 @@ For the BIG PICTURE issue "man qjail-howto".
########################################################################
+If your host is running 10.0-RELEASE be sure you apply system security
+update. You need to be at 10.0-RELEASE-p2. Run the following commands
+to apply system security updates.
+ freebsd-update fetch
+ freebsd-update install
-For instructions on upgrading jail filesystems
-Read %%EXAMPLESDIR%%/upgrade-info.txt
+########################################################################
diff --git a/sysutils/qjail/pkg-plist b/sysutils/qjail/pkg-plist
index ba6ad4adc035..7d539043a69c 100644
--- a/sysutils/qjail/pkg-plist
+++ b/sysutils/qjail/pkg-plist
@@ -3,9 +3,9 @@ bin/qjail.vnet.be
bin/qjail.vnet.ng
etc/qjail.portsnap.conf
etc/rc.d/qjail.bootime
-%%EXAMPLESDIR%%/upgrade-info.txt
-%%EXAMPLESDIR%%/vnet/jail.amd64
-%%EXAMPLESDIR%%/vnet/jail.i386
+man/man8/qjail.8.gz
+man/man8/qjail-intro.8.gz
+man/man8/qjail-howto.8.gz
%%EXAMPLESDIR%%/vnet/ipfw.rules.host
%%EXAMPLESDIR%%/vnet/ipfw.rules.vnet
%%EXAMPLESDIR%%/vnet/ipf.rules.host
@@ -17,6 +17,7 @@ etc/rc.d/qjail.bootime
%%EXAMPLESDIR%%/default/etc/periodic.conf
%%EXAMPLESDIR%%/default/etc/rc.conf
%%EXAMPLESDIR%%/default/root/.cshrc
+%%EXAMPLESDIR%%/default/usr/local/etc/pkg.conf
%%EXAMPLESDIR%%/default/usr/local/etc/sudoers
%%EXAMPLESDIR%%/ssh-default/etc/group
%%EXAMPLESDIR%%/ssh-default/etc/make.conf
@@ -37,6 +38,7 @@ etc/rc.d/qjail.bootime
%%EXAMPLESDIR%%/ssh-default/usr/home/qjail/.profile
%%EXAMPLESDIR%%/ssh-default/usr/home/qjail/.rhosts
%%EXAMPLESDIR%%/ssh-default/usr/home/qjail/.shrc
+%%EXAMPLESDIR%%/ssh-default/usr/local/etc/pkg.conf
%%EXAMPLESDIR%%/ssh-default/usr/local/etc/sudoers
@dirrm %%EXAMPLESDIR%%/default/usr/local/etc
@dirrm %%EXAMPLESDIR%%/default/usr/local