aboutsummaryrefslogtreecommitdiff
path: root/sysutils/qt5-qtplugininfo
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-06-21 18:07:19 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2017-06-21 18:07:19 +0000
commitd02de8e9403e26403a872afe9d2601a0404fd1c1 (patch)
treec9a86b3af6f6a86761a1f2a37061dc739f689680 /sysutils/qt5-qtplugininfo
parentead1b1cea1ff7bc59ac1f417e075f8160db85ec2 (diff)
downloadports-d02de8e9403e26403a872afe9d2601a0404fd1c1.tar.gz
ports-d02de8e9403e26403a872afe9d2601a0404fd1c1.zip
Add two new ports: sysutils/qt5-qtdiag and sysutils/qt5-qtplugininfo
* qtdiag outputs diagnostics on the current Qt installation and can be helpful to find issues. * qtpluginfo is useful while writing plugins for Qt5/KDE Plasma Reviewed by: rakuco, mat Differential Revision: https://reviews.freebsd.org/D11280
Notes
Notes: svn path=/head/; revision=444046
Diffstat (limited to 'sysutils/qt5-qtplugininfo')
-rw-r--r--sysutils/qt5-qtplugininfo/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/sysutils/qt5-qtplugininfo/Makefile b/sysutils/qt5-qtplugininfo/Makefile
new file mode 100644
index 000000000000..fc0dece6c193
--- /dev/null
+++ b/sysutils/qt5-qtplugininfo/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= qtplugininfo
+DISTVERSION= ${QT5_VERSION}
+CATEGORIES= sysutils
+PKGNAMEPREFIX= qt5-
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Qt5 plugin metadata dumper
+
+USES= qmake:outsource
+USE_QT5= core
+QT_DIST= tools
+
+PLIST_FILES= ${QT_BINDIR}/qtplugininfo
+
+# Similarly to x11/qt5-qev, it makes more sense to just run the build system
+# from the qtplugininfo directory. If we run it from the top of the source tree, it
+# will look for a lot more dependencies for other tools such as lupdate, which
+# we do not really have to depend on.
+WRKSRC_SUBDIR= src/${PORTNAME}
+
+post-patch:
+ ${CP} ${WRKSRC}/../../.qmake.conf ${WRKSRC}
+
+.include <bsd.port.mk>