aboutsummaryrefslogtreecommitdiff
path: root/sysutils/racktables
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-10-19 14:50:52 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-10-19 14:50:52 +0000
commit67971bd0fb8a440f973d12606b0f496ba216d7df (patch)
tree72fd93ae39b43490b34dc8479465e07b453d126e /sysutils/racktables
parentf13c234d6c664c916b5c0d0e6f089d8ef0c93d55 (diff)
downloadports-67971bd0fb8a440f973d12606b0f496ba216d7df.tar.gz
ports-67971bd0fb8a440f973d12606b0f496ba216d7df.zip
Improve shebangfix framework
- Support multiple values in *_OLD_CMD, i.e. we can now fix both "/usr/bin/python" and "/usr/bin/env python" at the same time - Default *_OLD_CMD values are now always appended, so you don't need to specify them in individual ports - Add lua support (depends on USES=lua) - Add more default values, such as "/usr/bin/env foo" for python, perl, bash, ruby and lua - Shebangfix now matches whole words, e.g. we will no longer (erroneously) replace "/usr/bin/perl5.005" with "${perl_CMD}5.005" (but "/usr/bin/perl -tt" is still (correctly) replaced with "${perl_CMD} -tt") Note that *_OLD_CMD items containing spaces must now be quoted (e.g. perl_OLD_CMD=/bin/perl /usr/bin/perl "/usr/bin/env perl") Update shebangfix usage according to new rules in many ports: - Remove *_OLD_CMD for patterns now replaced by default - Quote custom *_OLD_CMD which contain spaces Fix shebangfix usage in many ports (irrelevant to infrastructure change): - Remove redundant SHEBANG_LANG (no need to duplicate default langs) - Remove redundant *_CMD (such as python_CMD=${LOCALBASE}/bin/python${PYTHON_VER} when USES=python is present) - Never use *_OLD_CMD in REINPLACE_CMD matchers, these should always look for exact string Approved by: portmgr (bapt) Differential Revision: D3756
Notes
Notes: svn path=/head/; revision=399684
Diffstat (limited to 'sysutils/racktables')
-rw-r--r--sysutils/racktables/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/sysutils/racktables/Makefile b/sysutils/racktables/Makefile
index 1f92173d4264..80e1c026201f 100644
--- a/sysutils/racktables/Makefile
+++ b/sysutils/racktables/Makefile
@@ -3,7 +3,7 @@
PORTNAME= racktables
DISTVERSION= 0.20.10
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES?= sysutils www
MASTER_SITES= SF/${PORTNAME}/
DISTNAME= RackTables-${DISTVERSION}
@@ -18,10 +18,9 @@ RACKHOME?= www/racktables
PORTEXAMPLES= init-sample-racks.sql syncdomain.php
-USES= shebangfix
+USES= shebangfix perl5 python:run
+USE_PERL5= run
SHEBANG_FILES= gateways/*
-python_OLD_CMD= ${SETENV} python
-python_CMD= ${LOCALBASE}/bin/python2.7
WANT_PHP_WEB= yes
USE_PHP= bcmath gd json mbstring mysql pdo_mysql session