aboutsummaryrefslogtreecommitdiff
path: root/sysutils/rdup
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2016-04-17 21:48:22 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2016-04-17 21:48:22 +0000
commit13fa965ee490252b1c9ecf93e41c683df0e34b3b (patch)
tree24669dccbc4c4fb3fbeb7d1551f74eb80b05ef13 /sysutils/rdup
parent5d35098c0d800fdc030a652baccadbb53ce569e4 (diff)
downloadports-13fa965ee490252b1c9ecf93e41c683df0e34b3b.tar.gz
ports-13fa965ee490252b1c9ecf93e41c683df0e34b3b.zip
sysutils/rdup: update to 1.1.15
Notes
Notes: svn path=/head/; revision=413543
Diffstat (limited to 'sysutils/rdup')
-rw-r--r--sysutils/rdup/Makefile13
-rw-r--r--sysutils/rdup/distinfo4
-rw-r--r--sysutils/rdup/files/patch-GNUmakefile.in21
-rw-r--r--sysutils/rdup/files/patch-rdup-simple28
-rw-r--r--sysutils/rdup/pkg-descr2
5 files changed, 29 insertions, 39 deletions
diff --git a/sysutils/rdup/Makefile b/sysutils/rdup/Makefile
index 56fabf08fcca..d7cc4a389b4b 100644
--- a/sysutils/rdup/Makefile
+++ b/sysutils/rdup/Makefile
@@ -2,22 +2,25 @@
# $FreeBSD$
PORTNAME= rdup
-PORTVERSION= 1.1.14
-PORTREVISION= 3
+PORTVERSION= 1.1.15
CATEGORIES= sysutils
-MASTER_SITES= http://archive.miek.nl/projects/rdup/
+MASTER_SITES= https://github.com/miekg/rdup/archive/
+DISTNAME= ${PORTVERSION}
+DIST_SUBDIR= ${PORTNAME}
MAINTAINER= rm@FreeBSD.org
COMMENT= Tool to generate (incremental) backup file list
LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libglib-2.0.so:devel/glib20 \
libpcre.so:devel/pcre \
libnettle.so:security/nettle
-USES= gmake libarchive pkgconfig tar:bzip2
-USE_AUTOTOOLS= autoconf
+USES= autoreconf gmake libarchive pkgconfig
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
MAKEFILE= GNUmakefile
.include <bsd.port.mk>
diff --git a/sysutils/rdup/distinfo b/sysutils/rdup/distinfo
index 0a520e1f3005..fe6ba0bd4125 100644
--- a/sysutils/rdup/distinfo
+++ b/sysutils/rdup/distinfo
@@ -1,2 +1,2 @@
-SHA256 (rdup-1.1.14.tar.bz2) = b25e2b0656d2e6a9cb97a37f493913c4156468d4c21cea15a9a0c7b353e3742a
-SIZE (rdup-1.1.14.tar.bz2) = 363183
+SHA256 (rdup/1.1.15.tar.gz) = 787b8c37e88be810a710210a9d9f6966b544b1389a738aadba3903c71e0c29cb
+SIZE (rdup/1.1.15.tar.gz) = 333646
diff --git a/sysutils/rdup/files/patch-GNUmakefile.in b/sysutils/rdup/files/patch-GNUmakefile.in
index 909ab1f97e41..8419ed156aaf 100644
--- a/sysutils/rdup/files/patch-GNUmakefile.in
+++ b/sysutils/rdup/files/patch-GNUmakefile.in
@@ -1,6 +1,6 @@
---- GNUmakefile.in.orig 2013-01-20 00:33:20.000000000 -0800
-+++ GNUmakefile.in 2013-03-23 10:00:18.000000000 -0700
-@@ -19,7 +19,7 @@
+--- GNUmakefile.in.orig 2016-03-02 15:39:44 UTC
++++ GNUmakefile.in
+@@ -19,7 +19,7 @@ libdir=@libdir@
sbindir=@sbindir@
mandir=@mandir@
sysconfdir=@sysconfdir@
@@ -9,7 +9,7 @@
ARCHIVE_L=@ARCHIVE_L@
NETTLE_L=@NETTLE_L@
-@@ -28,7 +28,7 @@
+@@ -28,7 +28,7 @@ GLIB_CFLAGS=@GLIB_CFLAGS@
GLIB_LIBS=@GLIB_LIBS@
LIBS=@LIBS@
DEBUG=@DEBUG@
@@ -18,16 +18,3 @@
INSTALL=./install-sh -c
INSTALL_DATA=$(INSTALL) -m 644
-@@ -56,10 +56,10 @@
- ${GCC} ${OBJ} ${GLIB_LIBS} ${LDFLAGS} ${LIBS} -o rdup
-
- ifeq (${ARCHIVE_L},no)
--strip:
-+strip: rdup rdup-up
- strip rdup rdup-up
- else
--strip:
-+strip: rdup rdup-tr rdup-up
- strip rdup rdup-tr rdup-up
- endif
-
diff --git a/sysutils/rdup/files/patch-rdup-simple b/sysutils/rdup/files/patch-rdup-simple
index 30e5e097de16..c55af7347a51 100644
--- a/sysutils/rdup/files/patch-rdup-simple
+++ b/sysutils/rdup/files/patch-rdup-simple
@@ -1,12 +1,12 @@
---- rdup-simple.orig 2010-06-21 05:17:06.000000000 -0700
-+++ rdup-simple 2010-06-27 17:05:46.000000000 -0700
+--- rdup-simple.orig 2016-03-02 15:39:44 UTC
++++ rdup-simple
@@ -1,4 +1,4 @@
-#!/bin/bash
+#!/bin/sh
# updates a hardlinked backup
# licensed under the GPL version 3
-@@ -38,16 +38,17 @@
+@@ -38,16 +38,17 @@ copy_and_link() {
exit 2
fi
@@ -28,7 +28,7 @@
done
exit 1
}
-@@ -121,7 +122,7 @@
+@@ -122,7 +123,7 @@ while getopts "aE:k:vfgzxhVX:Y:s:Lnq" o;
exit 1
fi
if [ ! -r "$OPTARG" ]; then
@@ -36,8 +36,8 @@
+ echo2 "Cannot read keyfile \'$OPTARG': failed"
exit 1
fi
- trans="$trans -Pmcrypt,-q,-f,$OPTARG"
-@@ -163,9 +164,9 @@
+ trans="$trans -P 'mcrypt -q -f $OPTARG'"
+@@ -165,9 +166,9 @@ while getopts "aE:k:vfgzxhVX:Y:s:Lnq" o;
done
shift $((OPTIND - 1))
@@ -50,7 +50,7 @@
echo2 "+N needs to be a number [1..99]"
exit 1
fi
-@@ -187,7 +188,7 @@
+@@ -189,7 +190,7 @@ i=1; last=$#; DIRS=
while [ $i -lt $last ]; do
DIRS="$DIRS $1"
shift
@@ -59,7 +59,7 @@
done
# rdup [options] source destination
#dest="ssh://elektron.atoom.net/directory"
-@@ -197,8 +198,8 @@
+@@ -199,8 +200,8 @@ done
#dest="ssh://miekg@elektron.atoom.net/directory"
dest=$1
@@ -70,7 +70,7 @@
u=${rest%%@*}
if [ "$u" = "$rest" ]; then
-@@ -206,9 +207,9 @@
+@@ -208,9 +209,9 @@ if [ ${dest:0:6} = "ssh://" ]; then
u=
fi
@@ -81,9 +81,9 @@
+ BACKUPDIR=${rest#$h}
if [ -z "$u" ]; then
- ssh=" ssh -c blowfish -x $h"
-@@ -216,11 +217,11 @@
- ssh=" ssh -c blowfish -x $u@$h"
+ ssh=" ssh -x $h"
+@@ -218,11 +219,11 @@ if [ ${dest:0:6} = "ssh://" ]; then
+ ssh=" ssh -x $u@$h"
fi
fi
-if [ ${dest:0:7} = "file://" ]; then
@@ -97,7 +97,7 @@
# no hits above, assume relative filename
[ -z "$BACKUPDIR" ] && BACKUPDIR=$PWD/$dest
-@@ -228,8 +229,8 @@
+@@ -230,8 +231,8 @@ fi
$link && copy_and_link $DAYS $BACKUPDIR
# change all / to _ to make a valid filename
@@ -108,7 +108,7 @@
[ ! -d $etc ] && mkdir $etc
-@@ -250,6 +251,7 @@
+@@ -252,6 +253,7 @@ if ! $force; then
# path is set at the top
if [ -z "$ssh" ]; then
$PROGNAME $OPT_DRY -L +$DAYS /dev/null $BACKUPDIR
diff --git a/sysutils/rdup/pkg-descr b/sysutils/rdup/pkg-descr
index 66d37e588b7b..b76595267bd7 100644
--- a/sysutils/rdup/pkg-descr
+++ b/sysutils/rdup/pkg-descr
@@ -7,4 +7,4 @@ that are removed, allowing for correct incremental backups.
An example script named rdup-simple is included to show how to implement
a simple snapshot-style backup strategy.
-WWW: http://archive.miek.nl/projects/rdup/index.html
+WWW: https://github.com/miekg/rdup