aboutsummaryrefslogtreecommitdiff
path: root/sysutils/reed
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2012-11-04 16:59:46 +0000
committerChris Rees <crees@FreeBSD.org>2012-11-04 16:59:46 +0000
commit597625be425452bc569669039993b7b2731e7835 (patch)
treea6ecb057395072d5829f1a4f55a1113cc0e28853 /sysutils/reed
parentcb2f53a51a66a369fe646b9f14edd08a589ca1b3 (diff)
downloadports-597625be425452bc569669039993b7b2731e7835.tar.gz
ports-597625be425452bc569669039993b7b2731e7835.zip
Revive sysutils/reed, and take on role as upstream
Feature safe: yes
Notes
Notes: svn path=/head/; revision=306975
Diffstat (limited to 'sysutils/reed')
-rw-r--r--sysutils/reed/Makefile38
-rw-r--r--sysutils/reed/distinfo2
-rw-r--r--sysutils/reed/pkg-descr5
-rw-r--r--sysutils/reed/pkg-plist5
4 files changed, 50 insertions, 0 deletions
diff --git a/sysutils/reed/Makefile b/sysutils/reed/Makefile
new file mode 100644
index 000000000000..6826f61b7da3
--- /dev/null
+++ b/sysutils/reed/Makefile
@@ -0,0 +1,38 @@
+# Created by: Pete Fritchman <petef@databits.net>
+# $FreeBSD$
+
+PORTNAME= reed
+PORTVERSION= 5.4
+PORTREVISION= 1
+CATEGORIES= sysutils
+MASTER_SITES= http://www.bayofrum.net/dist/${PORTNAME}
+
+MAINTAINER= crees@FreeBSD.org
+COMMENT= A text pager with autoscrolling and more
+
+USE_PERL5= yes
+HAS_CONFIGURE= yes
+CONFIGURE_SCRIPT= configures
+
+MAN1= breed.1 reed.1 wrap.1
+
+post-patch:
+ @${PERL} -pi -e 's!/usr/local!${PREFIX}!g' ${WRKSRC}/configures
+ @${PERL} -pi -e 's!sys/dir.h!dirent.h!g;s!.*getopt.h.*\n!!' \
+ ${WRKSRC}/reed.c
+ @${PERL} -pi -e 's!getopt.h !!' ${WRKSRC}/cfg.data
+ @${PERL} -pi -e 's!-O2!${CFLAGS}!' ${WRKSRC}/Makefile.in
+ @${PERL} -pi -e 's!^#!/usr/bin/perl!#!${PERL}!' \
+ ${WRKSRC}/fix_bookmarks.pl
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/reed ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/breed ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/wrap ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/fix_bookmarks.pl ${DATADIR}
+.for file in ${MAN1}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${file} ${PREFIX}/man/man1
+.endfor
+
+.include <bsd.port.mk>
diff --git a/sysutils/reed/distinfo b/sysutils/reed/distinfo
new file mode 100644
index 000000000000..7761f0448e61
--- /dev/null
+++ b/sysutils/reed/distinfo
@@ -0,0 +1,2 @@
+SHA256 (reed-5.4.tar.gz) = 226a057aa5db705e83b685207d635d0d3b983999f1e526e0768aa56b0e7c02a8
+SIZE (reed-5.4.tar.gz) = 32414
diff --git a/sysutils/reed/pkg-descr b/sysutils/reed/pkg-descr
new file mode 100644
index 000000000000..d9088755d84c
--- /dev/null
+++ b/sysutils/reed/pkg-descr
@@ -0,0 +1,5 @@
+reed is a text pager for reading large files, such as full books
+(usually etexts from Project Gutenberg). It has the features one
+would expect for a pager (multiple buffers, searching, file
+information, subshells, etc) and more: persistent bookmarks, auto
+scrolling, and support for many different types of files.
diff --git a/sysutils/reed/pkg-plist b/sysutils/reed/pkg-plist
new file mode 100644
index 000000000000..fadfb8e54c06
--- /dev/null
+++ b/sysutils/reed/pkg-plist
@@ -0,0 +1,5 @@
+bin/breed
+bin/reed
+bin/wrap
+share/reed/fix_bookmarks.pl
+@dirrm share/reed