aboutsummaryrefslogtreecommitdiff
path: root/sysutils/replicant
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2013-05-22 21:33:24 +0000
committerMatthias Andree <mandree@FreeBSD.org>2013-05-22 21:33:24 +0000
commit6a93a338d7bdc290cf9329380c9f0216f098c238 (patch)
tree7cea0b3f1c63b4679974cef888d9ab5c085c404f /sysutils/replicant
parent8648240d94f69e48fcf06290e4256f8764bf59b9 (diff)
downloadports-6a93a338d7bdc290cf9329380c9f0216f098c238.tar.gz
ports-6a93a338d7bdc290cf9329380c9f0216f098c238.zip
Notes
Diffstat (limited to 'sysutils/replicant')
-rw-r--r--sysutils/replicant/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/sysutils/replicant/Makefile b/sysutils/replicant/Makefile
index b780ef10eab5..aa3498c63479 100644
--- a/sysutils/replicant/Makefile
+++ b/sysutils/replicant/Makefile
@@ -19,16 +19,20 @@ LIB_DEPENDS= busybee:${PORTSDIR}/devel/busybee \
ONLY_FOR_ARCHS= amd64
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CONFIGURE_ARGS= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+# The -D-efines and -include beat the code into shape on GCC 4.7/4.8
+# GCC 4.6 from ports and 9.1's base clang are fine,
+# upstream bug report at <https://github.com/rescrv/po6/issues/5>
+# This hack causes harmless "warning: '__STDC_LIMIT_MACROS' macro redefined"
+CPPFLAGS+= -D__STDC_LIMIT_MACROS -Du_int32_t=uint32_t \
+ -include stdint.h -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
USES= pathfix pkgconfig
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 90014 || !exists(clang++)
-# newer GCC versions than 4.6 do not work; clang 3.1 seems fine;
-# bug report to upstream at: <https://github.com/rescrv/po6/issues/5>
-USE_GCC= 4.6
+.if ${OSVERSION} < 900014 || !exists(/usr/bin/clang++)
+# No clang++ installed, use GCC from ports:
+USE_GCC= yes
.else
CC= clang
CXX= clang++