aboutsummaryrefslogtreecommitdiff
path: root/sysutils/restic
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2015-09-24 16:29:48 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2015-09-24 16:29:48 +0000
commit3fc35ba47f61352a63af95384458a7a4d14c633f (patch)
tree6d1f40b88d4633d336c7abe190e17b6c7bfef60a /sysutils/restic
parenta76e244dc20754ee8531e8bd351f846851c53126 (diff)
downloadports-3fc35ba47f61352a63af95384458a7a4d14c633f.tar.gz
ports-3fc35ba47f61352a63af95384458a7a4d14c633f.zip
sysutils/restic build properly
Notes
Notes: svn path=/head/; revision=397697
Diffstat (limited to 'sysutils/restic')
-rw-r--r--sysutils/restic/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/sysutils/restic/Makefile b/sysutils/restic/Makefile
index 00d8588414a8..638763cfe599 100644
--- a/sysutils/restic/Makefile
+++ b/sysutils/restic/Makefile
@@ -2,6 +2,7 @@
PORTNAME= restic
PORTVERSION= 0.1.0
+PORTREVISION= 1
DISTVERSIONPREFIX= v
CATEGORIES= sysutils
@@ -30,9 +31,9 @@ post-extract:
@${MV} ${WRKSRC_crypto} ${WRKSRC}/src/golang.org/x/crypto
do-build:
- @cd ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME}; ${SETENV} GOPATH=${WRKSRC} go build -o bin/${PORTNAME}
+ @cd ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME}; ${SETENV} GOPATH=${WRKSRC} go run build.go
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
.include <bsd.port.mk>