aboutsummaryrefslogtreecommitdiff
path: root/sysutils/retail
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2020-09-26 12:54:58 +0000
committerStefan Eßer <se@FreeBSD.org>2020-09-26 12:54:58 +0000
commit06412f62ef54b37ae5a05a9f002a14a1d235b124 (patch)
tree42b84c2045000bfc931397724ae6927d9574b237 /sysutils/retail
parenta69a6ecc266380a409e4829673f590d9a67b188f (diff)
downloadports-06412f62ef54b37ae5a05a9f002a14a1d235b124.tar.gz
ports-06412f62ef54b37ae5a05a9f002a14a1d235b124.zip
Fix build with -fno-common
Notes
Notes: svn path=/head/; revision=550177
Diffstat (limited to 'sysutils/retail')
-rw-r--r--sysutils/retail/Makefile1
-rw-r--r--sysutils/retail/files/patch-Makefile.in15
-rw-r--r--sysutils/retail/files/patch-src_getopt.c13
-rw-r--r--sysutils/retail/files/patch-src_main.c11
-rw-r--r--sysutils/retail/files/patch-src_open__files.c13
-rw-r--r--sysutils/retail/files/patch-src_read__files.c11
-rw-r--r--sysutils/retail/files/patch-src_retail.h37
7 files changed, 93 insertions, 8 deletions
diff --git a/sysutils/retail/Makefile b/sysutils/retail/Makefile
index e803caed3ef3..488c2cc346e5 100644
--- a/sysutils/retail/Makefile
+++ b/sysutils/retail/Makefile
@@ -3,6 +3,7 @@
PORTNAME= retail
PORTVERSION= 1.0.1
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://xjack.org/retail/download/ \
http://www.bsdstore.ru/downloads/
diff --git a/sysutils/retail/files/patch-Makefile.in b/sysutils/retail/files/patch-Makefile.in
index e21a30296ed5..4297513fdd0c 100644
--- a/sysutils/retail/files/patch-Makefile.in
+++ b/sysutils/retail/files/patch-Makefile.in
@@ -1,12 +1,11 @@
---- Makefile.in-orig 2010-05-23 01:04:54.000000000 +0400
-+++ Makefile.in 2010-05-23 01:05:04.000000000 +0400
-@@ -1,6 +1,8 @@
+--- Makefile.in.orig 2003-04-04 20:41:30 UTC
++++ Makefile.in
+@@ -3,6 +3,8 @@ DESTDIR =
default:
- cd src ; make
-
+ cd src ; make
+
+all: default
+
clean:
- cd src ; make clean
- rm -f *~
-
+ cd src ; make clean
+ rm -f *~
diff --git a/sysutils/retail/files/patch-src_getopt.c b/sysutils/retail/files/patch-src_getopt.c
new file mode 100644
index 000000000000..e59649734264
--- /dev/null
+++ b/sysutils/retail/files/patch-src_getopt.c
@@ -0,0 +1,13 @@
+--- src/getopt.c.orig 2003-03-18 18:24:14 UTC
++++ src/getopt.c
+@@ -21,6 +21,10 @@
+ /* Yee ole includes (I put this all in one file for my sanity) */
+ #include "include.h"
+
++short int debug; /* do we go into debug mode? (developer test only */
++char *suffix; /* suffix of the file we open to store stats in */
++char *prefix; /* prefix directory for where we put stats files */
++
+ /* our 'print usage to user' function */
+ void proc_args_usage(char *myname) {
+ fprintf(stderr, "retail v %s\n", VERSION);
diff --git a/sysutils/retail/files/patch-src_main.c b/sysutils/retail/files/patch-src_main.c
new file mode 100644
index 000000000000..394c04245c65
--- /dev/null
+++ b/sysutils/retail/files/patch-src_main.c
@@ -0,0 +1,11 @@
+--- src/main.c.orig 2003-03-18 17:48:18 UTC
++++ src/main.c
+@@ -21,6 +21,8 @@
+ /* Yee ole includes (I put this all in one file for my sanity) */
+ #include "include.h"
+
++short int retval; /* what value do we return at the end of all this */
++char **files; /* an array of all the file's we'll be opening */
+
+ int main(int argc, char **argv) {
+ long int i;
diff --git a/sysutils/retail/files/patch-src_open__files.c b/sysutils/retail/files/patch-src_open__files.c
new file mode 100644
index 000000000000..ae241887d513
--- /dev/null
+++ b/sysutils/retail/files/patch-src_open__files.c
@@ -0,0 +1,13 @@
+--- src/open_files.c.orig 2003-03-18 17:48:22 UTC
++++ src/open_files.c
+@@ -21,6 +21,10 @@
+ /* Yee ole includes (I put this all in one file for my sanity) */
+ #include "include.h"
+
++FILE *in_file; /* the files we'll be reading for input */
++FILE *in_stat; /* the file we're using to store our place in in_file */
++char *st_filename; /* the var we store the name of the offset file */
++
+ int open_infile(char *fname) {
+ /* open our input file read only */
+ in_file = fopen(fname, "r");
diff --git a/sysutils/retail/files/patch-src_read__files.c b/sysutils/retail/files/patch-src_read__files.c
new file mode 100644
index 000000000000..466d9f69bea6
--- /dev/null
+++ b/sysutils/retail/files/patch-src_read__files.c
@@ -0,0 +1,11 @@
+--- src/read_files.c.orig 2003-03-18 17:48:28 UTC
++++ src/read_files.c
+@@ -21,6 +21,8 @@
+ /* Yee ole includes (I put this all in one file for my sanity) */
+ #include "include.h"
+
++FILE_STAT f;
++
+ int read_infile_llcheck() {
+ long int i;
+ short int found = 0;
diff --git a/sysutils/retail/files/patch-src_retail.h b/sysutils/retail/files/patch-src_retail.h
new file mode 100644
index 000000000000..3196819ef457
--- /dev/null
+++ b/sysutils/retail/files/patch-src_retail.h
@@ -0,0 +1,37 @@
+--- src/retail.h.orig 2003-03-18 17:48:46 UTC
++++ src/retail.h
+@@ -19,16 +19,16 @@
+ */
+
+ /* global variables */
+-short int retval; /* what value do we return at the end of all this */
+-short int debug; /* do we go into debug mode? (developer test only */
+-FILE *in_file; /* the files we'll be reading for input */
+-FILE *in_stat; /* the file we're using to store our place in in_file */
+-char *st_filename; /* the var we store the name of the offset file */
+-
+-char **files; /* an array of all the file's we'll be opening */
+-char *suffix; /* suffix of the file we open to store stats in */
+-char *prefix; /* prefix directory for where we put stats files */
++extern short int retval; /* what value do we return at the end of all this */
++extern short int debug; /* do we go into debug mode? (developer test only */
++extern FILE *in_file; /* the files we'll be reading for input */
++extern FILE *in_stat; /* the file we're using to store our place in in_file */
++extern char *st_filename; /* the var we store the name of the offset file */
+
++extern char **files; /* an array of all the file's we'll be opening */
++extern char *suffix; /* suffix of the file we open to store stats in */
++extern char *prefix; /* prefix directory for where we put stats files */
++
+ /* structure for our info on the file */
+ typedef struct {
+ long int ipos; /* last position as an int */
+@@ -36,7 +36,7 @@ typedef struct {
+ char *last_line; /* last known line in the file */
+ } FILE_STAT;
+
+-FILE_STAT f;
++extern FILE_STAT f;
+
+ /* our local functions */
+ int proc_args(int argc, char **argv);