aboutsummaryrefslogtreecommitdiff
path: root/sysutils/riak-cs
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2015-11-06 11:56:18 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2015-11-06 11:56:18 +0000
commite3e072050906e8453bedc11f502b4f03d484a64d (patch)
treea8c8ffdfdf9ac7e83a0f9eaf546ae538014372e0 /sysutils/riak-cs
parentcab28dac85e189f6c9d9a8e1e44262417a5082b6 (diff)
downloadports-e3e072050906e8453bedc11f502b4f03d484a64d.tar.gz
ports-e3e072050906e8453bedc11f502b4f03d484a64d.zip
sysutils/riak-cs: fix shebangs and configs
- Fix shebangs - Fix config giles, @sample is used incorrectly - Add LICENSE_FILE - Remove needless @dir PR: 204324 Submitted by: amdmi3
Notes
Notes: svn path=/head/; revision=400924
Diffstat (limited to 'sysutils/riak-cs')
-rw-r--r--sysutils/riak-cs/Makefile17
-rw-r--r--sysutils/riak-cs/pkg-plist9
2 files changed, 15 insertions, 11 deletions
diff --git a/sysutils/riak-cs/Makefile b/sysutils/riak-cs/Makefile
index 6b9bad34d7a2..7049c4e7a80a 100644
--- a/sysutils/riak-cs/Makefile
+++ b/sysutils/riak-cs/Makefile
@@ -2,18 +2,23 @@
PORTNAME= riak-cs
PORTVERSION= 2.1.0
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://s3.amazonaws.com/downloads.basho.com/riak-cs/${PORTVERSION:R}/${PORTVERSION}/ \
- http://downloads.basho.com.s3.amazonaws.com/riak-cs/${PORTVERSION:R}/${PORTVERSION}/
+ http://downloads.basho.com.s3.amazonaws.com/riak-cs/${PORTVERSION:R}/${PORTVERSION}/
MAINTAINER= wg@FreeBSD.org
COMMENT= Open source, distributed, S3 interface to Riak KV
LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${LOCALBASE}/lib/riak-erlang/bin/erlc:${PORTSDIR}/lang/erlang-riak
-USES= gmake readline
+USES= gmake readline shebangfix
+SHEBANG_FILES= deps/eper/priv/bin/dtop \
+ deps/eper/priv/bin/ntop \
+ deps/eper/priv/bin/redbug
USE_RC_SUBR= riak-cs
USERS= riakcs
@@ -44,10 +49,10 @@ do-install:
${MKDIR} ${STAGEDIR}${RIAKCS_CONFDIR}
${MKDIR} ${STAGEDIR}${RIAKCS_DBDIR}
${MKDIR} ${STAGEDIR}${RIAKCS_LOGDIR}
- ${INSTALL_DATA} ${WRKSRC}/rel/riak-cs/etc/riak-cs.conf ${STAGEDIR}${RIAKCS_CONFDIR}/riak-cs.conf
- ${INSTALL_DATA} ${WRKSRC}/rel/riak-cs/etc/advanced.config ${STAGEDIR}${RIAKCS_CONFDIR}/advanced.config
- ${INSTALL_DATA} ${WRKSRC}/rel/riak-cs/etc/cert.pem ${STAGEDIR}${RIAKCS_CONFDIR}/cert.pem
- ${INSTALL_DATA} ${WRKSRC}/rel/riak-cs/etc/key.pem ${STAGEDIR}${RIAKCS_CONFDIR}/key.pem
+ ${INSTALL_DATA} ${WRKSRC}/rel/riak-cs/etc/riak-cs.conf ${STAGEDIR}${RIAKCS_CONFDIR}/riak-cs.conf.sample
+ ${INSTALL_DATA} ${WRKSRC}/rel/riak-cs/etc/advanced.config ${STAGEDIR}${RIAKCS_CONFDIR}/advanced.config.sample
+ ${INSTALL_DATA} ${WRKSRC}/rel/riak-cs/etc/cert.pem ${STAGEDIR}${RIAKCS_CONFDIR}/cert.pem.sample
+ ${INSTALL_DATA} ${WRKSRC}/rel/riak-cs/etc/key.pem ${STAGEDIR}${RIAKCS_CONFDIR}/key.pem.sample
(cd ${WRKSRC}/rel/riak-cs/lib/ && ${COPYTREE_BIN} . ${STAGEDIR}${RIAKCS_LIBDIR})
(cd ${WRKSRC}/rel/riak-cs/bin/ && ${COPYTREE_BIN} . ${STAGEDIR}${PREFIX}/sbin/)
(cd ${WRKSRC}/rel/riak-cs/lib/basho-patches && ${COPYTREE_SHARE} . ${STAGEDIR}${RIAKCS_LIBDIR}/basho-patches)
diff --git a/sysutils/riak-cs/pkg-plist b/sysutils/riak-cs/pkg-plist
index fe387e704f20..efa884a6db69 100644
--- a/sysutils/riak-cs/pkg-plist
+++ b/sysutils/riak-cs/pkg-plist
@@ -7,11 +7,10 @@ sbin/riak-cs-multibag
sbin/riak-cs-stanchion
sbin/riak-cs-storage
sbin/riak-cs-supercluster
-@sample %%RIAKCS_CONFDIR%%/riak-cs.conf
-@sample %%RIAKCS_CONFDIR%%/advanced.config
-@sample %%RIAKCS_CONFDIR%%/key.pem
-@sample %%RIAKCS_CONFDIR%%/cert.pem
-@dir %%RIAKCS_CONFDIR%%
+@sample %%RIAKCS_CONFDIR%%/riak-cs.conf.sample
+@sample %%RIAKCS_CONFDIR%%/advanced.config.sample
+@sample %%RIAKCS_CONFDIR%%/key.pem.sample
+@sample %%RIAKCS_CONFDIR%%/cert.pem.sample
@owner %%USERS%%
@group %%GROUPS%%
@dir %%RIAKCS_DBDIR%%