aboutsummaryrefslogtreecommitdiff
path: root/sysutils/roottail
diff options
context:
space:
mode:
authorChris D. Faulhaber <jedgar@FreeBSD.org>2000-07-18 19:44:14 +0000
committerChris D. Faulhaber <jedgar@FreeBSD.org>2000-07-18 19:44:14 +0000
commitaa869ccfbe6bfeddf9700a92ac375a4f51d10681 (patch)
tree62cd8977088990156aeea2b39ce3be8fc05c90c1 /sysutils/roottail
parent5f5a61d4aaf18497d26d2b25c0875d7c547aa0ef (diff)
downloadports-aa869ccfbe6bfeddf9700a92ac375a4f51d10681.tar.gz
ports-aa869ccfbe6bfeddf9700a92ac375a4f51d10681.zip
Notes
Diffstat (limited to 'sysutils/roottail')
-rw-r--r--sysutils/roottail/Makefile17
-rw-r--r--sysutils/roottail/distinfo2
-rw-r--r--sysutils/roottail/files/patch-aa25
-rw-r--r--sysutils/roottail/pkg-descr5
-rw-r--r--sysutils/roottail/pkg-plist2
5 files changed, 39 insertions, 12 deletions
diff --git a/sysutils/roottail/Makefile b/sysutils/roottail/Makefile
index 933676c42edb..921a88ed0247 100644
--- a/sysutils/roottail/Makefile
+++ b/sysutils/roottail/Makefile
@@ -6,21 +6,20 @@
#
PORTNAME= roottail
-PORTVERSION= 0.0.4b
+PORTVERSION= 0.0.6
CATEGORIES= sysutils
-MASTER_SITES= ftp://ftp.hypertek.net/misc/ \
- http://www.fxp.org/~jedgar/distfiles/
-DISTNAME= rt-0.0.4B
-EXTRACT_SUFX= .tgz
+MASTER_SITES= http://www.goof.com/pcg/marc/data/ \
+ ftp://www.goof.com/pub/pcg/marc/
+DISTNAME= root-tail-0.0.6
-MAINTAINER= jedgar@fxp.org
+MAINTAINER= jedgar@FreeBSD.org
-MAN1= rt.1
+MAN1= root-tail.1
USE_IMAKE= yes
MANCOMPRESSED= no
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/rt ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/rt.1 ${PREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/root-tail ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/root-tail.man ${PREFIX}/man/man1/root-tail.1
.include <bsd.port.mk>
diff --git a/sysutils/roottail/distinfo b/sysutils/roottail/distinfo
index f80e5984636d..1e589561decc 100644
--- a/sysutils/roottail/distinfo
+++ b/sysutils/roottail/distinfo
@@ -1 +1 @@
-MD5 (rt-0.0.4B.tgz) = bb2381e22f072ad28670e6f00ce16fc7
+MD5 (root-tail-0.0.6.tar.gz) = 8f1580b2bc1c1b50e4da412628a45b81
diff --git a/sysutils/roottail/files/patch-aa b/sysutils/roottail/files/patch-aa
new file mode 100644
index 000000000000..0775d3a497e7
--- /dev/null
+++ b/sysutils/roottail/files/patch-aa
@@ -0,0 +1,25 @@
+--- ../root-tail-0.0.6/root-tail.c Fri Mar 3 06:16:46 2000
++++ root-tail.c Thu Jul 13 07:38:05 2000
+@@ -24,6 +24,7 @@
+ /*---------------- Let's define signals functions -------------*/
+
+ static void reopen (int);
++static void exit_now(int);
+ static void list_files (int);
+ static void force_refresh (int);
+ static void InstallSigHandler (void);
+@@ -109,6 +110,14 @@
+ signal (SIGHUP, reopen);
+ signal (SIGUSR1, list_files);
+ signal (SIGUSR2, force_refresh);
++ signal (SIGSEGV, exit_now);
++}
++
++void exit_now(int signal)
++{
++
++ fprintf (stderr, "Program exiting due to signal: %d\n", signal);
++ exit(-1);
+ }
+
+
diff --git a/sysutils/roottail/pkg-descr b/sysutils/roottail/pkg-descr
index e8af1dc3c54a..664933f09e26 100644
--- a/sysutils/roottail/pkg-descr
+++ b/sysutils/roottail/pkg-descr
@@ -2,4 +2,7 @@ Simple utility to tail files/logs to a root X window.
Useful for keeping tabs on log files in X without having
an additional terminal window open.
-WWW: http://hypertek.net/root-tail/
+WWW: http://www.goof.com/pcg/marc/root-tail.html
+
+- Chris D. Faulhaber
+ <jedgar@FreeBSD.org>
diff --git a/sysutils/roottail/pkg-plist b/sysutils/roottail/pkg-plist
index db6011964c41..269bf01b4451 100644
--- a/sysutils/roottail/pkg-plist
+++ b/sysutils/roottail/pkg-plist
@@ -1 +1 @@
-bin/rt
+bin/root-tail