aboutsummaryrefslogtreecommitdiff
path: root/sysutils/rsyslog4
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-01-27 19:40:41 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-01-27 19:40:41 +0000
commit5e651b0fb36ada59fa0f96ff55cd183d529d133e (patch)
tree3444b7d4b6d4e0923c8063eede18756a6ef5d01f /sysutils/rsyslog4
parent9fa959e9749414fb058ffe2a0e489b4ef742e2a2 (diff)
downloadports-5e651b0fb36ada59fa0f96ff55cd183d529d133e.tar.gz
ports-5e651b0fb36ada59fa0f96ff55cd183d529d133e.zip
Notes
Diffstat (limited to 'sysutils/rsyslog4')
-rw-r--r--sysutils/rsyslog4/Makefile50
-rw-r--r--sysutils/rsyslog4/bsd.rsyslog.mk20
-rw-r--r--sysutils/rsyslog4/distinfo3
-rw-r--r--sysutils/rsyslog4/files/pkg-message.in16
-rw-r--r--sysutils/rsyslog4/files/rsyslogd.in77
-rw-r--r--sysutils/rsyslog4/pkg-descr18
-rw-r--r--sysutils/rsyslog4/pkg-plist140
7 files changed, 324 insertions, 0 deletions
diff --git a/sysutils/rsyslog4/Makefile b/sysutils/rsyslog4/Makefile
new file mode 100644
index 000000000000..27c9f654f9e0
--- /dev/null
+++ b/sysutils/rsyslog4/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: rsyslog4
+# Date created: 29 December 2008
+# Whom: Cristiano Rolim Pereira <cristianorolim@hotmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rsyslog
+PORTVERSION= 4.1.3
+CATEGORIES= sysutils
+MASTER_SITES= http://download.rsyslog.com/rsyslog/
+
+MAINTAINER= cristianorolim@hotmail.com
+COMMENT= Syslogd supporting SQL, TCP and TLS
+
+MAN8= rsyslogd.8
+MAN5= rsyslog.conf.5
+
+CONFLICTS= rsyslog-[2-3].[0-9]*
+USE_RC_SUBR= ${PORTNAME}d
+SUB_FILES= pkg-message
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+CONFIGURE_ARGS+=--enable-imfile --enable-mail --enable-imtemplate
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|/lib/rsyslog/|${PREFIX}/lib/rsyslog/|'\
+ ${WRKSRC}/tools/syslogd.c
+ @${GREP} -rl '/etc/rsyslog.conf' ${WRKSRC}|${XARGS} ${REINPLACE_CMD} -e\
+ 's|/etc/rsyslog.conf|${PREFIX}/etc/rsyslog.conf|'
+ @${FIND} ${WRKSRC} -name '*.bak' -delete
+
+post-install:
+.ifndef NOPORTDOCS
+ @${INSTALL} -d ${DOCSDIR}/
+ @${INSTALL_DATA} ${WRKSRC}/doc/*html ${DOCSDIR}/
+ @${INSTALL_DATA} ${WRKSRC}/doc/*jpg ${DOCSDIR}/
+.endif
+.ifndef NOPORTEXAMPLES
+ @${INSTALL} -d ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/rsyslog-example.conf ${EXAMPLESDIR}
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/sysutils/rsyslog4/bsd.rsyslog.mk b/sysutils/rsyslog4/bsd.rsyslog.mk
new file mode 100644
index 000000000000..56f65a30417d
--- /dev/null
+++ b/sysutils/rsyslog4/bsd.rsyslog.mk
@@ -0,0 +1,20 @@
+PORTNAME?= rsyslog
+PORTVERSION?= 4.1.3
+CATEGORIES?= sysutils
+MASTER_SITES?= http://download.rsyslog.com/rsyslog/
+MAINTAINER?= cristianorolim@hotmail.com
+
+CONFLICTS= rsyslog-[2-3].[0-9]*
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+.ifdef MNAME
+PKGNAMESUFFIX?= -${MNAME}
+CONFIGURE_ARGS+= --disable-rsyslogd --disable-klog
+RUN_DEPENDS= rsyslog>=4:${PORTSDIR}/sysutils/rsyslog4
+
+DESCR?= ${.CURDIR}/../rsyslog4/pkg-descr
+MD5_FILE?= ${.CURDIR}/../rsyslog4/distinfo
+.endif
diff --git a/sysutils/rsyslog4/distinfo b/sysutils/rsyslog4/distinfo
new file mode 100644
index 000000000000..ea1636588ace
--- /dev/null
+++ b/sysutils/rsyslog4/distinfo
@@ -0,0 +1,3 @@
+MD5 (rsyslog-4.1.3.tar.gz) = d598cbed2066321bd4b156300a39b9ed
+SHA256 (rsyslog-4.1.3.tar.gz) = 5a2e139f47b41ed59828e7dc04df79837f23179eed6e83a948570fff40ace66d
+SIZE (rsyslog-4.1.3.tar.gz) = 1349408
diff --git a/sysutils/rsyslog4/files/pkg-message.in b/sysutils/rsyslog4/files/pkg-message.in
new file mode 100644
index 000000000000..fd027fff9592
--- /dev/null
+++ b/sysutils/rsyslog4/files/pkg-message.in
@@ -0,0 +1,16 @@
+===================================================================
+To start using rsyslogd(8), stop syslogd(8) if it's running and
+add the following lines to rc.conf(5):
+ syslogd_enable="NO"
+ rsyslogd_enable="YES"
+To avoid warnings about rsyslogd running in compatibility mode, add
+this:
+ rsyslogd_flags="-c3"
+It's recommended to copy syslog.conf(5) to
+%%PREFIX%%/etc/rsyslog.conf and edit it there. Otherwise add
+this:
+ rsyslogd_config="/etc/syslog.conf"
+newsyslog(8) has the path of syslogd's pid file hardcoded. To
+make it work seamlessly with rsyslog, add this:
+ rsyslogd_pidfile="/var/run/syslog.pid"
+===================================================================
diff --git a/sysutils/rsyslog4/files/rsyslogd.in b/sysutils/rsyslog4/files/rsyslogd.in
new file mode 100644
index 000000000000..c4997460783e
--- /dev/null
+++ b/sysutils/rsyslog4/files/rsyslogd.in
@@ -0,0 +1,77 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: rsyslogd
+# REQUIRE: mountcritremote cleanvar newsyslog ldconfig
+# BEFORE: SERVERS
+
+. %%RC_SUBR%%
+
+name=rsyslogd
+rcvar=`set_rcvar`
+command="%%PREFIX%%/sbin/${name}"
+load_rc_config $name
+: ${rsyslogd_enable:="NO"}
+: ${rsyslogd_pidfile:="/var/run/rsyslogd.pid"}
+: ${rsyslogd_config:="%%PREFIX%%/etc/rsyslog.conf"}
+pidfile="${rsyslogd_pidfile}"
+command_args="-i ${pidfile} -f ${rsyslogd_config}"
+required_files="${rsyslogd_config}"
+start_precmd="rsyslogd_precmd"
+extra_commands="reload"
+
+sockfile="/var/run/rsyslogd.sockets"
+evalargs="rc_flags=\"\`set_socketlist\` \$rc_flags\""
+altlog_proglist="named"
+
+rsyslogd_precmd()
+{
+ local _l _ldir
+
+ # Transitional symlink for old binaries
+ #
+ if [ ! -L /dev/log ]; then
+ ln -sf /var/run/log /dev/log
+ fi
+ rm -f /var/run/log
+
+ # Create default list of syslog sockets to watch
+ #
+ ( umask 022 ; > $sockfile )
+
+ # If running named(8) or ntpd(8) chrooted, added appropriate
+ # syslog socket to list of sockets to watch.
+ #
+ for _l in $altlog_proglist; do
+ eval _ldir=\$${_l}_chrootdir
+ if checkyesno `set_rcvar $_l` && [ -n "$_ldir" ]; then
+ echo "${_ldir}/var/run/log" >> $sockfile
+ fi
+ done
+
+ # If other sockets have been provided, change run_rc_command()'s
+ # internal copy of $rsyslogd_flags to force use of specific
+ # rsyslogd sockets.
+ #
+ if [ -s $sockfile ]; then
+ echo "/var/run/log" >> $sockfile
+ eval $evalargs
+ fi
+
+ return 0
+}
+
+set_socketlist()
+{
+ local _s _socketargs
+
+ _socketargs=
+ for _s in `cat $sockfile | tr '\n' ' '` ; do
+ _socketargs="-a $_s $_socketargs"
+ done
+ echo $_socketargs
+}
+
+run_rc_command "$1"
diff --git a/sysutils/rsyslog4/pkg-descr b/sysutils/rsyslog4/pkg-descr
new file mode 100644
index 000000000000..d4b2dbe2e185
--- /dev/null
+++ b/sysutils/rsyslog4/pkg-descr
@@ -0,0 +1,18 @@
+Rsyslog is an enhanced multi-threaded syslogd with a focus on security and
+reliability.
+
+Among others, it offers support for on-demand disk buffering, reliable syslog
+over TCP, SSL, TLS and RELP, writing to databases (MySQL, PostgreSQL, Oracle,
+and many more), email alerting, fully configurable output formats (including
+high-precision timestamps),the ability to filter on any part of the syslog
+message, on-the-wire message compression, and the ability to convert text
+files to syslog.
+
+It is a drop-in replacement for stock syslogd and able to work with the same
+configuration file syntax. Its advanced features make it suitable for
+enterprise-class, encryption protected syslog relay chains while at the same
+time being very easy to setup for the novice user.
+
+Version 4.x.x is still in devel stage and can show stability issues.
+
+WWW: http://www.rsyslog.com/
diff --git a/sysutils/rsyslog4/pkg-plist b/sysutils/rsyslog4/pkg-plist
new file mode 100644
index 000000000000..ac8abe4a9c7c
--- /dev/null
+++ b/sysutils/rsyslog4/pkg-plist
@@ -0,0 +1,140 @@
+lib/rsyslog/imfile.la
+lib/rsyslog/imfile.so
+lib/rsyslog/imklog.la
+lib/rsyslog/imklog.so
+lib/rsyslog/immark.la
+lib/rsyslog/immark.so
+lib/rsyslog/imtcp.la
+lib/rsyslog/imtcp.so
+lib/rsyslog/imtemplate.la
+lib/rsyslog/imtemplate.so
+lib/rsyslog/imudp.la
+lib/rsyslog/imudp.so
+lib/rsyslog/imuxsock.la
+lib/rsyslog/imuxsock.so
+lib/rsyslog/lmnet.la
+lib/rsyslog/lmnet.so
+lib/rsyslog/lmnetstrms.la
+lib/rsyslog/lmnetstrms.so
+lib/rsyslog/lmnsd_ptcp.la
+lib/rsyslog/lmnsd_ptcp.so
+lib/rsyslog/lmregexp.la
+lib/rsyslog/lmregexp.so
+lib/rsyslog/lmtcpclt.la
+lib/rsyslog/lmtcpclt.so
+lib/rsyslog/lmtcpsrv.la
+lib/rsyslog/lmtcpsrv.so
+lib/rsyslog/ommail.la
+lib/rsyslog/ommail.so
+lib/rsyslog/omtesting.la
+lib/rsyslog/omtesting.so
+sbin/rsyslogd
+%%PORTDOCS%%%%DOCSDIR%%/bugs.html
+%%PORTDOCS%%%%DOCSDIR%%/build_from_repo.html
+%%PORTDOCS%%%%DOCSDIR%%/contributors.html
+%%PORTDOCS%%%%DOCSDIR%%/debug.html
+%%PORTDOCS%%%%DOCSDIR%%/dev_queue.html
+%%PORTDOCS%%%%DOCSDIR%%/droppriv.html
+%%PORTDOCS%%%%DOCSDIR%%/expression.html
+%%PORTDOCS%%%%DOCSDIR%%/features.html
+%%PORTDOCS%%%%DOCSDIR%%/generic_design.html
+%%PORTDOCS%%%%DOCSDIR%%/gssapi.html
+%%PORTDOCS%%%%DOCSDIR%%/history.html
+%%PORTDOCS%%%%DOCSDIR%%/how2help.html
+%%PORTDOCS%%%%DOCSDIR%%/im3195.html
+%%PORTDOCS%%%%DOCSDIR%%/imfile.html
+%%PORTDOCS%%%%DOCSDIR%%/imgssapi.html
+%%PORTDOCS%%%%DOCSDIR%%/imklog.html
+%%PORTDOCS%%%%DOCSDIR%%/imrelp.html
+%%PORTDOCS%%%%DOCSDIR%%/imtcp.html
+%%PORTDOCS%%%%DOCSDIR%%/imuxsock.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/install.html
+%%PORTDOCS%%%%DOCSDIR%%/ipv6.html
+%%PORTDOCS%%%%DOCSDIR%%/licensing.html
+%%PORTDOCS%%%%DOCSDIR%%/log_rotation_fix_size.html
+%%PORTDOCS%%%%DOCSDIR%%/man_rsyslogd.html
+%%PORTDOCS%%%%DOCSDIR%%/manual.html
+%%PORTDOCS%%%%DOCSDIR%%/modules.html
+%%PORTDOCS%%%%DOCSDIR%%/netstream.html
+%%PORTDOCS%%%%DOCSDIR%%/ns_gtls.html
+%%PORTDOCS%%%%DOCSDIR%%/ns_ptcp.html
+%%PORTDOCS%%%%DOCSDIR%%/omlibdbi.html
+%%PORTDOCS%%%%DOCSDIR%%/ommail.html
+%%PORTDOCS%%%%DOCSDIR%%/omrelp.html
+%%PORTDOCS%%%%DOCSDIR%%/omsnmp.html
+%%PORTDOCS%%%%DOCSDIR%%/professional_support.html
+%%PORTDOCS%%%%DOCSDIR%%/property_replacer.html
+%%PORTDOCS%%%%DOCSDIR%%/queueWorkerLogic.jpg
+%%PORTDOCS%%%%DOCSDIR%%/queueWorkerLogic_small.jpg
+%%PORTDOCS%%%%DOCSDIR%%/queues.html
+%%PORTDOCS%%%%DOCSDIR%%/rainerscript.html
+%%PORTDOCS%%%%DOCSDIR%%/rsconf1_actionexeconlywhenpreviousissuspended.html
+%%PORTDOCS%%%%DOCSDIR%%/rsconf1_actionresumeinterval.html
+%%PORTDOCS%%%%DOCSDIR%%/rsconf1_allowedsender.html
+%%PORTDOCS%%%%DOCSDIR%%/rsconf1_controlcharacterescapeprefix.html
+%%PORTDOCS%%%%DOCSDIR%%/rsconf1_debugprintcfsyslinehandlerlist.html
+%%PORTDOCS%%%%DOCSDIR%%/rsconf1_debugprintmodulelist.html
+%%PORTDOCS%%%%DOCSDIR%%/rsconf1_debugprinttemplatelist.html
+%%PORTDOCS%%%%DOCSDIR%%/rsconf1_dircreatemode.html
+%%PORTDOCS%%%%DOCSDIR%%/rsconf1_dirgroup.html
+%%PORTDOCS%%%%DOCSDIR%%/rsconf1_dirowner.html
+%%PORTDOCS%%%%DOCSDIR%%/rsconf1_dropmsgswithmaliciousdnsptrrecords.html
+%%PORTDOCS%%%%DOCSDIR%%/rsconf1_droptrailinglfonreception.html
+%%PORTDOCS%%%%DOCSDIR%%/rsconf1_dynafilecachesize.html
+%%PORTDOCS%%%%DOCSDIR%%/rsconf1_escapecontrolcharactersonreceive.html
+%%PORTDOCS%%%%DOCSDIR%%/rsconf1_failonchownfailure.html
+%%PORTDOCS%%%%DOCSDIR%%/rsconf1_filecreatemode.html
+%%PORTDOCS%%%%DOCSDIR%%/rsconf1_filegroup.html
+%%PORTDOCS%%%%DOCSDIR%%/rsconf1_fileowner.html
+%%PORTDOCS%%%%DOCSDIR%%/rsconf1_gssforwardservicename.html
+%%PORTDOCS%%%%DOCSDIR%%/rsconf1_gsslistenservicename.html
+%%PORTDOCS%%%%DOCSDIR%%/rsconf1_gssmode.html
+%%PORTDOCS%%%%DOCSDIR%%/rsconf1_includeconfig.html
+%%PORTDOCS%%%%DOCSDIR%%/rsconf1_mainmsgqueuesize.html
+%%PORTDOCS%%%%DOCSDIR%%/rsconf1_markmessageperiod.html
+%%PORTDOCS%%%%DOCSDIR%%/rsconf1_moddir.html
+%%PORTDOCS%%%%DOCSDIR%%/rsconf1_modload.html
+%%PORTDOCS%%%%DOCSDIR%%/rsconf1_repeatedmsgreduction.html
+%%PORTDOCS%%%%DOCSDIR%%/rsconf1_resetconfigvariables.html
+%%PORTDOCS%%%%DOCSDIR%%/rsconf1_umask.html
+%%PORTDOCS%%%%DOCSDIR%%/rscript_abnf.html
+%%PORTDOCS%%%%DOCSDIR%%/rsyslog_conf.html
+%%PORTDOCS%%%%DOCSDIR%%/rsyslog_conf_actions.html
+%%PORTDOCS%%%%DOCSDIR%%/rsyslog_conf_examples.html
+%%PORTDOCS%%%%DOCSDIR%%/rsyslog_conf_filter.html
+%%PORTDOCS%%%%DOCSDIR%%/rsyslog_conf_global.html
+%%PORTDOCS%%%%DOCSDIR%%/rsyslog_conf_modules.html
+%%PORTDOCS%%%%DOCSDIR%%/rsyslog_conf_nomatch.html
+%%PORTDOCS%%%%DOCSDIR%%/rsyslog_conf_output.html
+%%PORTDOCS%%%%DOCSDIR%%/rsyslog_conf_templates.html
+%%PORTDOCS%%%%DOCSDIR%%/rsyslog_high_database_rate.html
+%%PORTDOCS%%%%DOCSDIR%%/rsyslog_mysql.html
+%%PORTDOCS%%%%DOCSDIR%%/rsyslog_ng_comparison.html
+%%PORTDOCS%%%%DOCSDIR%%/rsyslog_packages.html
+%%PORTDOCS%%%%DOCSDIR%%/rsyslog_php_syslog_ng.html
+%%PORTDOCS%%%%DOCSDIR%%/rsyslog_recording_pri.html
+%%PORTDOCS%%%%DOCSDIR%%/rsyslog_reliable_forwarding.html
+%%PORTDOCS%%%%DOCSDIR%%/rsyslog_secure_tls.html
+%%PORTDOCS%%%%DOCSDIR%%/rsyslog_stunnel.html
+%%PORTDOCS%%%%DOCSDIR%%/rsyslog_tls.html
+%%PORTDOCS%%%%DOCSDIR%%/status.html
+%%PORTDOCS%%%%DOCSDIR%%/syslog_protocol.html
+%%PORTDOCS%%%%DOCSDIR%%/tls_cert.jpg
+%%PORTDOCS%%%%DOCSDIR%%/tls_cert_100.jpg
+%%PORTDOCS%%%%DOCSDIR%%/tls_cert_ca.html
+%%PORTDOCS%%%%DOCSDIR%%/tls_cert_ca.jpg
+%%PORTDOCS%%%%DOCSDIR%%/tls_cert_client.html
+%%PORTDOCS%%%%DOCSDIR%%/tls_cert_errmsgs.html
+%%PORTDOCS%%%%DOCSDIR%%/tls_cert_machine.html
+%%PORTDOCS%%%%DOCSDIR%%/tls_cert_scenario.html
+%%PORTDOCS%%%%DOCSDIR%%/tls_cert_server.html
+%%PORTDOCS%%%%DOCSDIR%%/tls_cert_summary.html
+%%PORTDOCS%%%%DOCSDIR%%/tls_cert_udp_relay.html
+%%PORTDOCS%%%%DOCSDIR%%/troubleshoot.html
+%%PORTDOCS%%%%DOCSDIR%%/v3compatibility.html
+%%PORTDOCS%%%%DOCSDIR%%/version_naming.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rsyslog-example.conf
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrmtry lib/rsyslog