aboutsummaryrefslogtreecommitdiff
path: root/sysutils/rubygem-hammer_cli_foreman_ssh
diff options
context:
space:
mode:
authorJohannes Jost Meixner <xmj@FreeBSD.org>2014-11-16 07:55:07 +0000
committerJohannes Jost Meixner <xmj@FreeBSD.org>2014-11-16 07:55:07 +0000
commitbe2136f177b0b67bcea3a645b35c549ec0f8342b (patch)
tree57e70320289349d96217c15bd09b2ae7827b2189 /sysutils/rubygem-hammer_cli_foreman_ssh
parent8450c7abe1fa8a38da9e0bfb390f86ee4d046cb7 (diff)
downloadports-be2136f177b0b67bcea3a645b35c549ec0f8342b.tar.gz
ports-be2136f177b0b67bcea3a645b35c549ec0f8342b.zip
Notes
Diffstat (limited to 'sysutils/rubygem-hammer_cli_foreman_ssh')
-rw-r--r--sysutils/rubygem-hammer_cli_foreman_ssh/Makefile28
-rw-r--r--sysutils/rubygem-hammer_cli_foreman_ssh/distinfo2
-rw-r--r--sysutils/rubygem-hammer_cli_foreman_ssh/files/foreman_ssh.yml.sample3
-rw-r--r--sysutils/rubygem-hammer_cli_foreman_ssh/pkg-descr4
4 files changed, 37 insertions, 0 deletions
diff --git a/sysutils/rubygem-hammer_cli_foreman_ssh/Makefile b/sysutils/rubygem-hammer_cli_foreman_ssh/Makefile
new file mode 100644
index 000000000000..d54a839129e2
--- /dev/null
+++ b/sysutils/rubygem-hammer_cli_foreman_ssh/Makefile
@@ -0,0 +1,28 @@
+# Created by: Michael Moll <kvedulv@kvedulv.de>
+# $FreeBSD$
+
+PORTNAME= hammer_cli_foreman_ssh
+PORTVERSION= 0.0.2
+CATEGORIES= sysutils ruby
+MASTER_SITES= RG
+
+MAINTAINER= kvedulv@kvedulv.de
+COMMENT= SSH host commands for Hammer CLI
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= rubygem-hammer_cli_foreman>=0.1.2:${PORTSDIR}/sysutils/rubygem-hammer_cli_foreman \
+ rubygem-net-ssh-multi>0:${PORTSDIR}/security/rubygem-net-ssh-multi
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+PLIST_FILES= "@sample etc/hammer/cli.modules.d/foreman_ssh.yml.sample"
+
+.include <bsd.port.pre.mk>
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/hammer/cli.modules.d
+ ${INSTALL_DATA} ${FILESDIR}/foreman_ssh.yml.sample ${STAGEDIR}${PREFIX}/etc/hammer/cli.modules.d/foreman_ssh.yml.sample
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/rubygem-hammer_cli_foreman_ssh/distinfo b/sysutils/rubygem-hammer_cli_foreman_ssh/distinfo
new file mode 100644
index 000000000000..606a8e0fc35a
--- /dev/null
+++ b/sysutils/rubygem-hammer_cli_foreman_ssh/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/hammer_cli_foreman_ssh-0.0.2.gem) = b75c930a185c6c18195fddf745cdfcfcc777c3a7ae873fbe4fc12a01971d4e7b
+SIZE (rubygem/hammer_cli_foreman_ssh-0.0.2.gem) = 6656
diff --git a/sysutils/rubygem-hammer_cli_foreman_ssh/files/foreman_ssh.yml.sample b/sysutils/rubygem-hammer_cli_foreman_ssh/files/foreman_ssh.yml.sample
new file mode 100644
index 000000000000..d66a4387b9f9
--- /dev/null
+++ b/sysutils/rubygem-hammer_cli_foreman_ssh/files/foreman_ssh.yml.sample
@@ -0,0 +1,3 @@
+:foreman_ssh:
+ :enable_module: true
+ :require: 'foreman'
diff --git a/sysutils/rubygem-hammer_cli_foreman_ssh/pkg-descr b/sysutils/rubygem-hammer_cli_foreman_ssh/pkg-descr
new file mode 100644
index 000000000000..4183816f33ef
--- /dev/null
+++ b/sysutils/rubygem-hammer_cli_foreman_ssh/pkg-descr
@@ -0,0 +1,4 @@
+This Hammer CLI plugin contains a set of commands for remote execution
+of commands on hosts known to Foreman via SSH
+
+WWW: https://github.com/theforeman/hammer-cli-foreman-ssh