aboutsummaryrefslogtreecommitdiff
path: root/sysutils/rubygem-smart_proxy_salt
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2014-09-27 20:05:12 +0000
committerSteve Wills <swills@FreeBSD.org>2014-09-27 20:05:12 +0000
commit1c6b920a96a9306232da318f042a54c887426660 (patch)
tree1485da57a0a9786063fcacf11fb63a5dffe4d6f1 /sysutils/rubygem-smart_proxy_salt
parent2f7367e2fa6d14d589151c22dba04be33c2801ce (diff)
downloadports-1c6b920a96a9306232da318f042a54c887426660.tar.gz
ports-1c6b920a96a9306232da318f042a54c887426660.zip
sysutils/rubygem-smart_proxy_salt: create port
This plug-in adds support for SaltStack to Foreman's Smart Proxy. WWW: https://github.com/theforeman/smart_proxy_salt PR: 193976 Submitted by: Michael Moll <kvedulv@kvedulv.de>
Notes
Notes: svn path=/head/; revision=369418
Diffstat (limited to 'sysutils/rubygem-smart_proxy_salt')
-rw-r--r--sysutils/rubygem-smart_proxy_salt/Makefile31
-rw-r--r--sysutils/rubygem-smart_proxy_salt/distinfo2
-rw-r--r--sysutils/rubygem-smart_proxy_salt/files/salt.rb1
-rw-r--r--sysutils/rubygem-smart_proxy_salt/files/salt.yml.sample4
-rw-r--r--sysutils/rubygem-smart_proxy_salt/pkg-descr3
-rw-r--r--sysutils/rubygem-smart_proxy_salt/pkg-plist3
6 files changed, 44 insertions, 0 deletions
diff --git a/sysutils/rubygem-smart_proxy_salt/Makefile b/sysutils/rubygem-smart_proxy_salt/Makefile
new file mode 100644
index 000000000000..d67795e79391
--- /dev/null
+++ b/sysutils/rubygem-smart_proxy_salt/Makefile
@@ -0,0 +1,31 @@
+# Created by: Michael Moll <kvedulv@kvedulv.de>
+# $FreeBSD$
+
+PORTNAME= smart_proxy_salt
+PORTVERSION= 0.0.2
+CATEGORIES= sysutils ruby
+MASTER_SITES= RG
+
+MAINTAINER= kvedulv@kvedulv.de
+COMMENT= SaltStack Plug-In for Foreman's Smart Proxy
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= foreman-proxy>=1.6.0:${PORTSDIR}/net/foreman-proxy \
+ ${PYTHON_PKGNAMEPREFIX}salt:${PORTSDIR}/sysutils/py-salt
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.pre.mk>
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/foreman-proxy
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/foreman-proxy/settings.d
+ ${INSTALL_DATA} ${FILESDIR}/salt.yml.sample ${STAGEDIR}${PREFIX}/etc/foreman-proxy/settings.d/salt.yml.sample
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/foreman-proxy
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/foreman-proxy/bundler.d
+ ${INSTALL_DATA} ${FILESDIR}/salt.rb ${STAGEDIR}${PREFIX}/share/foreman-proxy/bundler.d/salt.rb
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/rubygem-smart_proxy_salt/distinfo b/sysutils/rubygem-smart_proxy_salt/distinfo
new file mode 100644
index 000000000000..1245d19eac23
--- /dev/null
+++ b/sysutils/rubygem-smart_proxy_salt/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/smart_proxy_salt-0.0.2.gem) = 7b3ea0eb67a9a0fd05ab9179e3f45b59968407d13720dbdd92e70b78cb601f73
+SIZE (rubygem/smart_proxy_salt-0.0.2.gem) = 20992
diff --git a/sysutils/rubygem-smart_proxy_salt/files/salt.rb b/sysutils/rubygem-smart_proxy_salt/files/salt.rb
new file mode 100644
index 000000000000..e33da60fbe95
--- /dev/null
+++ b/sysutils/rubygem-smart_proxy_salt/files/salt.rb
@@ -0,0 +1 @@
+gem 'smart_proxy_salt', '0.0.2'
diff --git a/sysutils/rubygem-smart_proxy_salt/files/salt.yml.sample b/sysutils/rubygem-smart_proxy_salt/files/salt.yml.sample
new file mode 100644
index 000000000000..7b35c6ac8a03
--- /dev/null
+++ b/sysutils/rubygem-smart_proxy_salt/files/salt.yml.sample
@@ -0,0 +1,4 @@
+---
+:enabled: true
+:autosign_file: /usr/local/etc/salt/autosign.conf
+:salt_command_user: root
diff --git a/sysutils/rubygem-smart_proxy_salt/pkg-descr b/sysutils/rubygem-smart_proxy_salt/pkg-descr
new file mode 100644
index 000000000000..e1c5aeaa1819
--- /dev/null
+++ b/sysutils/rubygem-smart_proxy_salt/pkg-descr
@@ -0,0 +1,3 @@
+This plug-in adds support for SaltStack to Foreman's Smart Proxy.
+
+WWW: https://github.com/theforeman/smart_proxy_salt
diff --git a/sysutils/rubygem-smart_proxy_salt/pkg-plist b/sysutils/rubygem-smart_proxy_salt/pkg-plist
new file mode 100644
index 000000000000..3625dc936838
--- /dev/null
+++ b/sysutils/rubygem-smart_proxy_salt/pkg-plist
@@ -0,0 +1,3 @@
+bin/foreman-node
+share/foreman-proxy/bundler.d/salt.rb
+@sample etc/foreman-proxy/settings.d/salt.yml.sample