aboutsummaryrefslogtreecommitdiff
path: root/sysutils/runit
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2004-03-25 22:15:48 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2004-03-25 22:15:48 +0000
commitc3fb284092aa3c364e1b45753a6a327727ac7d74 (patch)
tree0cb8777bad1c61e429cb39de7e6293f812ddca0e /sysutils/runit
parent4423c3e60c56eed1b3cb2bf9914b557395197738 (diff)
downloadports-c3fb284092aa3c364e1b45753a6a327727ac7d74.tar.gz
ports-c3fb284092aa3c364e1b45753a6a327727ac7d74.zip
- Make running self-tests an optional step since it may fail
in some environments (particularlly, bento's). Move it from do-build to a new test target. Reported by: bento (via kris)
Notes
Notes: svn path=/head/; revision=105278
Diffstat (limited to 'sysutils/runit')
-rw-r--r--sysutils/runit/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/sysutils/runit/Makefile b/sysutils/runit/Makefile
index 2b003885f63c..bd1e6fd20d0d 100644
--- a/sysutils/runit/Makefile
+++ b/sysutils/runit/Makefile
@@ -30,7 +30,7 @@ do-configure:
${ECHO_CMD} "${CC} ${CFLAGS}" > ${WRKSRC}/src/conf-cc
do-build:
- cd ${WRKSRC} && package/compile && package/check
+ cd ${WRKSRC} && package/compile
@${MKDIR} ${WRKDIR}/etc/getty-ttyv4
@${SED} -e 's!%%PREFIX%%!${PREFIX}!' \
-e 's!%%SERVICE_DIR%%!${SERVICE_DIR}!' \
@@ -41,6 +41,10 @@ do-build:
-e 's!/usr/local!${PREFIX}!g' \
${WRKSRC}/${file} > ${WRKDIR}/${file:S!freebsd/!!}.sample
.endfor
+ @${ECHO_MSG} "Type 'make test' to run self-tests"
+
+test:
+ cd ${WRKSRC} && package/check
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/command/* ${PREFIX}/sbin