aboutsummaryrefslogtreecommitdiff
path: root/sysutils/samesame
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2009-06-30 20:43:11 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2009-06-30 20:43:11 +0000
commit27aca420975e23ac11d24f0e82f7f891518606d9 (patch)
treebc75224cf2fdef2a5ffeb918061ac1ef1ae55143 /sysutils/samesame
parent6eabf27d0e8b69c17351a017e1de0bb528dcc7ee (diff)
downloadports-27aca420975e23ac11d24f0e82f7f891518606d9.tar.gz
ports-27aca420975e23ac11d24f0e82f7f891518606d9.zip
- Fix a small Bug in samefile/samearchive
- Bump PORTREVISION PR: ports/136194 Submitted by: Alex de Kruijff <samesame@akruijff.dds.nl> (maintainer)
Notes
Notes: svn path=/head/; revision=236833
Diffstat (limited to 'sysutils/samesame')
-rw-r--r--sysutils/samesame/Makefile1
-rw-r--r--sysutils/samesame/files/patch-matchmatrix.cpp10
2 files changed, 11 insertions, 0 deletions
diff --git a/sysutils/samesame/Makefile b/sysutils/samesame/Makefile
index 76e5da994b69..805eb62003f1 100644
--- a/sysutils/samesame/Makefile
+++ b/sysutils/samesame/Makefile
@@ -6,6 +6,7 @@
PORTNAME= samesame
PORTVERSION= 1.2
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://samesame.kruijff.org/ \
${MASTER_SITE_LOCAL}
diff --git a/sysutils/samesame/files/patch-matchmatrix.cpp b/sysutils/samesame/files/patch-matchmatrix.cpp
new file mode 100644
index 000000000000..3e6360546637
--- /dev/null
+++ b/sysutils/samesame/files/patch-matchmatrix.cpp
@@ -0,0 +1,10 @@
+--- matchmatrix.cpp.orig 2009-05-22 12:45:27.000000000 +0200
++++ matchmatrix.cpp 2009-06-30 22:24:35.000000000 +0200
+@@ -35,6 +35,7 @@
+ arr[0] = ((signed char *)tmp) + n * sizeof(char **);
+ for (size_t i = 1; i < n; ++i)
+ arr[i] = arr[i - 1] + n - i + 1;
++ memset(arr[0], 0, (n + 1) * n / 2);
+ #ifdef DEBUG
+ if (tmp + n * sizeof(char **) + (n + 1) * n / 2 <= arr[n - 1])
+ {