aboutsummaryrefslogtreecommitdiff
path: root/sysutils/samesame
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2009-04-30 15:31:00 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2009-04-30 15:31:00 +0000
commit48098be05a6b301ec11d1633ae8a23045c9f1565 (patch)
tree8dd33e2ffd1bcc24e013859db76aec3c9024b94f /sysutils/samesame
parent36c416aea22b7fdd187c83b1fa28d76d67b6b45f (diff)
downloadports-48098be05a6b301ec11d1633ae8a23045c9f1565.tar.gz
ports-48098be05a6b301ec11d1633ae8a23045c9f1565.zip
These applications find identical / duplicate files and hard- or symlink
them to save space. This port was inspired by the application samefile written by Jens Schweikhardt. It has a own version of samefile that is noticeable faster and is able to process very large file list. This port contains the applications: samefile, samelink and samearchive. The latter does the same as samefile but for file-based archives. The port also contains a version that uses just 10% of the resources compared to samearchive. The application samelink (hard) links files for you. Typical usage would be: find / | samefile -i | samelink This would search for identical files and clean up wasted disk space by linking them together. Add the option -n after samelink for a dry-run. PR: ports/133637 Submitted by: Alex de Kruijff <freebsd@akruijff.dds.nl> (maintainer) Approved by: tabthorpe (co-mentor)
Notes
Notes: svn path=/head/; revision=232986
Diffstat (limited to 'sysutils/samesame')
-rw-r--r--sysutils/samesame/Makefile55
-rw-r--r--sysutils/samesame/distinfo3
-rw-r--r--sysutils/samesame/pkg-descr16
3 files changed, 74 insertions, 0 deletions
diff --git a/sysutils/samesame/Makefile b/sysutils/samesame/Makefile
new file mode 100644
index 000000000000..8643c53f5c40
--- /dev/null
+++ b/sysutils/samesame/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: samesame
+# Date created: 14 April 2009
+# Whom: Alex de Kruijff
+#
+# $FreeBSD$
+
+PORTNAME= samesame
+PORTVERSION= 1.0
+CATEGORIES= sysutils
+MASTER_SITES= http://www.akruijff.dds.nl/samesame/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= dhn
+
+MAINTAINER= freebsd@akruijff.dds.nl
+COMMENT= Find files with identical contents and replaces them with links
+
+CONFLICTS= samefile-[0-9]*
+
+MAN1= samearchive.1 samearchive-lite.1 samefile.1 samelink.1
+MANCOMPRESSED= yes
+PLIST_FILES= bin/samearchive \
+ bin/samearchive-lite \
+ bin/samefile \
+ bin/samelink
+
+USE_BZIP2= yes
+
+OPTIONS= DEBUG "Enables debugging support" Off \
+ DISK_STORAGE "Allow temporarily storage paths on disk" On \
+ LOGIC "Determine results by using logic when posible" On
+
+.if defined(WITH_DEBUG)
+CFLAGS+= -DDEBUG
+.endif
+
+.if defined(WITH_DISK_STORAGE)
+CFLAGS+= -DWITH_DISK_STORAGE
+.endif
+
+.if defined(WITH_LOGIC)
+CFLAGS+= -DWITH_LOGIC
+.endif
+
+CFLAGS+= -DWITH_MMAP
+CFLAGS+= -D'TEMP_STORAGE_DIR=\"/tmp\"'
+CFLAGS+= -DPATH_INIT=256
+CFLAGS+= -DSTATIC_CACHE_CAPACITY=8192
+
+post-install:
+ ${STRIP_CMD} ${PREFIX}/bin/samefile
+ ${STRIP_CMD} ${PREFIX}/bin/samelink
+ ${STRIP_CMD} ${PREFIX}/bin/samearchive
+ ${STRIP_CMD} ${PREFIX}/bin/samearchive-lite
+
+.include <bsd.port.mk>
diff --git a/sysutils/samesame/distinfo b/sysutils/samesame/distinfo
new file mode 100644
index 000000000000..5896c6d2a8b8
--- /dev/null
+++ b/sysutils/samesame/distinfo
@@ -0,0 +1,3 @@
+MD5 (samesame-1.0.tar.bz2) = c832d26032bf2eaced10ec04fef7ca68
+SHA256 (samesame-1.0.tar.bz2) = 59c440f12e12e11eefea7e1dc2b95cd70e42473b3b6143cd452bf75ab36805d0
+SIZE (samesame-1.0.tar.bz2) = 37910
diff --git a/sysutils/samesame/pkg-descr b/sysutils/samesame/pkg-descr
new file mode 100644
index 000000000000..7db57ce5c202
--- /dev/null
+++ b/sysutils/samesame/pkg-descr
@@ -0,0 +1,16 @@
+These applications find identical / duplicate files and hard- or symlink
+them to save space. This port was inspired by the application samefile
+written by Jens Schweikhardt. It has a own version of samefile that is
+noticeable faster and is able to process very large file list.
+
+This port contains the applications: samefile, samelink and samearchive.
+The latter does the same as samefile but for file-based archives. The
+port also contains a version that uses just 10% of the resources compared
+to samearchive. The application samelink (hard) links files for you.
+
+Typical usage would be:
+
+ find / | samefile -i | samelink
+
+This would search for identical files and clean up wasted disk space by
+linking them together. Add the option -n after samelink for a dry-run.