aboutsummaryrefslogtreecommitdiff
path: root/sysutils/samesame
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2009-07-07 22:08:29 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2009-07-07 22:08:29 +0000
commit95b65fc48ac1d1d3554ca3c595653b328ef70232 (patch)
tree6da54805f1944ecae22817cf91f27c02f9c8f6f2 /sysutils/samesame
parent2a2f4f0d33cc6992caa6cadfd336e7bea3f19063 (diff)
downloadports-95b65fc48ac1d1d3554ca3c595653b328ef70232.tar.gz
ports-95b65fc48ac1d1d3554ca3c595653b328ef70232.zip
- Update to 1.3
PR: ports/136307 Submitted by: Alex de Kruijff <samesame@akruijff.dds.nl> (maintainer)
Notes
Notes: svn path=/head/; revision=237377
Diffstat (limited to 'sysutils/samesame')
-rw-r--r--sysutils/samesame/Makefile37
-rw-r--r--sysutils/samesame/distinfo6
-rw-r--r--sysutils/samesame/files/patch-matchmatrix.cpp10
-rw-r--r--sysutils/samesame/pkg-message4
4 files changed, 24 insertions, 33 deletions
diff --git a/sysutils/samesame/Makefile b/sysutils/samesame/Makefile
index 805eb62003f1..3008623b99f6 100644
--- a/sysutils/samesame/Makefile
+++ b/sysutils/samesame/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= samesame
-PORTVERSION= 1.2
-PORTREVISION= 1
+PORTVERSION= 1.3
CATEGORIES= sysutils
MASTER_SITES= http://samesame.kruijff.org/ \
${MASTER_SITE_LOCAL}
@@ -18,55 +17,53 @@ COMMENT= Find identical files and optionally link them together
CONFLICTS= samefile-[0-9]*
MAN1= samearchive.1 samearchive-lite.1 samefile.1 samelink.1
-MANCOMPRESSED= yes
+MANCOMPRESSED= no
+
PLIST_FILES= bin/samearchive bin/samefile \
bin/samearchive-lite bin/samelink \
etc/rc.d/samesame.sh
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --mandir="${MANPREFIX}/man" --prefix="${PREFIX}" \
+ --includedir="${LOCALBASE}/include" --libdir="${LOCALBASE}/lib"
USE_BZIP2= yes
OPTIONS= DEBUG "Enables debugging support" Off \
- DISK_STORAGE "Allow temporarily storage paths on disk" On \
+ DISK_STORAGE "Allows temporarily storage paths on disk" On \
LOGIC "Determine results by using logic when posible" On \
TEST "Run quality assurance test" Off
.include <bsd.port.pre.mk>
.if defined(WITH_DEBUG)
-CFLAGS+= -DDEBUG
+CONFIGURE_ARGS+= --enable-debug
.endif
.if defined(WITH_DISK_STORAGE)
-CFLAGS+= -DWITH_DISK_STORAGE
+CONFIGURE_ARGS+= --enable-disk-storage
.endif
.if defined(WITHOUT_LOGIC)
-CFLAGS+= -DWITHOUT_LOGIC
+CONFIGURE_ARGS+= --disable-logic
.endif
-CFLAGS+= -DWITH_MMAP
-CFLAGS+= -D'TEMP_STORAGE_DIR=\"/tmp\"'
-CFLAGS+= -DPATH_INIT=256
-CFLAGS+= -DSTATIC_CACHE_CAPACITY=8192
-
-post-patch:
- @${REINPLACE_CMD} -e 's|@||g' ${WRKSRC}/Makefile
-
-post-build:
-.if defined(WITH_TEST)
- cd ${WRKSRC}; ${MAKE} test
-.endif
+test: build
+ @cd ${WRKSRC}; ${MAKE} check
pre-install:
.if defined(WITH_TEST)
- cd ${WRKSRC}; ${MAKE} test
+ @cd ${WRKSRC}; ${MAKE} check
.endif
post-install:
+.if defined(WITHOUT_DEBUG)
${STRIP_CMD} ${PREFIX}/bin/samefile
${STRIP_CMD} ${PREFIX}/bin/samelink
${STRIP_CMD} ${PREFIX}/bin/samearchive
${STRIP_CMD} ${PREFIX}/bin/samearchive-lite
+.endif
+
${INSTALL_SCRIPT} ${FILESDIR}/samesame.sh ${PREFIX}/etc/rc.d/
+ @${CAT} pkg-message
.include <bsd.port.post.mk>
diff --git a/sysutils/samesame/distinfo b/sysutils/samesame/distinfo
index ec53d466b366..740dd78432d0 100644
--- a/sysutils/samesame/distinfo
+++ b/sysutils/samesame/distinfo
@@ -1,3 +1,3 @@
-MD5 (samesame-1.2.tar.bz2) = 828eb35bdb1c8dc9a4cd37e38a3de61e
-SHA256 (samesame-1.2.tar.bz2) = 82f30cc8295dace42e3c6a847217b1b023cd55c754a409c3388614f45a0a6c3b
-SIZE (samesame-1.2.tar.bz2) = 42642
+MD5 (samesame-1.3.tar.bz2) = e64863157690dfcc161c92f079a1dee7
+SHA256 (samesame-1.3.tar.bz2) = 057f5e754cdcceae1d78d4878d501c589fbe214ce63022feebe9c9b7d11d3483
+SIZE (samesame-1.3.tar.bz2) = 100841
diff --git a/sysutils/samesame/files/patch-matchmatrix.cpp b/sysutils/samesame/files/patch-matchmatrix.cpp
deleted file mode 100644
index 3e6360546637..000000000000
--- a/sysutils/samesame/files/patch-matchmatrix.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- matchmatrix.cpp.orig 2009-05-22 12:45:27.000000000 +0200
-+++ matchmatrix.cpp 2009-06-30 22:24:35.000000000 +0200
-@@ -35,6 +35,7 @@
- arr[0] = ((signed char *)tmp) + n * sizeof(char **);
- for (size_t i = 1; i < n; ++i)
- arr[i] = arr[i - 1] + n - i + 1;
-+ memset(arr[0], 0, (n + 1) * n / 2);
- #ifdef DEBUG
- if (tmp + n * sizeof(char **) + (n + 1) * n / 2 <= arr[n - 1])
- {
diff --git a/sysutils/samesame/pkg-message b/sysutils/samesame/pkg-message
new file mode 100644
index 000000000000..b7b51b8753b2
--- /dev/null
+++ b/sysutils/samesame/pkg-message
@@ -0,0 +1,4 @@
+---------------------------------------------------
+A 2 clause BSD licence applies to this application:
+http://samesame.kruijff.org/license.html
+---------------------------------------------------