aboutsummaryrefslogtreecommitdiff
path: root/sysutils/samesame
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-03-20 00:00:02 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-03-20 00:00:02 +0000
commitd37b6538ae5f60d822b9d644b5370085804dd925 (patch)
treeb055ec04eeba63fb2ba0580f004e86db4f6cecf0 /sysutils/samesame
parent645a87e476baec14e760ae93272343f2a4da6625 (diff)
downloadports-d37b6538ae5f60d822b9d644b5370085804dd925.tar.gz
ports-d37b6538ae5f60d822b9d644b5370085804dd925.zip
sysutils/samesame: unbreak with clang 4.0
src/mainAction.cpp:184:19: error: ordered comparison between pointer and zero ('FILE *' (aka '__sFILE *') and 'int') if (pipeLeafs < 0) ~~~~~~~~~ ^ ~ src/mainAction.cpp:197:21: error: ordered comparison between pointer and zero ('FILE *' (aka '__sFILE *') and 'int') if (outputLeafs < 0) ~~~~~~~~~~~ ^ ~ PR: 216636 Submitted by: akruijff@dds.nl Approved by: portmgr blanket
Notes
Notes: svn path=/head/; revision=436516
Diffstat (limited to 'sysutils/samesame')
-rw-r--r--sysutils/samesame/Makefile1
-rw-r--r--sysutils/samesame/files/patch-src_mainAction.cpp20
2 files changed, 21 insertions, 0 deletions
diff --git a/sysutils/samesame/Makefile b/sysutils/samesame/Makefile
index 70a476eadf92..ae5702c6aa8c 100644
--- a/sysutils/samesame/Makefile
+++ b/sysutils/samesame/Makefile
@@ -3,6 +3,7 @@
PORTNAME= samesame
PORTVERSION= 1.10
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://samesame.kruijff.org/ \
LOCAL/dhn
diff --git a/sysutils/samesame/files/patch-src_mainAction.cpp b/sysutils/samesame/files/patch-src_mainAction.cpp
new file mode 100644
index 000000000000..c45d30c1b9a9
--- /dev/null
+++ b/sysutils/samesame/files/patch-src_mainAction.cpp
@@ -0,0 +1,20 @@
+--- src/mainAction.cpp.orig 2011-09-15 22:31:49 UTC
++++ src/mainAction.cpp
+@@ -181,7 +181,7 @@ int actionProcessOptions(int argc, char
+ // strcpy(p, optarg);
+ pipeLeafs = popen(optarg, "w");
+ setlinebuf(pipeLeafs);
+- if (pipeLeafs < 0)
++ if (pipeLeafs == NULL)
+ warn("coudn't open pipe to: %s\n", optarg);
+ else if (outputLeafs)
+ {
+@@ -194,7 +194,7 @@ int actionProcessOptions(int argc, char
+ fclose(outputLeafs);
+ outputLeafs = fopen(optarg, "w");
+ setlinebuf(outputLeafs);
+- if (outputLeafs < 0)
++ if (outputLeafs == NULL)
+ warn("open file: %s\n", optarg);
+ else if (pipeLeafs)
+ {