aboutsummaryrefslogtreecommitdiff
path: root/sysutils/screen
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2022-03-18 13:05:49 +0000
committerCy Schubert <cy@FreeBSD.org>2022-03-18 13:05:49 +0000
commitf65342707d226f3685e96f5463ea14921dc27f71 (patch)
tree64a70a2cd42bb2572db242602ddaf992cdcf1638 /sysutils/screen
parent58797c419cbedb9b84abec488f9f497847cf9125 (diff)
downloadports-f65342707d226f3685e96f5463ea14921dc27f71.tar.gz
ports-f65342707d226f3685e96f5463ea14921dc27f71.zip
sysutils/screen: Fix SHOWENC build
The SHOWENC optional patch is now included in screen 4.9.0. We simply enable the option now and build. The patch is redundant. PR: 262641 Reported by: Trond.Endrestol@ximalas.info, sunpoet, many others Fixes: 9bdc78861688
Diffstat (limited to 'sysutils/screen')
-rw-r--r--sysutils/screen/Makefile2
-rw-r--r--sysutils/screen/files/opt-showencoding21
2 files changed, 1 insertions, 22 deletions
diff --git a/sysutils/screen/Makefile b/sysutils/screen/Makefile
index e0cd0e7b650a..70c2698736ad 100644
--- a/sysutils/screen/Makefile
+++ b/sysutils/screen/Makefile
@@ -75,7 +75,7 @@ CFLAGS+= -DNONETHACK
# show encoding on the status line via option "showenc"
.if ${PORT_OPTIONS:MSHOWENC}
-EXTRA_PATCHES+= ${FILESDIR}/opt-showencoding
+CFLAGS+= -DENCODINGS
.endif
post-patch:
diff --git a/sysutils/screen/files/opt-showencoding b/sysutils/screen/files/opt-showencoding
deleted file mode 100644
index b931f0d67292..000000000000
--- a/sysutils/screen/files/opt-showencoding
+++ /dev/null
@@ -1,21 +0,0 @@
---- screen.c.orig 2017-01-17 11:28:29.397404660 -0800
-+++ screen.c 2017-01-18 12:24:40.855402000 -0800
-@@ -2760,6 +2760,18 @@
- }
- p += strlen(p) - 1;
- break;
-+#ifdef ENCODINGS
-+ case 'e':
-+ *p = 0;
-+ D_encoding = nwin_options.encoding > 0 ? nwin_options.encoding : 0;
-+ if (win && win->w_encoding)
-+ {
-+ *p++ = ' ';
-+ strcpy(p, EncodingName(win->w_encoding));
-+ }
-+ p += strlen(p) - 1;
-+ break;
-+#endif
-
- case '{':
- {