aboutsummaryrefslogtreecommitdiff
path: root/sysutils/seatd
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-10-28 14:41:59 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-10-28 14:41:59 +0000
commit78457167564cc62ba0a017fbf0507ea4bf847c06 (patch)
tree8612fbd4d604b97f0aa3b70875748d37a8b55023 /sysutils/seatd
parentd04a1f3e79ecd9e50b0ad3390c582531b2ed4dd4 (diff)
downloadports-78457167564cc62ba0a017fbf0507ea4bf847c06.tar.gz
ports-78457167564cc62ba0a017fbf0507ea4bf847c06.zip
x11-toolkits/wlroots: enable LIBSEAT by default
When seatd is running don't use setuid bit. Otherwise, use wlroots direct session like before to keep POLA. For example, $ sway [ERROR] [libseat] [libseat/libseat.c:73] libseat_open_seat: No backend was able to open a seat [ERROR] [backend/session/libseat.c:102] Unable to create seat: Function not implemented <direct session started> $ ps -lp $(pgrep -x sway) UID PID PPID C PRI NI VSZ RSS MWCHAN STAT TT TIME COMMAND 1234 63621 63611 0 20 0 279152 107156 select S v0 0:01.11 sway 0 63623 63621 6 52 0 32124 18396 sbwait I v0 0:00.00 sway vs. $ service seatd onestart $ sway <libseat session started> $ ps -lp $(pgrep -x sway) UID PID PPID C PRI NI VSZ RSS MWCHAN STAT TT TIME COMMAND 1234 46290 46280 4 20 0 332924 105248 select S v0 0:05.47 sway
Notes
Notes: svn path=/head/; revision=553548
Diffstat (limited to 'sysutils/seatd')
-rw-r--r--sysutils/seatd/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/sysutils/seatd/Makefile b/sysutils/seatd/Makefile
index 954cd732fd87..37a8bd63bf30 100644
--- a/sysutils/seatd/Makefile
+++ b/sysutils/seatd/Makefile
@@ -2,6 +2,7 @@
PORTNAME= seatd
DISTVERSION= 0.4.0
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= https://git.sr.ht/~kennylevinsen/${PORTNAME}/archive/${DISTVERSIONFULL}${EXTRACT_SUFX}?dummy=/
@@ -14,16 +15,19 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= compiler:c11 meson pkgconfig
USE_LDCONFIG= yes
USE_RC_SUBR= ${PORTNAME}
-MESON_ARGS= -Dbuiltin=enabled # SUID fallback
PLIST_FILES= bin/${PORTNAME} \
include/libseat.h \
lib/libseat.so \
lib/libseat.so.1 \
libdata/pkgconfig/libseat.pc
-OPTIONS_DEFINE= MANPAGES
+OPTIONS_DEFINE= MANPAGES SUID
+# XXX enable SUID after wlroots removes direct session
OPTIONS_DEFAULT=MANPAGES
+SUID_DESC= Fall back to builtin server when running as root
+SUID_MESON_ENABLED= builtin
+
MANPAGES_BUILD_DEPENDS= scdoc:textproc/scdoc
MANPAGES_MESON_ENABLED= man-pages
MANPAGES_PLIST_FILES= man/man1/${PORTNAME}.1.gz