aboutsummaryrefslogtreecommitdiff
path: root/sysutils/showbeastie
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-03-02 17:44:00 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-03-02 17:44:00 +0000
commitab71ff83d37a091ceef199b9e7bee832a8994135 (patch)
tree4caafc37b434039ab79cbc5b6f7166f56993ef6f /sysutils/showbeastie
parent0a91065b7ca1cf9b70c47a1d819df5f42d342184 (diff)
downloadports-ab71ff83d37a091ceef199b9e7bee832a8994135.tar.gz
ports-ab71ff83d37a091ceef199b9e7bee832a8994135.zip
sysutils/showbeastie: Fix build after base r329859
In file included from ficl.c:61: /usr/include/stdlib.h:89:1: error: unknown type name 'jagged' double atof(const char *); ^ <command line>:2:16: note: expanded from here #define double jagged-little-pill ^
Notes
Notes: svn path=/head/; revision=463421
Diffstat (limited to 'sysutils/showbeastie')
-rw-r--r--sysutils/showbeastie/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/sysutils/showbeastie/Makefile b/sysutils/showbeastie/Makefile
index edc1cb4b6f21..6fe7eacdf005 100644
--- a/sysutils/showbeastie/Makefile
+++ b/sysutils/showbeastie/Makefile
@@ -45,12 +45,14 @@ pre-patch:
-cf - . | ${TAR} -C ${WRKSRC}/.. -xf -
post-patch:
- ${REINPLACE_CMD} 's|-I.*/\.\./common|-I${SRC_STAND}/common|g' \
+ @${REINPLACE_CMD} 's|-I.*/\.\./common|-I${SRC_STAND}/common|g' \
${WRKSRC}/Makefile
-
+ @if [ -f "${WRKSRC}/../defs.mk" ]; then \
+ ${REINPLACE_CMD} '/jagged-little-pill/d' ${WRKSRC}/../defs.mk \
+ ; fi
# Make sure building on FreeBSD 11.0/i386 works. Calls to biospci_* are not
# needed for this program.
- ${REINPLACE_CMD} 's|ifdef __i386__|if 0|g' ${WRKSRC}/loader.c
+ @${REINPLACE_CMD} 's|ifdef __i386__|if 0|g' ${WRKSRC}/loader.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/testmain ${STAGEDIR}${PREFIX}/bin/${PORTNAME}