aboutsummaryrefslogtreecommitdiff
path: root/sysutils/showbeastie
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2016-12-17 14:41:07 +0000
committerJason E. Hale <jhale@FreeBSD.org>2016-12-17 14:41:07 +0000
commitfac26a0c6f9a0e4f3439d4c42eb84fc4bee1b0ec (patch)
treea14f9b0a1e9fc9368d68c9215c9dc45d9eaf9d8e /sysutils/showbeastie
parent05d0a36520b2ff654684ba3b1df2af74a34de0d7 (diff)
downloadports-fac26a0c6f9a0e4f3439d4c42eb84fc4bee1b0ec.tar.gz
ports-fac26a0c6f9a0e4f3439d4c42eb84fc4bee1b0ec.zip
Update to 0.3
- Fix build on FreeBSD 12.0-CURRENT. sys/boot/ficl/Makefile now includes sys/boot/Makefile.ficl, so the directory the port copies is moved up one level - Showbeastie will now sleep until the user terminates it with Ctrl-c, which makes sure that logos and brands can be displayed correctly on 80x25 consoles PR: 214674 Submitted by: Tobias Kortkamp <t@tobik.me> (maintainer)
Notes
Notes: svn path=/head/; revision=428765
Diffstat (limited to 'sysutils/showbeastie')
-rw-r--r--sysutils/showbeastie/Makefile8
-rw-r--r--sysutils/showbeastie/files/patch-testmain.c7
2 files changed, 9 insertions, 6 deletions
diff --git a/sysutils/showbeastie/Makefile b/sysutils/showbeastie/Makefile
index 90c1ec2b93c4..dbcaf7a9eb95 100644
--- a/sysutils/showbeastie/Makefile
+++ b/sysutils/showbeastie/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= showbeastie
-PORTVERSION= 0.2
+PORTVERSION= 0.3
CATEGORIES= sysutils
MASTER_SITES= # none
DISTFILES= # none
@@ -27,11 +27,13 @@ MAKE_ARGS+= -m ${SRC_BASE}/share/mk
BROKEN_FreeBSD_9= builds but expects newer loader environment
+WRKSRC_SUBDIR= ficl
+
pre-patch:
@${MKDIR} ${WRKSRC}
- @${TAR} -C ${SRC_BASE}/sys/boot/ficl \
+ @${TAR} -C ${SRC_BASE}/sys/boot \
--exclude '*.o' --exclude '*.a' --exclude 'testmain' \
- -cf - . | ${TAR} -C ${WRKSRC} -xf -
+ -cf - . | ${TAR} -C ${WRKSRC}/.. -xf -
post-patch:
${REINPLACE_CMD} 's|-I.*/\.\./common|-I${SRC_BASE}/sys/boot/common|g' \
diff --git a/sysutils/showbeastie/files/patch-testmain.c b/sysutils/showbeastie/files/patch-testmain.c
index ab3b061fdf7b..197dc5b5a73c 100644
--- a/sysutils/showbeastie/files/patch-testmain.c
+++ b/sysutils/showbeastie/files/patch-testmain.c
@@ -1,4 +1,4 @@
---- testmain.c.orig 2015-10-11 17:48:47 UTC
+--- testmain.c.orig 2016-11-17 00:02:13 UTC
+++ testmain.c
@@ -296,6 +296,7 @@ void buildTestInterface(FICL_SYSTEM *pSy
ficlBuild(pSys, "cd", ficlChDir, FW_DEFAULT);
@@ -8,7 +8,7 @@
ficlBuild(pSys, "pwd", ficlGetCWD, FW_DEFAULT);
ficlBuild(pSys, "system", ficlSystem, FW_DEFAULT);
ficlBuild(pSys, "spewhash", spewHash, FW_DEFAULT);
-@@ -316,17 +317,58 @@ int main(int argc, char **argv)
+@@ -316,17 +317,59 @@ int main(int argc, char **argv)
buildTestInterface(pSys);
pVM = ficlNewVM(pSys);
@@ -63,7 +63,8 @@
+ ficlEvaluate(pVM, "draw-beastie");
+ ficlEvaluate(pVM, "draw-brand");
+ ficlEvaluate(pVM, "menu-init");
-+ printf("\n\n");
++ fflush(stdout);
++ sleep(3600); // sleep "forever"
+ return 0;
+
for (;;)