aboutsummaryrefslogtreecommitdiff
path: root/sysutils/slurm-wlm
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2020-12-01 22:02:47 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2020-12-01 22:02:47 +0000
commit128364843209a695e638da3633f2fe54e0bd867e (patch)
treeb185faadaeb9cd532271f549e504f39100b16f2c /sysutils/slurm-wlm
parentedd26c4cf89f4998ab23dd0b881121cd65c2c6b1 (diff)
downloadports-128364843209a695e638da3633f2fe54e0bd867e.tar.gz
ports-128364843209a695e638da3633f2fe54e0bd867e.zip
sysutils/slurm-wlm: Patch in lua 5.4 support
PR opened upstream Make sure patch files have meaningful names PR: 251471 Reported by: greg@unrelenting.technology
Notes
Notes: svn path=/head/; revision=556796
Diffstat (limited to 'sysutils/slurm-wlm')
-rw-r--r--sysutils/slurm-wlm/Makefile2
-rw-r--r--sysutils/slurm-wlm/files/patch-c8be6ceb.c25
-rw-r--r--sysutils/slurm-wlm/files/patch-configure38
-rw-r--r--sysutils/slurm-wlm/files/patch-src_scancel_scancel.c10
-rw-r--r--sysutils/slurm-wlm/files/patch-src_scancel_scancel.h11
5 files changed, 60 insertions, 26 deletions
diff --git a/sysutils/slurm-wlm/Makefile b/sysutils/slurm-wlm/Makefile
index ed853220a67a..3f7328c0491e 100644
--- a/sysutils/slurm-wlm/Makefile
+++ b/sysutils/slurm-wlm/Makefile
@@ -2,7 +2,7 @@
PORTNAME= slurm
DISTVERSION= 20.02.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils python
MASTER_SITES= https://download.schedmd.com/slurm/
PKGNAMESUFFIX= -wlm
diff --git a/sysutils/slurm-wlm/files/patch-c8be6ceb.c b/sysutils/slurm-wlm/files/patch-c8be6ceb.c
deleted file mode 100644
index 645ab28d0c54..000000000000
--- a/sysutils/slurm-wlm/files/patch-c8be6ceb.c
+++ /dev/null
@@ -1,25 +0,0 @@
-diff --git a/src/scancel/scancel.c b/src/scancel/scancel.c
-index 4448b75599..23594fe0bf 100644
---- src/scancel/scancel.c
-+++ src/scancel/scancel.c
-@@ -99,6 +99,7 @@ static pthread_cond_t num_active_threads_cond;
- static pthread_mutex_t max_delay_lock;
- static uint32_t max_resp_time = 0;
- static int request_count = 0;
-+opt_t opt;
-
- int
- main (int argc, char **argv)
-diff --git a/src/scancel/scancel.h b/src/scancel/scancel.h
-index a0c9d8a829..678bcd7616 100644
---- src/scancel/scancel.h
-+++ src/scancel/scancel.h
-@@ -75,7 +75,7 @@ typedef struct scancel_options {
- bool *job_pend; /* Set fi job is pending */
- } opt_t;
-
--opt_t opt;
-+extern opt_t opt;
-
- /* process options:
- * 1. set defaults
diff --git a/sysutils/slurm-wlm/files/patch-configure b/sysutils/slurm-wlm/files/patch-configure
new file mode 100644
index 000000000000..5fb3c989de75
--- /dev/null
+++ b/sysutils/slurm-wlm/files/patch-configure
@@ -0,0 +1,38 @@
+--- configure.orig 2020-11-30 15:56:36 UTC
++++ configure
+@@ -24075,8 +24075,24 @@ fi
+
+
+ x_ac_lua_pkg_name="lua"
+- #check for 5.3 then 5.2 then 5.1
+- if test -n "$PKG_CONFIG" && \
++ #check for 5.4 then 5.3 then 5.2 then 5.1
++if test -n "$PKG_CONFIG" && \
++ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"lua5.4\""; } >&5
++ ($PKG_CONFIG --exists --print-errors "lua5.4") 2>&5
++ ac_status=$?
++ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
++ test $ac_status = 0; }; then
++ x_ac_lua_pkg_name=lua5.4
++else
++ if test -n "$PKG_CONFIG" && \
++ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"lua-5.4\""; } >&5
++ ($PKG_CONFIG --exists --print-errors "lua-5.4") 2>&5
++ ac_status=$?
++ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
++ test $ac_status = 0; }; then
++ x_ac_lua_pkg_name=lua-5.4
++else
++ if test -n "$PKG_CONFIG" && \
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"lua5.3\""; } >&5
+ ($PKG_CONFIG --exists --print-errors "lua5.3") 2>&5
+ ac_status=$?
+@@ -24125,6 +24141,8 @@ else
+ x_ac_lua_pkg_name=lua-5.1
+ else
+ x_ac_lua_pkg_name="lua >= 5.1"
++fi
++fi
+ fi
+ fi
+ fi
diff --git a/sysutils/slurm-wlm/files/patch-src_scancel_scancel.c b/sysutils/slurm-wlm/files/patch-src_scancel_scancel.c
new file mode 100644
index 000000000000..44d38bb6f0db
--- /dev/null
+++ b/sysutils/slurm-wlm/files/patch-src_scancel_scancel.c
@@ -0,0 +1,10 @@
+--- src/scancel/scancel.c.orig 2020-03-26 21:44:05 UTC
++++ src/scancel/scancel.c
+@@ -99,6 +99,7 @@ static pthread_cond_t num_active_threads_cond;
+ static pthread_mutex_t max_delay_lock;
+ static uint32_t max_resp_time = 0;
+ static int request_count = 0;
++opt_t opt;
+
+ int
+ main (int argc, char **argv)
diff --git a/sysutils/slurm-wlm/files/patch-src_scancel_scancel.h b/sysutils/slurm-wlm/files/patch-src_scancel_scancel.h
new file mode 100644
index 000000000000..f04da5e3d40b
--- /dev/null
+++ b/sysutils/slurm-wlm/files/patch-src_scancel_scancel.h
@@ -0,0 +1,11 @@
+--- src/scancel/scancel.h.orig 2020-03-26 21:44:05 UTC
++++ src/scancel/scancel.h
+@@ -75,7 +75,7 @@ typedef struct scancel_options {
+ bool *job_pend; /* Set fi job is pending */
+ } opt_t;
+
+-opt_t opt;
++extern opt_t opt;
+
+ /* process options:
+ * 1. set defaults