aboutsummaryrefslogtreecommitdiff
path: root/sysutils/slurm-wlm
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2020-12-08 16:21:16 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2020-12-08 16:21:16 +0000
commit23137bb0cc3a36fd51077596abf58a9447b1383f (patch)
tree73b3d3557b347360b0960b27e56f6b19fb41f04f /sysutils/slurm-wlm
parenta2758f114a6a0476e7113b667f33adef347b330f (diff)
downloadports-23137bb0cc3a36fd51077596abf58a9447b1383f.tar.gz
ports-23137bb0cc3a36fd51077596abf58a9447b1383f.zip
sysutils/slurm-wlm: Back out -fno-common patches, add -fcommon flag
Fixes runtime regression caused by r546150 Reported by: jrm MFH: 2020Q4
Notes
Notes: svn path=/head/; revision=557295
Diffstat (limited to 'sysutils/slurm-wlm')
-rw-r--r--sysutils/slurm-wlm/Makefile6
-rw-r--r--sysutils/slurm-wlm/files/patch-src_plugins_select_cons__tres_job__test.c26
-rw-r--r--sysutils/slurm-wlm/files/patch-src_scancel_scancel.c10
-rw-r--r--sysutils/slurm-wlm/files/patch-src_scancel_scancel.h11
4 files changed, 3 insertions, 50 deletions
diff --git a/sysutils/slurm-wlm/Makefile b/sysutils/slurm-wlm/Makefile
index 3f7328c0491e..cbfa24ea9d21 100644
--- a/sysutils/slurm-wlm/Makefile
+++ b/sysutils/slurm-wlm/Makefile
@@ -2,7 +2,7 @@
PORTNAME= slurm
DISTVERSION= 20.02.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= sysutils python
MASTER_SITES= https://download.schedmd.com/slurm/
PKGNAMESUFFIX= -wlm
@@ -82,8 +82,8 @@ RRD_CONFIGURE_WITH= rrdtool
CONFIGURE_ARGS= --without-ofed
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${DISTVERSION}
-CFLAGS+= -I${WRKSRC}/slurm -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -lsysinfo -lprocstat
+CFLAGS+= -I${WRKSRC}/slurm -I${LOCALBASE}/include -fcommon
+LDFLAGS+= -L${LOCALBASE}/lib -lsysinfo -lprocstat -fcommon
# Hack around nonfunctional --disable-gtktest flag
pre-configure-GUI-off:
diff --git a/sysutils/slurm-wlm/files/patch-src_plugins_select_cons__tres_job__test.c b/sysutils/slurm-wlm/files/patch-src_plugins_select_cons__tres_job__test.c
deleted file mode 100644
index 95640af1ae59..000000000000
--- a/sysutils/slurm-wlm/files/patch-src_plugins_select_cons__tres_job__test.c
+++ /dev/null
@@ -1,26 +0,0 @@
---- src/plugins/select/cons_tres/job_test.c.orig 2020-03-26 21:44:05 UTC
-+++ src/plugins/select/cons_tres/job_test.c
-@@ -41,23 +41,6 @@
-
- #define _DEBUG 0 /* Enables module specific debugging */
-
--/*
-- * These symbols are defined here so when we link with something other
-- * than the slurmctld we will have these symbols defined. They will get
-- * overwritten when linking with the slurmctld.
-- */
--#if defined (__APPLE__)
--extern slurmctld_config_t slurmctld_config __attribute__((weak_import));
--extern bitstr_t *idle_node_bitmap __attribute__((weak_import));
--extern node_record_t *node_record_table_ptr __attribute__((weak_import));
--extern List job_list __attribute__((weak_import));
--#else
--slurmctld_config_t slurmctld_config;
--bitstr_t *idle_node_bitmap;
--node_record_t *node_record_table_ptr;
--List job_list;
--#endif
--
- typedef struct node_weight_struct {
- bitstr_t *node_bitmap; /* bitmap of nodes with this weight */
- uint32_t weight; /* priority of node for scheduling work on */
diff --git a/sysutils/slurm-wlm/files/patch-src_scancel_scancel.c b/sysutils/slurm-wlm/files/patch-src_scancel_scancel.c
deleted file mode 100644
index 44d38bb6f0db..000000000000
--- a/sysutils/slurm-wlm/files/patch-src_scancel_scancel.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/scancel/scancel.c.orig 2020-03-26 21:44:05 UTC
-+++ src/scancel/scancel.c
-@@ -99,6 +99,7 @@ static pthread_cond_t num_active_threads_cond;
- static pthread_mutex_t max_delay_lock;
- static uint32_t max_resp_time = 0;
- static int request_count = 0;
-+opt_t opt;
-
- int
- main (int argc, char **argv)
diff --git a/sysutils/slurm-wlm/files/patch-src_scancel_scancel.h b/sysutils/slurm-wlm/files/patch-src_scancel_scancel.h
deleted file mode 100644
index f04da5e3d40b..000000000000
--- a/sysutils/slurm-wlm/files/patch-src_scancel_scancel.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/scancel/scancel.h.orig 2020-03-26 21:44:05 UTC
-+++ src/scancel/scancel.h
-@@ -75,7 +75,7 @@ typedef struct scancel_options {
- bool *job_pend; /* Set fi job is pending */
- } opt_t;
-
--opt_t opt;
-+extern opt_t opt;
-
- /* process options:
- * 1. set defaults