aboutsummaryrefslogtreecommitdiff
path: root/sysutils/smartmontools
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2012-06-19 20:36:11 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2012-06-19 20:36:11 +0000
commit26e3c2d2248c4e3f5c9ae18ad6daeacc897dc1f0 (patch)
tree53cb3796cb1bc0872df7f6c4dd8371062a5b89be /sysutils/smartmontools
parentc144e4a445907a170e07c0eaf7d387646ec92674 (diff)
downloadports-26e3c2d2248c4e3f5c9ae18ad6daeacc897dc1f0.tar.gz
ports-26e3c2d2248c4e3f5c9ae18ad6daeacc897dc1f0.zip
Notes
Diffstat (limited to 'sysutils/smartmontools')
-rw-r--r--sysutils/smartmontools/Makefile2
-rw-r--r--sysutils/smartmontools/files/patch-atacam25
2 files changed, 26 insertions, 1 deletions
diff --git a/sysutils/smartmontools/Makefile b/sysutils/smartmontools/Makefile
index e6bd3aabb32d..edf6fb268724 100644
--- a/sysutils/smartmontools/Makefile
+++ b/sysutils/smartmontools/Makefile
@@ -7,7 +7,7 @@
PORTNAME= smartmontools
PORTVERSION= 5.42
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= sysutils
MASTER_SITES= SF
diff --git a/sysutils/smartmontools/files/patch-atacam b/sysutils/smartmontools/files/patch-atacam
new file mode 100644
index 000000000000..54a106803fdf
--- /dev/null
+++ b/sysutils/smartmontools/files/patch-atacam
@@ -0,0 +1,25 @@
+--- os_freebsd.cpp 2012-05-31 17:43:19.000000000 +0400
++++ os_freebsd.cpp 2012-05-31 17:45:44.000000000 +0400
+@@ -1749,8 +1769,7 @@
+ if (ccb.cdm.matches[i].type == DEV_MATCH_BUS) {
+ bus_result = &ccb.cdm.matches[i].result.bus_result;
+
+- if (strcmp(bus_result->dev_name,"ata") == 0 /* ATAPICAM devices will be probed as ATA devices, skip'em there */
+- || strcmp(bus_result->dev_name,"xpt") == 0) /* skip XPT bus at all */
++ if (strcmp(bus_result->dev_name,"xpt") == 0) /* skip XPT bus at all */
+ skip_bus = 1;
+ else
+ skip_bus = 0;
+@@ -1773,8 +1792,10 @@
+ * We are searching for latest name
+ */
+ periph_result = &ccb.cdm.matches[i].result.periph_result;
+- devname = strprintf("%s%s%d", _PATH_DEV, periph_result->periph_name, periph_result->unit_number);
+- changed = 0;
++ if (strcmp(periph_result->periph_name, "pass")) {
++ devname = strprintf("%s%s%d", _PATH_DEV, periph_result->periph_name, periph_result->unit_number);
++ changed = 0;
++ }
+ };
+ if ((changed == 1 || show_all) && !devname.empty()) {
+ names.push_back(devname);