aboutsummaryrefslogtreecommitdiff
path: root/sysutils/solaar
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2020-01-13 09:38:12 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2020-01-13 09:38:12 +0000
commit5c28b85533a863d448bb2832394b638120f72630 (patch)
tree9a5051f657176e6f8379939b96fb13c325ef0e99 /sysutils/solaar
parent629c18619495f2a5ed6174005e1e89f8e7fb7008 (diff)
Notes
Diffstat (limited to 'sysutils/solaar')
-rw-r--r--sysutils/solaar/Makefile1
-rw-r--r--sysutils/solaar/files/patch-lib_logitech__receiver_settings.py17
2 files changed, 18 insertions, 0 deletions
diff --git a/sysutils/solaar/Makefile b/sysutils/solaar/Makefile
index 607ddf195ced..93796160719a 100644
--- a/sysutils/solaar/Makefile
+++ b/sysutils/solaar/Makefile
@@ -2,6 +2,7 @@
PORTNAME= solaar
DISTVERSION= 1.0.1
+PORTREVISION= 1
CATEGORIES= sysutils
MAINTAINER= tobik@FreeBSD.org
diff --git a/sysutils/solaar/files/patch-lib_logitech__receiver_settings.py b/sysutils/solaar/files/patch-lib_logitech__receiver_settings.py
new file mode 100644
index 000000000000..c8cb6054447e
--- /dev/null
+++ b/sysutils/solaar/files/patch-lib_logitech__receiver_settings.py
@@ -0,0 +1,17 @@
+Solaar will die with a silent error when trying to configure devices like
+e.g. the Logitech K400 that are detected as keyboards but also have
+mouse settings for an integrated touchpad. Remove the overly cautious
+assert.
+
+https://github.com/pwr/Solaar/issues/330
+
+--- lib/logitech_receiver/settings.py.orig 2019-07-26 15:55:51 UTC
++++ lib/logitech_receiver/settings.py
+@@ -61,7 +61,6 @@ class Setting(object):
+
+ def __call__(self, device):
+ assert not hasattr(self, '_value')
+- assert self.device_kind is None or device.kind in self.device_kind
+ p = device.protocol
+ if p == 1.0:
+ # HID++ 1.0 devices do not support features