aboutsummaryrefslogtreecommitdiff
path: root/sysutils/spiped
diff options
context:
space:
mode:
authorColin Percival <cperciva@FreeBSD.org>2014-05-11 01:39:40 +0000
committerColin Percival <cperciva@FreeBSD.org>2014-05-11 01:39:40 +0000
commite2f52ba444b36181a4420e2e5cbdbd7ee7a63b86 (patch)
tree26f5fb1f43352d2ea17b16e324c464ab660399a7 /sysutils/spiped
parent7addc2727e4cbf2b07437627a77d864f6097ac2c (diff)
downloadports-e2f52ba444b36181a4420e2e5cbdbd7ee7a63b86.tar.gz
ports-e2f52ba444b36181a4420e2e5cbdbd7ee7a63b86.zip
Notes
Diffstat (limited to 'sysutils/spiped')
-rw-r--r--sysutils/spiped/Makefile26
1 files changed, 10 insertions, 16 deletions
diff --git a/sysutils/spiped/Makefile b/sysutils/spiped/Makefile
index 2f6cacc7b6b2..d1b3f2e47b7b 100644
--- a/sysutils/spiped/Makefile
+++ b/sysutils/spiped/Makefile
@@ -10,34 +10,28 @@ EXTRACT_SUFX= .tgz
MAINTAINER= cperciva@tarsnap.com
COMMENT= Daemon for creating secure symmetric pipes
-LICENSE= BSD
+LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
-# Ask to have man pages installed
-MAKE_ARGS= MAN1DIR=${MANPREFIX}/man/man1
-MAN1= spiped.1 spipe.1
-
-# Binaries go into ${PREFIX}/bin
-MAKE_ARGS+= BINDIR=${PREFIX}/bin
+# Install into ${STAGEDIR}${PREFIX}
+MAKE_ARGS+= BINDIR=${STAGEDIR}${PREFIX}/bin
+MAKE_ARGS+= MAN1DIR=${STAGEDIR}${PREFIX}/man/man1
# Force __BSD_VISIBLE on since it works and improves performance
MAKE_ARGS+= CFLAGS="-O2 -D__BSD_VISIBLE"
PORTDOCS= BUILDING CHANGELOG COPYRIGHT README STYLE
-PLIST_FILES= bin/spiped bin/spipe
+PLIST_FILES= bin/spipe \
+ bin/spiped \
+ man/man1/spipe.1.gz \
+ man/man1/spiped.1.gz
USE_RC_SUBR= spiped
-NO_STAGE= yes
-
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- (cd ${WRKSRC} && ${INSTALL_MAN} ${PORTDOCS} ${DOCSDIR})
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>