aboutsummaryrefslogtreecommitdiff
path: root/sysutils/squashfs-tools
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2015-02-08 22:32:50 +0000
committerAshish SHUKLA <ashish@FreeBSD.org>2015-02-08 22:32:50 +0000
commit444283b2632a1c92f6ddccd34148f7893debf845 (patch)
tree501bb32b5cacfb1133917a4cd084fa6e3da1ba75 /sysutils/squashfs-tools
parent956e1ab761f38c390e78a53bb1eee1e49716c139 (diff)
downloadports-444283b2632a1c92f6ddccd34148f7893debf845.tar.gz
ports-444283b2632a1c92f6ddccd34148f7893debf845.zip
Notes
Diffstat (limited to 'sysutils/squashfs-tools')
-rw-r--r--sysutils/squashfs-tools/Makefile2
-rw-r--r--sysutils/squashfs-tools/distinfo4
-rw-r--r--sysutils/squashfs-tools/files/patch-action.c19
-rw-r--r--sysutils/squashfs-tools/files/patch-squashfs-tools_unsquashfs.c18
-rw-r--r--sysutils/squashfs-tools/pkg-descr2
5 files changed, 31 insertions, 14 deletions
diff --git a/sysutils/squashfs-tools/Makefile b/sysutils/squashfs-tools/Makefile
index e37ddb956a23..2a4210386eea 100644
--- a/sysutils/squashfs-tools/Makefile
+++ b/sysutils/squashfs-tools/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= squashfs-tools
-PORTVERSION= 4.2
+PORTVERSION= 4.3
CATEGORIES= sysutils
MASTER_SITES= SF/squashfs/squashfs/${DISTNAME}/
DISTNAME= squashfs${PORTVERSION}
diff --git a/sysutils/squashfs-tools/distinfo b/sysutils/squashfs-tools/distinfo
index e89cf9bd33c5..b93746d97ae6 100644
--- a/sysutils/squashfs-tools/distinfo
+++ b/sysutils/squashfs-tools/distinfo
@@ -1,2 +1,2 @@
-SHA256 (squashfs4.2.tar.gz) = d9e0195aa922dbb665ed322b9aaa96e04a476ee650f39bbeadb0d00b24022e96
-SIZE (squashfs4.2.tar.gz) = 133173
+SHA256 (squashfs4.3.tar.gz) = 0d605512437b1eb800b4736791559295ee5f60177e102e4d4ccd0ee241a5f3f6
+SIZE (squashfs4.3.tar.gz) = 182550
diff --git a/sysutils/squashfs-tools/files/patch-action.c b/sysutils/squashfs-tools/files/patch-action.c
new file mode 100644
index 000000000000..a5732dc6709d
--- /dev/null
+++ b/sysutils/squashfs-tools/files/patch-action.c
@@ -0,0 +1,19 @@
+Hack for lack of strdupa() in BSD libc
+
+$FreeBSD$
+
+--- action.c.orig
++++ action.c
+@@ -44,6 +44,12 @@
+ #include "action.h"
+ #include "error.h"
+
++#ifndef strdupa
++#include <string.h> // required for str*()
++#include <stdlib.h> // required for alloca
++#define strdupa(foo) (strncpy( alloca( strlen(foo) + 1 ), foo, strlen( foo ) + 1 ))
++#endif
++
+ /*
+ * code to parse actions
+ */
diff --git a/sysutils/squashfs-tools/files/patch-squashfs-tools_unsquashfs.c b/sysutils/squashfs-tools/files/patch-squashfs-tools_unsquashfs.c
index a67b8778678f..9b4ab4e475b4 100644
--- a/sysutils/squashfs-tools/files/patch-squashfs-tools_unsquashfs.c
+++ b/sysutils/squashfs-tools/files/patch-squashfs-tools_unsquashfs.c
@@ -1,21 +1,19 @@
$FreeBSD$
---- unsquashfs.c.orig 2010-09-20 03:14:38.000000000 +0530
-+++ unsquashfs.c 2010-09-29 09:34:43.000000000 +0530
-@@ -29,9 +29,16 @@
- #include "compressor.h"
- #include "xattr.h"
+--- unsquashfs.c.orig
++++ unsquashfs.c
+@@ -31,7 +31,14 @@
+ #include "unsquashfs_info.h"
+ #include "stdarg.h"
+#ifdef __linux__
#include <sys/sysinfo.h>
+#endif
+
- #include <sys/types.h>
-
+#ifdef __FreeBSD__
+#include <sys/sysctl.h>
+#endif
+
- struct cache *fragment_cache, *data_cache;
- struct queue *to_reader, *to_deflate, *to_writer, *from_writer;
- pthread_t *thread, *deflator_thread;
+ #include <sys/types.h>
+ #include <sys/time.h>
+ #include <sys/resource.h>
diff --git a/sysutils/squashfs-tools/pkg-descr b/sysutils/squashfs-tools/pkg-descr
index d2fc6eae74c2..75dfa6020d33 100644
--- a/sysutils/squashfs-tools/pkg-descr
+++ b/sysutils/squashfs-tools/pkg-descr
@@ -7,4 +7,4 @@ PowerPC, i586, Sparc and ARM architectures.
squashfs-tools are the set of tools to manipulate squashfs images.
-WWW: http://squashfs.sourceforge.net/
+WWW: http://squashfs.sourceforge.net/