aboutsummaryrefslogtreecommitdiff
path: root/sysutils/stow/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-02-20 00:06:54 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-02-20 00:06:54 +0000
commit3b0c987220ef5fe049f964013a235fd442324c90 (patch)
treead9ec8212dab88544d7398412760f95bf14a94da /sysutils/stow/Makefile
parent007ecbefd4280fe5dbfe1cb064d41a786be3ad6a (diff)
Notes
Diffstat (limited to 'sysutils/stow/Makefile')
-rw-r--r--sysutils/stow/Makefile34
1 files changed, 28 insertions, 6 deletions
diff --git a/sysutils/stow/Makefile b/sysutils/stow/Makefile
index 49780d186ee5..054970042556 100644
--- a/sysutils/stow/Makefile
+++ b/sysutils/stow/Makefile
@@ -8,23 +8,45 @@
PORTNAME= stow
PORTVERSION= 2.1.3
+PORTREVISION= 1
CATEGORIES= sysutils
-MASTER_SITES= ${MASTER_SITE_GNU}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= GNU
MAINTAINER= ports@FreeBSD.org
COMMENT= GNU version of Carnegie Mellon's "Depot" program
-LICENSE= GPLv3
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
TEST_DEPENDS= p5-Test-Output>0:${PORTSDIR}/devel/p5-Test-Output
-GNU_CONFIGURE= yes
USE_BZIP2= yes
-USE_GMAKE= yes
USE_PERL5= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= ac_cv_path_PERL=${PERL}
+INSTALL_TARGET= install-exec-am install-dist_pmstowDATA install-info-am \
+ install-man install-pmDATA
-INFO= stow
MAN8= stow.8
+INFO= stow
+PORTDOCS= *
+PLIST_FILES= bin/chkstow \
+ bin/stow \
+ %%SITE_PERL%%/Stow.pm \
+ %%SITE_PERL%%/Stow/Util.pm
+PLIST_DIRS= %%SITE_PERL%%/Stow
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for FILE in ChangeLog README
+ ${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+.endfor
+.for FILE in ChangeLog.OLD manual-single.html manual.pdf version.texi
+ ${INSTALL_DATA} ${WRKSRC}/doc/${FILE} ${DOCSDIR}
+.endfor
+ @(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} manual-split ${DOCSDIR})
+.endif
.include <bsd.port.mk>