aboutsummaryrefslogtreecommitdiff
path: root/sysutils/synergy
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2015-08-13 06:33:29 +0000
committerKevin Lo <kevlo@FreeBSD.org>2015-08-13 06:33:29 +0000
commitfc51c02c2cd5ff7f79770cdbbfef2726a9033909 (patch)
tree9cbf8ff2c44efd81ad8216eac1d29da5a9520f03 /sysutils/synergy
parent68e9e300cecdb59db079689d71e10e1bf4d615fb (diff)
downloadports-fc51c02c2cd5ff7f79770cdbbfef2726a9033909.tar.gz
ports-fc51c02c2cd5ff7f79770cdbbfef2726a9033909.zip
Update to 1.7.4
Notes
Notes: svn path=/head/; revision=394053
Diffstat (limited to 'sysutils/synergy')
-rw-r--r--sysutils/synergy/Makefile10
-rw-r--r--sysutils/synergy/distinfo4
-rw-r--r--sysutils/synergy/files/patch-CMakeLists.txt6
-rw-r--r--sysutils/synergy/files/patch-src_CMakeLists.txt15
-rw-r--r--sysutils/synergy/files/patch-src_lib_arch_CMakeLists.txt13
-rw-r--r--sysutils/synergy/files/patch-src_test_CMakeLists.txt36
6 files changed, 56 insertions, 28 deletions
diff --git a/sysutils/synergy/Makefile b/sysutils/synergy/Makefile
index ec828d79236b..f1aa69ed4ce8 100644
--- a/sysutils/synergy/Makefile
+++ b/sysutils/synergy/Makefile
@@ -1,14 +1,14 @@
# $FreeBSD$
PORTNAME= synergy
-PORTVERSION= 1.7.3
+PORTVERSION= 1.7.4
CATEGORIES= sysutils
MAINTAINER= kevlo@FreeBSD.org
COMMENT= Mouse and keyboard sharing utility
LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
+LICENSE_FILE= ${WRKSRC}/LICENSE
USES= cmake cpe
CPE_VENDOR= synergy-foss
@@ -31,12 +31,6 @@ PORTEXAMPLES= synergy.conf.example synergy.conf.example-basic \
OPTIONS_DEFINE= EXAMPLES
-post-extract:
- cp ${WRKSRC}/LICENSE ${WRKSRC}/COPYING
- ${MKDIR} -p ${WRKSRC}/ext/gmock-1.6.0 ${WRKSRC}/ext/gtest-1.6.0
- (cd ${WRKSRC}/ext/gmock-1.6.0 && ${TAR} xfz ../gmock-1.6.0.zip)
- (cd ${WRKSRC}/ext/gtest-1.6.0 && ${TAR} xfz ../gtest-1.6.0.zip)
-
do-install:
.for f in synergyc synergyd synergys
${INSTALL_PROGRAM} ${WRKSRC}/bin/${f} ${STAGEDIR}${PREFIX}/bin
diff --git a/sysutils/synergy/distinfo b/sysutils/synergy/distinfo
index 21610f29898b..ffd0498418ee 100644
--- a/sysutils/synergy/distinfo
+++ b/sysutils/synergy/distinfo
@@ -1,2 +1,2 @@
-SHA256 (synergy-synergy-v1.7.3-stable_GH0.tar.gz) = a4effc3ddb0ef6de95f83fa62b5290e2909f8b76729b1bde89c5061e5d381e25
-SIZE (synergy-synergy-v1.7.3-stable_GH0.tar.gz) = 13661943
+SHA256 (synergy-synergy-v1.7.4-stable_GH0.tar.gz) = 215dc3918b9f3ddfb57cc963f8df6751e5e834fd90c0a8b2767091589b012bdf
+SIZE (synergy-synergy-v1.7.4-stable_GH0.tar.gz) = 13665193
diff --git a/sysutils/synergy/files/patch-CMakeLists.txt b/sysutils/synergy/files/patch-CMakeLists.txt
index 1987785b125f..f43637ab70bd 100644
--- a/sysutils/synergy/files/patch-CMakeLists.txt
+++ b/sysutils/synergy/files/patch-CMakeLists.txt
@@ -1,6 +1,6 @@
---- CMakeLists.txt.orig 2015-05-26 15:56:21 UTC
-+++ CMakeLists.txt
-@@ -74,10 +74,6 @@ endif()
+--- CMakeLists.txt.orig 2015-05-26 23:56:21.000000000 +0800
++++ CMakeLists.txt 2015-08-03 14:02:26.524577000 +0800
+@@ -74,10 +74,6 @@
# Depending on the platform, pass in the required defines.
if (UNIX)
diff --git a/sysutils/synergy/files/patch-src_CMakeLists.txt b/sysutils/synergy/files/patch-src_CMakeLists.txt
index 89b79c6fe94c..c3c6e7144423 100644
--- a/sysutils/synergy/files/patch-src_CMakeLists.txt
+++ b/sysutils/synergy/files/patch-src_CMakeLists.txt
@@ -1,11 +1,10 @@
---- src/CMakeLists.txt.orig 2015-05-26 15:56:21 UTC
-+++ src/CMakeLists.txt
-@@ -18,6 +18,7 @@ add_subdirectory(lib)
+--- src/CMakeLists.txt.orig 2015-08-13 10:21:27.325279000 +0800
++++ src/CMakeLists.txt 2015-08-13 10:21:43.969252000 +0800
+@@ -17,7 +17,3 @@
+ add_subdirectory(lib)
add_subdirectory(cmd)
add_subdirectory(micro)
-
+-
-if (NOT ${CMAKE_SYSTEM_NAME} MATCHES "IRIX")
-+if (NOT ${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD"
-+ AND NOT ${CMAKE_SYSTEM_NAME} MATCHES "IRIX")
- add_subdirectory(test)
- endif()
+- add_subdirectory(test)
+-endif()
diff --git a/sysutils/synergy/files/patch-src_lib_arch_CMakeLists.txt b/sysutils/synergy/files/patch-src_lib_arch_CMakeLists.txt
index 372a0c362cb2..6482461541a5 100644
--- a/sysutils/synergy/files/patch-src_lib_arch_CMakeLists.txt
+++ b/sysutils/synergy/files/patch-src_lib_arch_CMakeLists.txt
@@ -1,10 +1,9 @@
---- src/lib/arch/CMakeLists.txt.orig 2015-05-26 15:56:21 UTC
-+++ src/lib/arch/CMakeLists.txt
-@@ -49,6 +49,6 @@ endif()
-
+--- src/lib/arch/CMakeLists.txt.orig 2015-08-03 10:52:29.431081000 +0800
++++ src/lib/arch/CMakeLists.txt 2015-08-03 10:52:45.330309000 +0800
+@@ -50,5 +50,5 @@
add_library(arch STATIC ${sources})
--if (UNIX)
-+if (UNIX AND NOT ${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
- target_link_libraries(arch dl ${libs})
+ if (UNIX)
+- target_link_libraries(arch dl ${libs})
++ target_link_libraries(arch ${libs})
endif()
diff --git a/sysutils/synergy/files/patch-src_test_CMakeLists.txt b/sysutils/synergy/files/patch-src_test_CMakeLists.txt
new file mode 100644
index 000000000000..f0291a0c40fd
--- /dev/null
+++ b/sysutils/synergy/files/patch-src_test_CMakeLists.txt
@@ -0,0 +1,36 @@
+--- src/test/CMakeLists.txt.orig 2015-05-26 23:56:21.000000000 +0800
++++ src/test/CMakeLists.txt 2015-08-03 10:48:57.642889000 +0800
+@@ -1,33 +0,0 @@
+-# synergy -- mouse and keyboard sharing utility
+-# Copyright (C) 2012 Synergy Si Ltd.
+-# Copyright (C) 2011 Nick Bolton
+-#
+-# This package is free software; you can redistribute it and/or
+-# modify it under the terms of the GNU General Public License
+-# found in the file LICENSE that should have accompanied this file.
+-#
+-# This package is distributed in the hope that it will be useful,
+-# but WITHOUT ANY WARRANTY; without even the implied warranty of
+-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+-# GNU General Public License for more details.
+-#
+-# You should have received a copy of the GNU General Public License
+-# along with this program. If not, see <http://www.gnu.org/licenses/>.
+-
+-include_directories(
+- ../../ext/gtest-1.6.0
+- ../../ext/gtest-1.6.0/include
+- ../../ext/gmock-1.6.0
+- ../../ext/gmock-1.6.0/include)
+-
+-add_library(gtest STATIC ../../ext/gtest-1.6.0/src/gtest-all.cc)
+-add_library(gmock STATIC ../../ext/gmock-1.6.0/src/gmock-all.cc)
+-
+-if (UNIX)
+- # ignore warnings in gtest and gmock
+- set_target_properties(gtest PROPERTIES COMPILE_FLAGS "-w")
+- set_target_properties(gmock PROPERTIES COMPILE_FLAGS "-w")
+-endif()
+-
+-add_subdirectory(integtests)
+-add_subdirectory(unittests)