aboutsummaryrefslogtreecommitdiff
path: root/sysutils/sysgather
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2006-02-06 19:46:02 +0000
committerPeter Pentchev <roam@FreeBSD.org>2006-02-06 19:46:02 +0000
commit5824d11798253f8b3dc6f209b1ff963bc4ed8978 (patch)
tree5161634b3498ed80a461d242659587e920d20049 /sysutils/sysgather
parentf1acb1a85539f87fdcdc0b0356df5ef6fe863ce4 (diff)
downloadports-5824d11798253f8b3dc6f209b1ff963bc4ed8978.tar.gz
ports-5824d11798253f8b3dc6f209b1ff963bc4ed8978.zip
Add sysgather-1.0pre3 - a simple configuration file manager that makes
it easier to keep track of configuration files using a version control system.
Notes
Notes: svn path=/head/; revision=155367
Diffstat (limited to 'sysutils/sysgather')
-rw-r--r--sysutils/sysgather/Makefile24
-rw-r--r--sysutils/sysgather/distinfo3
-rw-r--r--sysutils/sysgather/pkg-descr5
-rw-r--r--sysutils/sysgather/pkg-plist4
4 files changed, 36 insertions, 0 deletions
diff --git a/sysutils/sysgather/Makefile b/sysutils/sysgather/Makefile
new file mode 100644
index 000000000000..6bbd40d878db
--- /dev/null
+++ b/sysutils/sysgather/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: sysgather
+# Date created: 16 December 2005
+# Whom: roam@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= sysgather
+PORTVERSION= 1.0.b3
+CATEGORIES= sysutils
+MASTER_SITES= http://devel.ringlet.net/sysutils/sysgather/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.b/pre/}
+
+MAINTAINER= roam@FreeBSD.org
+COMMENT= Keep configuration files under version control
+
+BUILD_DEPENDS= ${SITE_PERL}/Config/IniFiles.pm:${PORTSDIR}/devel/p5-Config-IniFiles
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PERL5= yes
+
+MAN1= sysgather.1
+
+.include <bsd.port.mk>
diff --git a/sysutils/sysgather/distinfo b/sysutils/sysgather/distinfo
new file mode 100644
index 000000000000..bd6dff1c0495
--- /dev/null
+++ b/sysutils/sysgather/distinfo
@@ -0,0 +1,3 @@
+MD5 (sysgather-1.0pre3.tar.gz) = f5d39dbf71c76468cce4157c4b8ac0b5
+SHA256 (sysgather-1.0pre3.tar.gz) = ba5951d50af4c36b5daad53cf02339dbfd021cef3c04f36132ef8ac9b143c8c4
+SIZE (sysgather-1.0pre3.tar.gz) = 6969
diff --git a/sysutils/sysgather/pkg-descr b/sysutils/sysgather/pkg-descr
new file mode 100644
index 000000000000..40b15a24e0f9
--- /dev/null
+++ b/sysutils/sysgather/pkg-descr
@@ -0,0 +1,5 @@
+sysgather is a simple command-line utility for keeping configuration files
+under version control.
+
+WWW: http://devel.ringlet.net/sysutils/sysgather/
+Author: Peter Pentchev <roam@ringlet.net>
diff --git a/sysutils/sysgather/pkg-plist b/sysutils/sysgather/pkg-plist
new file mode 100644
index 000000000000..c0c9ce00bf52
--- /dev/null
+++ b/sysutils/sysgather/pkg-plist
@@ -0,0 +1,4 @@
+bin/sysgather
+@unexec if cmp -s %D/etc/sysgather.conf %D/etc/sysgather.conf.default; then rm -f %D/etc/sysgather.conf; fi
+etc/sysgather.conf.default
+@exec [ -f %B/sysgather.conf ] || cp %B/%f %B/sysgather.conf