aboutsummaryrefslogtreecommitdiff
path: root/sysutils/sysgather
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2006-02-10 11:14:47 +0000
committerPeter Pentchev <roam@FreeBSD.org>2006-02-10 11:14:47 +0000
commitec772577a58fec1dcab6ccbab7c5462ba9304a0b (patch)
tree50a91dee2030ea7bcfc531f68b36e9d82c16729b /sysutils/sysgather
parenteb8e70347a09f15e6ef0fced2a9b955fbee95d76 (diff)
downloadports-ec772577a58fec1dcab6ccbab7c5462ba9304a0b.tar.gz
ports-ec772577a58fec1dcab6ccbab7c5462ba9304a0b.zip
Make this work with Perl 5.005:
- supply a second argument to mkdir(); - bypass the podchecker invocation on Perl 5.005, which simply does not have it. Reported by: pointyhat via kris
Notes
Notes: svn path=/head/; revision=155637
Diffstat (limited to 'sysutils/sysgather')
-rw-r--r--sysutils/sysgather/Makefile8
-rw-r--r--sysutils/sysgather/files/patch-Makefile24
-rw-r--r--sysutils/sysgather/files/patch-sysgather.pl40
3 files changed, 71 insertions, 1 deletions
diff --git a/sysutils/sysgather/Makefile b/sysutils/sysgather/Makefile
index 209ab467b7f9..294d1e54c5b0 100644
--- a/sysutils/sysgather/Makefile
+++ b/sysutils/sysgather/Makefile
@@ -21,4 +21,10 @@ USE_PERL5= yes
MAN1= sysgather.1
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+MAKE_ENV+= PODCHECKER=true PODCHECKER_ARGS=
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/sysgather/files/patch-Makefile b/sysutils/sysgather/files/patch-Makefile
new file mode 100644
index 000000000000..b7d68f5e7f37
--- /dev/null
+++ b/sysutils/sysgather/files/patch-Makefile
@@ -0,0 +1,24 @@
+Index: Makefile
+===================================================================
+--- Makefile (revision 217)
++++ Makefile (revision 218)
+@@ -61,8 +61,10 @@
+ SED?= sed
+ CP?= cp
+ TAR?= tar
++PODCHECKER?= podchecker
+
+ TAR_CREATE?= -zcf
++PODCHECKER_ARGS?= -w
+
+ VERSION_MAJ?= 1
+ VERSION_MIN?= 0
+@@ -84,7 +86,7 @@
+ perl -c ${PROG}
+
+ ${MANPAGE}: ${PROG}
+- podchecker -w ${PROG}
++ ${PODCHECKER} ${PODCHECKER_ARGS} ${PROG}
+ pod2man --section=1 ${PROG} > ${MANPAGE} || ${RM} ${MANPAGE}
+
+ ${REALCONF}: ${TESTCONF}
diff --git a/sysutils/sysgather/files/patch-sysgather.pl b/sysutils/sysgather/files/patch-sysgather.pl
new file mode 100644
index 000000000000..eb292e4f01b8
--- /dev/null
+++ b/sysutils/sysgather/files/patch-sysgather.pl
@@ -0,0 +1,40 @@
+Index: sysgather.pl
+===================================================================
+--- sysgather.pl (revision 217)
++++ sysgather.pl (revision 219)
+@@ -211,7 +211,7 @@
+ die "No base directory $g->{basedir} for $pkg\n";
+ }
+ if (! -d $g->{'confdir'}) {
+- mkdir $g->{'confdir'} or
++ mkdir $g->{'confdir'}, 0777 or
+ die "Could not create $g->{confdir}: $!\n";
+ }
+
+@@ -269,7 +269,7 @@
+ die "No source directory $g->{srcdir} for $pkg\n";
+ }
+ if (! -d $g->{'confdir'}) {
+- mkdir $g->{'confdir'} or
++ mkdir $g->{'confdir'}, 0777 or
+ die "Could not create $g->{confdir}: $!\n";
+ }
+
+@@ -325,7 +325,7 @@
+ die "No base directory $g->{basedir} for $pkg\n";
+ }
+ if (! -d $g->{'confdir'}) {
+- mkdir $g->{'confdir'} or
++ mkdir $g->{'confdir'}, 0777 or
+ die "Could not create $g->{confdir}: $!\n";
+ }
+
+@@ -457,7 +457,7 @@
+ die "No source directory $g->{srcdir} for $pkg\n";
+ }
+ if (! -d $g->{'confdir'}) {
+- mkdir $g->{'confdir'} or
++ mkdir $g->{'confdir'}, 0777 or
+ die "Could not create $g->{confdir}: $!\n";
+ }
+