aboutsummaryrefslogtreecommitdiff
path: root/sysutils/syslog-ng315/Makefile
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2019-01-13 20:58:36 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2019-01-13 20:58:36 +0000
commit2eb84a7a059fb89765e1d2e0676b6649fe4d384c (patch)
tree0ab3646146acd5dfea61c57f28f979f6613d0336 /sysutils/syslog-ng315/Makefile
parent8634eafdb93075a48cc744574b5ea40bec528073 (diff)
downloadports-2eb84a7a059fb89765e1d2e0676b6649fe4d384c.tar.gz
ports-2eb84a7a059fb89765e1d2e0676b6649fe4d384c.zip
Notes
Diffstat (limited to 'sysutils/syslog-ng315/Makefile')
-rw-r--r--sysutils/syslog-ng315/Makefile10
1 files changed, 2 insertions, 8 deletions
diff --git a/sysutils/syslog-ng315/Makefile b/sysutils/syslog-ng315/Makefile
index a5018a360b84..62370b16c4b1 100644
--- a/sysutils/syslog-ng315/Makefile
+++ b/sysutils/syslog-ng315/Makefile
@@ -3,7 +3,7 @@
PORTNAME= syslog-ng
DISTVERSION= 3.15.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= sysutils
DISTFILES= syslog-ng-${DISTVERSION}.tar.gz
MASTER_SITES= https://github.com/balabit/syslog-ng/releases/download/syslog-ng-${DISTVERSION}/
@@ -25,14 +25,13 @@ CONFLICTS?= syslog-ng-[0-9]* syslog-ng[0-9]-[0-9]* \
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
MAKE_JOBS_UNSAFE= yes
-OPTIONS_DEFINE= TCP_WRAPPERS SQL SPOOF IPV6 SMTP JSON GEOIP GEOIP2 DOCS REDIS JAVA PYTHON MONGO CURL JAVA_MOD AMQP
+OPTIONS_DEFINE= TCP_WRAPPERS SQL SPOOF IPV6 SMTP JSON GEOIP2 DOCS REDIS JAVA PYTHON MONGO CURL JAVA_MOD AMQP
OPTIONS_DEFAULT= CURL JSON
TCP_WRAPPERS_DESC= Build with TCP Wrappers
SQL_DESC= Build with database (libdbi) support
SPOOF_DESC= Build with spoof source support
SMTP_DESC= Build with SMTP support
JSON_DESC= Build with JSON-C support
-GEOIP_DESC= Build with GeoIP support (deprecated)
GEOIP2_DESC= Build with geoip2 (MaxMindDB) support
REDIS_DESC= Build with Redis support
JAVA_DESC= Build with Java support (no modules)
@@ -73,11 +72,6 @@ IPV6_CONFIGURE_ENABLE= ipv6
AMQP_CONFIGURE_ENABLE= amqp
AMQP_PLIST_FILES= lib/syslog-ng/libafamqp.so
-GEOIP_CONFIGURE_ENABLE= geoip
-GEOIP_LIB_DEPENDS= libGeoIP.so:net/GeoIP
-GEOIP_CONFIGURE_ENV= GEOIP_LIBS="-L${LOCALBASE}/lib -lGeoIP"
-GEOIP_PLIST_FILES= lib/syslog-ng/libgeoip-plugin.so
-
GEOIP2_CONFIGURE_ENABLE= geoip2
GEOIP2_LIB_DEPENDS= libmaxminddb.so:net/libmaxminddb
GEOIP2_LDFLAGS= -L${LOCALBASE}/lib