aboutsummaryrefslogtreecommitdiff
path: root/sysutils/tcplist
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2013-11-16 13:25:19 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2013-11-16 13:25:19 +0000
commitf9611b2a9ee29f2b13bd885f891745db91557a3e (patch)
tree448387c55dee1a0def3084635c218e0ee785b37f /sysutils/tcplist
parent137a5754fd88cd54c5e3c686f039dfc863f115f9 (diff)
downloadports-f9611b2a9ee29f2b13bd885f891745db91557a3e.tar.gz
ports-f9611b2a9ee29f2b13bd885f891745db91557a3e.zip
Support STAGEDIR.
Notes
Notes: svn path=/head/; revision=333992
Diffstat (limited to 'sysutils/tcplist')
-rw-r--r--sysutils/tcplist/Makefile2
-rw-r--r--sysutils/tcplist/files/patch-0127
-rw-r--r--sysutils/tcplist/pkg-plist2
3 files changed, 24 insertions, 7 deletions
diff --git a/sysutils/tcplist/Makefile b/sysutils/tcplist/Makefile
index 2a3f7c158d3d..82b79fb836be 100644
--- a/sysutils/tcplist/Makefile
+++ b/sysutils/tcplist/Makefile
@@ -18,7 +18,5 @@ EXTRACT_BEFORE_ARGS=
EXTRACT_AFTER_ARGS= |sh
NO_WRKSUBDIR= yes
INSTALL_TARGET= install install.man
-MAN1= tcplist.1
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/sysutils/tcplist/files/patch-01 b/sysutils/tcplist/files/patch-01
index e9abe9ee6291..4d10f8a98f2f 100644
--- a/sysutils/tcplist/files/patch-01
+++ b/sysutils/tcplist/files/patch-01
@@ -1,5 +1,5 @@
---- Makefile.orig Thu Apr 24 09:33:17 1997
-+++ Makefile Thu Apr 24 10:02:39 1997
+--- Makefile.orig 2013-11-16 20:34:19.000000000 +0800
++++ Makefile 2013-11-16 20:35:17.000000000 +0800
@@ -1,14 +1,16 @@
# Compiler: eg. cc or gcc
CC = cc
@@ -20,7 +20,7 @@
# Owner of tcplist executable
OWNER = root
-@@ -45,18 +47,18 @@
+@@ -45,18 +47,18 @@ MANEXT = 1
#
# Solaris 2.x (using LSOF):
#
@@ -47,7 +47,7 @@
#
# If you're using an old version of lsof, uncomment this:
-@@ -76,8 +78,8 @@
+@@ -76,8 +78,8 @@ OBJS = $(SRCS:.c=.o)
RM = /bin/rm -rf
CP = /bin/cp
CHMOD = /bin/chmod
@@ -58,3 +58,22 @@
all:: tcplist
+@@ -95,13 +97,13 @@ depend:
+
+ install: tcplist
+ strip tcplist
+- $(CP) tcplist $(BINDIR)
+- $(CHGRP) $(GROUP) $(BINDIR)/tcplist
+- $(CHMOD) $(MODE) $(BINDIR)/tcplist
++ $(CP) tcplist $(DESTDIR)$(BINDIR)
++ $(CHGRP) $(GROUP) $(DESTDIR)$(BINDIR)/tcplist
++ $(CHMOD) $(MODE) $(DESTDIR)$(BINDIR)/tcplist
+
+ install.man: tcplist.1
+- $(CP) tcplist.1 $(MANDIR)/tcplist.$(MANEXT)
+- $(CHMOD) $(MANMODE) $(MANDIR)/tcplist.$(MANEXT)
++ $(CP) tcplist.1 $(DESTDIR)$(MANDIR)/tcplist.$(MANEXT)
++ $(CHMOD) $(MANMODE) $(DESTDIR)$(MANDIR)/tcplist.$(MANEXT)
+
+ shar:
+ shar `awk '{print $$1}' MANIFEST` >tcplist-`awk '{print $$7;exit}' patchlevel.h`.shar
diff --git a/sysutils/tcplist/pkg-plist b/sysutils/tcplist/pkg-plist
index 4b61aea2acc3..62295c115b9c 100644
--- a/sysutils/tcplist/pkg-plist
+++ b/sysutils/tcplist/pkg-plist
@@ -1,2 +1,2 @@
-@comment $FreeBSD$
bin/tcplist
+man/man1/tcplist.1.gz