aboutsummaryrefslogtreecommitdiff
path: root/sysutils/testdisk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-04-28 12:46:39 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-04-28 12:46:39 +0000
commitb33b30947050d7236099e994c6074e8f43c21849 (patch)
tree5bc21ac2110ac4875b1d24a4735370a51f907577 /sysutils/testdisk
parent19d34bb573dbed0d4a86c038ffcaa7218dedf884 (diff)
downloadports-b33b30947050d7236099e994c6074e8f43c21849.tar.gz
ports-b33b30947050d7236099e994c6074e8f43c21849.zip
Stagify a bunch of ports maintained by flz
While here: - graphics/icoconvert: * Respect CC * Use modern LIB_DEPENDS - net/grdesktop: * Convert gnomehack to pathfix - net/ldapsh: * Use shebangfix instead of custom post-patch target - net-im/py-jabber: * Use autoplist - net-p2p/bnbt: * Use the options framework * Convert to dos2unix * Respect CXX * Do not renamed base on option - sysutils/testdisk: * Update to 6.14 * Use options helpers * Use modern LIB_DEPENDS * Convert USE_BZIP2 -> USES=tar:bzip2
Notes
Notes: svn path=/head/; revision=352490
Diffstat (limited to 'sysutils/testdisk')
-rw-r--r--sysutils/testdisk/Makefile54
-rw-r--r--sysutils/testdisk/distinfo4
2 files changed, 18 insertions, 40 deletions
diff --git a/sysutils/testdisk/Makefile b/sysutils/testdisk/Makefile
index e52ecf832a3b..6661dc3b7fe5 100644
--- a/sysutils/testdisk/Makefile
+++ b/sysutils/testdisk/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= testdisk
-PORTVERSION= 6.13
-PORTREVISION= 1
+PORTVERSION= 6.14
CATEGORIES= sysutils
MASTER_SITES= http://www.cgsecurity.org/
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
@@ -10,16 +9,18 @@ DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER= flz@FreeBSD.org
COMMENT= Tool to check and undelete partitions
-LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg
-USE_BZIP2= yes
+USES= tar:bzip2
GNU_CONFIGURE= yes
CPPFLAGS+= -I${PREFIX}/include
LDFLAGS+= -L${PREFIX}/lib
CONFIGURE_ARGS= --without-ewf
-MAN8= fidentify.8 testdisk.8 photorec.8
-PLIST_FILES= bin/fidentify bin/testdisk bin/photorec
+PLIST_FILES= bin/fidentify bin/testdisk bin/photorec \
+ man/man8/fidentify.8.gz man/man8/photorec.8.gz \
+ man/man8/testdisk.8.gz
+
PORTDOCS= *
OPTIONS_DEFINE= ICONV PROGSREISERFS NTFS DOCS
@@ -32,18 +33,8 @@ NTFSPROGS_DESC= Use ntfsprogs extensions
PROGSREISERFS_DESC= Use reiserfs extensions
# E2FSPROGS "Use ext2fs extensions" off \
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-#.if !defined(NOPORTDOCS)
-#DISTFILES+= ${PORTNAME}-doc-${PORTVERSION}${EXTRACT_SUFX}
-#.endif
-
-.if ${PORT_OPTIONS:MICONV}
-USES= iconv
-.else
-CONFIGURE_ARGS+=--without-iconv
-.endif
+ICONV_USES= iconv
+ICONV_CONFIGURE_OFF= --without-iconv
# e2fsprogs does not provide ext2fs.so any more
# since it does not do 'make install-libs'
@@ -53,30 +44,17 @@ CONFIGURE_ARGS+=--without-iconv
#CONFIGURE_ARGS+=--without-ext2fs
#.endif
-.if ${PORT_OPTIONS:MNTFS3G}
-LIB_DEPENDS+= ntfs-3g:${PORTSDIR}/sysutils/fusefs-ntfs
-.else
-CONFIGURE_ARGS+=--without-ntfs3g
-.endif
+NTFS3G_LIB_DEPENDS= libntfs-3g.so:${PORTSDIR}/sysutils/fusefs-ntfs
+NTFS3G_CONFIGURE_OFF= --without-ntfs3g
-.if ${PORT_OPTIONS:MNTFSPROGS}
-LIB_DEPENDS+= ntfs:${PORTSDIR}/sysutils/ntfsprogs
-.else
-CONFIGURE_ARGS+=--without-ntfs
-.endif
+NTFSPROGS_LIB_DEPENDS= libntfs.so:${PORTSDIR}/sysutils/ntfsprogs
+NTFS_PROGS_CONFIGURE_ARGS= --without-ntfs
-.if ${PORT_OPTIONS:MPROGSREISERFS}
-LIB_DEPENDS+= reiserfs-0.3.0:${PORTSDIR}/sysutils/progsreiserfs
-.else
-CONFIGURE_ARGS+=--without-reiserfs
-.endif
+PROGSREISERFS_LIB_DEPENDS= libreiserfs-0.3.so:${PORTSDIR}/sysutils/progsreiserfs
+PROGSREISERFS_CONFIGURE_OFF= --without-reiserfs
post-patch:
-.if ${PORT_OPTIONS:MDOCS}
@${REINPLACE_CMD} -e 's|/doc/.(PACKAGE)-.(VERSION)|/doc/${PORTNAME}|' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e '/doc\/testdisk\/html/d' ${WRKSRC}/Makefile.in
-.else
- @${REINPLACE_CMD} -e '/\/doc\/$$(PACKAGE)-$$(VERSION)/d' ${WRKSRC}/Makefile.in
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/testdisk/distinfo b/sysutils/testdisk/distinfo
index 7383af245cc8..8295d010c0ce 100644
--- a/sysutils/testdisk/distinfo
+++ b/sysutils/testdisk/distinfo
@@ -1,2 +1,2 @@
-SHA256 (testdisk-6.13.tar.bz2) = 48275ccddfc9445b6c3e6e181728dae9e49bd25b824a6b5670d58f1f88cdf220
-SIZE (testdisk-6.13.tar.bz2) = 560696
+SHA256 (testdisk-6.14.tar.bz2) = a597c3ebc375acdf0ff60f44ed8935a301132aae78ec00f64f091637d055326c
+SIZE (testdisk-6.14.tar.bz2) = 620077