aboutsummaryrefslogtreecommitdiff
path: root/sysutils/tmate
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2016-05-27 19:56:49 +0000
committerSteve Wills <swills@FreeBSD.org>2016-05-27 19:56:49 +0000
commit8946e732cecc52099c01320f90b976f83688f8c0 (patch)
tree51cd0b9071efb42fb8a247c22ffd8d59fdd133d9 /sysutils/tmate
parent1701f697db9fb4f316d6bf443408119d09758a39 (diff)
downloadports-8946e732cecc52099c01320f90b976f83688f8c0.tar.gz
ports-8946e732cecc52099c01320f90b976f83688f8c0.zip
sysutils/tmate: create port
Instant terminal sharing WWW: https://tmate.io/
Notes
Notes: svn path=/head/; revision=415961
Diffstat (limited to 'sysutils/tmate')
-rw-r--r--sysutils/tmate/Makefile30
-rw-r--r--sysutils/tmate/distinfo3
-rw-r--r--sysutils/tmate/files/patch-tmate-session.c10
-rw-r--r--sysutils/tmate/files/patch-tmate-ssh-client.c10
-rw-r--r--sysutils/tmate/pkg-descr3
5 files changed, 56 insertions, 0 deletions
diff --git a/sysutils/tmate/Makefile b/sysutils/tmate/Makefile
new file mode 100644
index 000000000000..3a06bdae967d
--- /dev/null
+++ b/sysutils/tmate/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= tmate
+PORTVERSION= 2.2.1
+CATEGORIES= sysutils
+
+MAINTAINER= swills@FreeBSD.org
+COMMENT= Instant terminal sharing
+
+LIB_DEPENDS= libevent.so:devel/libevent2 \
+ libmsgpackc.so:devel/msgpack \
+ libssh_threads.so:security/libssh
+
+USES= autoreconf pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= tmate-io
+
+GNU_CONFIGURE= yes
+INSTALL_ARGET= install-strip
+USE_LDCONFIG= yes
+LDFLAGS+= -lexecinfo
+
+PLIST_FILES= bin/tmate man/man1/tmate.1.gz
+
+BROKEN_FreeBSD_9= Does not build
+
+pre-configure:
+ @cd $(wrksrc} && ./autogen.sh
+
+.include <bsd.port.mk>
diff --git a/sysutils/tmate/distinfo b/sysutils/tmate/distinfo
new file mode 100644
index 000000000000..c9ce93242bb7
--- /dev/null
+++ b/sysutils/tmate/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1463695696
+SHA256 (tmate-io-tmate-2.2.1_GH0.tar.gz) = d9c2ac59f42e65aac5f500f0548ea8056fd79c9c5285e5af324d833e2a84c305
+SIZE (tmate-io-tmate-2.2.1_GH0.tar.gz) = 610745
diff --git a/sysutils/tmate/files/patch-tmate-session.c b/sysutils/tmate/files/patch-tmate-session.c
new file mode 100644
index 000000000000..dbf7cfef2808
--- /dev/null
+++ b/sysutils/tmate/files/patch-tmate-session.c
@@ -0,0 +1,10 @@
+--- tmate-session.c.orig 2016-03-29 03:30:07 UTC
++++ tmate-session.c
+@@ -8,6 +8,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <assert.h>
++#include <netinet/in.h>
+
+ #include "tmate.h"
+
diff --git a/sysutils/tmate/files/patch-tmate-ssh-client.c b/sysutils/tmate/files/patch-tmate-ssh-client.c
new file mode 100644
index 000000000000..73d28cefa8e5
--- /dev/null
+++ b/sysutils/tmate/files/patch-tmate-ssh-client.c
@@ -0,0 +1,10 @@
+--- tmate-ssh-client.c.orig 2016-03-29 03:30:07 UTC
++++ tmate-ssh-client.c
+@@ -3,6 +3,7 @@
+ #include <stdio.h>
+ #include <event.h>
+ #include <assert.h>
++#include <netinet/in.h>
+
+ #include "tmate.h"
+ #include "window-copy.h"
diff --git a/sysutils/tmate/pkg-descr b/sysutils/tmate/pkg-descr
new file mode 100644
index 000000000000..c742b0a032d4
--- /dev/null
+++ b/sysutils/tmate/pkg-descr
@@ -0,0 +1,3 @@
+Instant terminal sharing
+
+WWW: https://tmate.io/