aboutsummaryrefslogtreecommitdiff
path: root/sysutils/tmpwatch
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2006-04-20 10:01:11 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2006-04-20 10:01:11 +0000
commit243c713feb500590727a8807b46ee3513afb3175 (patch)
tree353f77d11a74af1518a2fc7bb342a8af29f160d0 /sysutils/tmpwatch
parentea6082d3cbcc60a4c3924c6db3114cd5e5cdf458 (diff)
downloadports-243c713feb500590727a8807b46ee3513afb3175.tar.gz
ports-243c713feb500590727a8807b46ee3513afb3175.zip
Fix build on 4.x.
Submitted by: Rainer Alves (maintainer) Reported by: pointyhat via kris
Notes
Notes: svn path=/head/; revision=159997
Diffstat (limited to 'sysutils/tmpwatch')
-rw-r--r--sysutils/tmpwatch/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/sysutils/tmpwatch/Makefile b/sysutils/tmpwatch/Makefile
index a1913071e502..1346053b38bb 100644
--- a/sysutils/tmpwatch/Makefile
+++ b/sysutils/tmpwatch/Makefile
@@ -23,6 +23,8 @@ CFLAGS+= ${CPPFLAGS} -DVERSION=\"${PORTVERSION}\"
MAN8= tmpwatch.8
PLIST_FILES= sbin/tmpwatch
+.include <bsd.port.pre.mk>
+
do-extract:
${MKDIR} ${WRKDIR}
cd ${WRKDIR} && \
@@ -33,6 +35,10 @@ do-extract:
post-patch:
${REINPLACE_CMD} -E "s/^#include.+mntent.h.+//g" ${WRKSRC}/tmpwatch.c
+.if ${OSVERSION} < 500000
+ ${REINPLACE_CMD} -E "s/intmax_t/long long/;s/strtoimax/strtoll/" \
+ ${WRKSRC}/tmpwatch.c
+.endif
do-build:
cd ${WRKSRC} && ${CC} ${CFLAGS} ${LDFLAGS} -o tmpwatch tmpwatch.c
@@ -41,4 +47,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tmpwatch ${PREFIX}/sbin
${INSTALL_MAN} ${WRKSRC}/tmpwatch.8 ${MAN8PREFIX}/man/man8
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>