aboutsummaryrefslogtreecommitdiff
path: root/sysutils/tmux/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-03-05 08:26:57 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-03-05 08:26:57 +0000
commita2fa2144192e3e34d079073b5523d0089dfc454f (patch)
tree96e6979254e8448b846c6ad72eeca727a264abe0 /sysutils/tmux/Makefile
parentd4644e39a8a13376d4527c657859a47dba3814af (diff)
downloadports-a2fa2144192e3e34d079073b5523d0089dfc454f.tar.gz
ports-a2fa2144192e3e34d079073b5523d0089dfc454f.zip
Notes
Diffstat (limited to 'sysutils/tmux/Makefile')
-rw-r--r--sysutils/tmux/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/sysutils/tmux/Makefile b/sysutils/tmux/Makefile
index a9cde165f7b9..6af2cce560a3 100644
--- a/sysutils/tmux/Makefile
+++ b/sysutils/tmux/Makefile
@@ -3,6 +3,7 @@
PORTNAME= tmux
DISTVERSION= 1.9a
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION:R}
@@ -11,11 +12,12 @@ COMMENT= Terminal Multiplexer
LICENSE= BSD2CLAUSE
-GNU_CONFIGURE= yes
USES= pkgconfig shebangfix
-
SHEBANG_FILES= examples/tmux_backup.sh
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--sysconfdir=${PREFIX}/etc
+
PLIST_FILES= bin/tmux \
man/man1/tmux.1.gz \
etc/bash_completion.d/tmux
@@ -47,9 +49,7 @@ PORTSCOUT= ignore:1.9
.include <bsd.port.options.mk>
post-patch:
- @${REINPLACE_CMD} -e 's|/etc/tmux.conf|${PREFIX}/etc/tmux.conf|g' \
- ${WRKSRC}/tmux.1 ${WRKSRC}/tmux.h ${WRKSRC}/CHANGES
- @${REINPLACE_CMD} -e '/LIBS=/s/-lrt//' ${WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} -e 's|/etc/tmux.conf|${PREFIX}/etc/tmux.conf|g' ${WRKSRC}/CHANGES
.if ${PORT_OPTIONS:MLIBEVENT_STATIC}
.if ${PORT_OPTIONS:MLIBEVENT2}