aboutsummaryrefslogtreecommitdiff
path: root/sysutils/tmux
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-12-17 17:19:28 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-12-17 17:19:28 +0000
commitb4c4d6656e7b913544a3cbd1bea7f40f7cad2e74 (patch)
treea521fb26802c90a1dfd3c8c6faf41e209f6da9a0 /sysutils/tmux
parent6bb642b982032fc67d3b8e347f9ee1bdb8643402 (diff)
downloadports-b4c4d6656e7b913544a3cbd1bea7f40f7cad2e74.tar.gz
ports-b4c4d6656e7b913544a3cbd1bea7f40f7cad2e74.zip
Fix a regression in 2.1 where tmux was misshandling key strokes if you
started typing too fast after a tmux command. PR: 205372 Submitted by: me jahn de Obtained from: https://github.com/tmux/tmux/commit/8c8cddbe022af5ece9949804cacffbee6b8972fa MFH: 2015Q4 Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=403912
Diffstat (limited to 'sysutils/tmux')
-rw-r--r--sysutils/tmux/Makefile1
-rw-r--r--sysutils/tmux/files/patch-server-client.c34
2 files changed, 35 insertions, 0 deletions
diff --git a/sysutils/tmux/Makefile b/sysutils/tmux/Makefile
index 51196dbc15b2..07f1e30ff25d 100644
--- a/sysutils/tmux/Makefile
+++ b/sysutils/tmux/Makefile
@@ -3,6 +3,7 @@
PORTNAME= tmux
PORTVERSION= 2.1
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= https://github.com/tmux/tmux/releases/download/${PORTVERSION}/ \
SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION:S/a$//}
diff --git a/sysutils/tmux/files/patch-server-client.c b/sysutils/tmux/files/patch-server-client.c
new file mode 100644
index 000000000000..df30e710d0c6
--- /dev/null
+++ b/sysutils/tmux/files/patch-server-client.c
@@ -0,0 +1,34 @@
+From 8c8cddbe022af5ece9949804cacffbee6b8972fa Mon Sep 17 00:00:00 2001
+From: nicm <nicm>
+Date: Tue, 20 Oct 2015 14:19:27 +0000
+Subject: [PATCH] The table could change when retrying so don't save it at
+ start of server_client_handle_key.
+
+--- server-client.c.orig 2015-09-27 09:42:08 UTC
++++ server-client.c
+@@ -540,7 +540,7 @@ server_client_handle_key(struct client *
+ struct window *w;
+ struct window_pane *wp;
+ struct timeval tv;
+- struct key_table *table = c->keytable;
++ struct key_table *table;
+ struct key_binding bd_find, *bd;
+ int xtimeout;
+
+@@ -606,7 +606,7 @@ server_client_handle_key(struct client *
+ retry:
+ /* Try to see if there is a key binding in the current table. */
+ bd_find.key = key;
+- bd = RB_FIND(key_bindings, &table->key_bindings, &bd_find);
++ bd = RB_FIND(key_bindings, &c->keytable->key_bindings, &bd_find);
+ if (bd != NULL) {
+ /*
+ * Key was matched in this table. If currently repeating but a
+@@ -624,6 +624,7 @@ retry:
+ * Take a reference to this table to make sure the key binding
+ * doesn't disappear.
+ */
++ table = c->keytable;
+ table->references++;
+
+ /*