aboutsummaryrefslogtreecommitdiff
path: root/sysutils/tracker
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-06-11 01:44:15 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-06-11 01:44:15 +0000
commit13fb0b92a29536c74fd1cea5b5e8e7fb8705be98 (patch)
treed21fd4ee60da4c705d6bb2d4d0222a7e7af7ef7b /sysutils/tracker
parent52a39feebd3a360c0a4633697006081ae2024197 (diff)
downloadports-13fb0b92a29536c74fd1cea5b5e8e7fb8705be98.tar.gz
ports-13fb0b92a29536c74fd1cea5b5e8e7fb8705be98.zip
Fix port builds for architectures which remain on gcc as the default compiler.
This will primarily help powerpc64. For archs where clang is the default compiler, these changes will have no effect, as the base compiler already has these capabilities (primarily, but not exclusively, c++-11). Tested for no-harm on amd64. While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=472160
Diffstat (limited to 'sysutils/tracker')
-rw-r--r--sysutils/tracker/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/sysutils/tracker/Makefile b/sysutils/tracker/Makefile
index fa0d942b82f0..996be96ebf81 100644
--- a/sysutils/tracker/Makefile
+++ b/sysutils/tracker/Makefile
@@ -25,8 +25,9 @@ RUN_DEPENDS= xdg-desktop-icon:devel/xdg-utils \
PORTSCOUT= limitw:1,even
-USES= desktop-file-utils gettext gmake gnome libarchive libtool \
- pathfix pkgconfig python:run shebangfix sqlite tar:xz
+USES= compiler:c++11-lib desktop-file-utils gettext gmake gnome \
+ libarchive libtool pathfix pkgconfig python:run shebangfix \
+ sqlite tar:xz
USE_GNOME= gtk30 intltool introspection:build libxslt:build
USE_LDCONFIG= yes
USE_GSTREAMER1= yes