aboutsummaryrefslogtreecommitdiff
path: root/sysutils/tracker
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-08-05 19:13:24 +0000
committerKoop Mast <kwm@FreeBSD.org>2015-08-05 19:13:24 +0000
commitd129587b5d568b0ff5300386f1e1b706c349f38e (patch)
treee398c7b6ea5203fd3953999e6dd9d6c83c9ec931 /sysutils/tracker
parentc13de12f75988e599e389d9c77ed92db8d927185 (diff)
downloadports-d129587b5d568b0ff5300386f1e1b706c349f38e.tar.gz
ports-d129587b5d568b0ff5300386f1e1b706c349f38e.zip
The FreeBSD GNOME team proudly presents GNOME 3.16 for FreeBSD.
The offical GNOME 3.16 release notes can be found at https://help.gnome.org/misc/release-notes/3.16/ Upgrade instructions for port users: Delete the old tracker package with: # pkg delete -f tracker And user port upgrade tool of choice to upgrade. Thanks to Antoine Brodin for running the exp-runs. This release was made possible by the following people: Gustau Perez Ting-Wei_Lan PR: 201980
Notes
Notes: svn path=/head/; revision=393607
Diffstat (limited to 'sysutils/tracker')
-rw-r--r--sysutils/tracker/Makefile130
-rw-r--r--sysutils/tracker/distinfo4
-rw-r--r--sysutils/tracker/files/patch-configure29
-rw-r--r--sysutils/tracker/files/patch-src_tracker-extract_tracker-extract-gstreamer.c13
-rw-r--r--sysutils/tracker/pkg-plist209
5 files changed, 189 insertions, 196 deletions
diff --git a/sysutils/tracker/Makefile b/sysutils/tracker/Makefile
index 96e0a220ec4e..f27e4744698b 100644
--- a/sysutils/tracker/Makefile
+++ b/sysutils/tracker/Makefile
@@ -1,10 +1,8 @@
# Created by: Michael Johnson <ahze@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/trunk/sysutils/tracker/Makefile 20045 2014-11-10 06:23:59Z gusi $
PORTNAME= tracker
-PORTVERSION= 1.2.6
-PORTREVISION= 4
+PORTVERSION= 1.4.1
CATEGORIES= sysutils gnome
MASTER_SITES= GNOME
@@ -17,28 +15,29 @@ LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
libraptor.so:${PORTSDIR}/textproc/raptor \
libuuid.so:${PORTSDIR}/misc/e2fsprogs-libuuid \
libicutu.so:${PORTSDIR}/devel/icu \
- libmediaart-1.0.so:${PORTSDIR}/multimedia/libmediaart \
+ libmediaart-2.0.so:${PORTSDIR}/multimedia/libmediaart \
librest-0.7.so:${PORTSDIR}/devel/librest
RUN_DEPENDS= xdg-desktop-icon:${PORTSDIR}/devel/xdg-utils \
o3totxt:${PORTSDIR}/converters/o3read \
pdftotext:${PORTSDIR}/graphics/poppler-utils \
w3m:${PORTSDIR}/www/w3m
-PLIST_SUB= TRACKER_VER="1.0"
+PORTSCOUT= limitw:1,even
-USES= gettext gmake libarchive libtool pathfix pkgconfig tar:xz
-USE_GNOME= gnomeprefix gtk30 intlhack introspection:build
+USES= desktop-file-utils gettext gmake libtool pathfix pkgconfig tar:xz
+USE_GNOME= gtk30 intltool introspection:build libxslt:build
USE_LDCONFIG= yes
USE_SQLITE= 3
USE_GSTREAMER1= yes
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
-LDFLAGS+= -L${LOCALBASE}/lib -L${LOCALBASE}/lib/tracker
-CONFIGURE_ARGS= --enable-video-extractor=gstreamer \
- --with-session-bus-services-dir=${LOCALBASE}/share/dbus-1/services \
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS= --with-session-bus-services-dir=${LOCALBASE}/share/dbus-1/services \
--disable-libiptcdata --enable-miner-fs \
- --disable-meegotouch --disable-miner-flickr \
+ --disable-meegotouch \
--enable-icu-charset-detection \
+ --disable-network-manager \
--disable-enca \
--enable-tracker-preferences \
--disable-libosinfo \
@@ -55,86 +54,49 @@ GLIB_SCHEMAS= org.freedesktop.Tracker.DB.gschema.xml \
org.freedesktop.Tracker.enums.xml \
org.freedesktop.Tracker.gschema.xml
-OPTIONS_DEFINE= AUDIO_MINERS DOCUMENT_MINERS GRAPHIC_MINERS WEB_MINERS
+PLIST_SUB= TRACKER_VER="1.0" LIBVER=400
+
+OPTIONS_DEFINE= AUDIO_MINERS DOCUMENT_MINERS GRAPHIC_MINERS \
+ NAUTILUS WEB_MINERS
OPTIONS_DEFAULT= AUDIO_MINERS DOCUMENT_MINERS GRAPHIC_MINERS
-WEB_MINERS_DESC= Support for Firefox, Thunderbird and Evolution
+OPTIONS_SUB=yes
+WEB_MINERS_DESC= Support for Firefox, Thunderbird
+# and Evolution
AUDIO_MINERS_DESC= Support for audio formats
DOCUMENT_MINERS_DESC= Support for some sort of documents (pdf, ps, xps, office)
GRAPHIC_MINERS_DESC= Support for some graphic formats (gif, png, tiff)
+NAUTILUS_DESC= Support for nautilus tagging
-.include <bsd.port.pre.mk>
+WEB_MINERS_CONFIGURE_ENABLE= miner-firefox miner-thunderbird
+# miner-evolution
+WEB_MINERS_BUILD_DEPENDS= firefox>=0:${PORTSDIR}/www/firefox \
+ thunderbird>=0:${PORTSDIR}/mail/thunderbird
+WEB_MINERS_RUN_DEPENDS= firefox>=0:${PORTSDIR}/www/firefox \
+ thunderbird>=0:${PORTSDIR}/mail/thunderbird
-.if ${PORT_OPTIONS:MWEB_MINERS}
-CONFIGURE_ARGS+= --enable-miner-firefox \
- --enable-miner-thunderbird
-BUILD_DEPENDS+= firefox>=0:${PORTSDIR}/www/firefox \
- thunderbird>=0:${PORTSDIR}/mail/thunderbird
-RUN_DEPENDS+= firefox>=0:${PORTSDIR}/www/firefox \
- thunderbird>=0:${PORTSDIR}/mail/thunderbird
-PLIST_SUB+= WEB_MINERS=""
-.else
-CONFIGURE_ARGS+= --disable-miner-evolution --disable-miner-firefox \
- --disable-miner-thunderbird
-PLIST_SUB+= WEB_MINERS="@comment "
-.endif
+AUDIO_MINERS_CONFIGURE_ENABLE= libvorbis libflac taglib mp3 libcue playlist
+AUDIO_MINERS_LIB_DEPENDS= libtotem-plparser.so:${PORTSDIR}/multimedia/totem-pl-parser \
+ libFLAC.so:${PORTSDIR}/audio/flac \
+ libvorbis.so:${PORTSDIR}/audio/libvorbis \
+ libcue.so:${PORTSDIR}/textproc/libcue \
+ libogg.so:${PORTSDIR}/audio/libogg \
+ libtag.so:${PORTSDIR}/audio/taglib
-.if ${PORT_OPTIONS:MAUDIO_MINERS}
-LIB_DEPENDS+= libtotem-plparser.so:${PORTSDIR}/multimedia/totem-pl-parser \
- libFLAC.so:${PORTSDIR}/audio/flac \
- libvorbis.so:${PORTSDIR}/audio/libvorbis \
- libcue.so:${PORTSDIR}/textproc/libcue \
- libogg.so:${PORTSDIR}/audio/libogg \
- libtag.so:${PORTSDIR}/audio/taglib
-CONFIGURE_ARGS+= --enable-libvorbis --enable-libflac \
- --enable-taglib --enable-mp3 \
- --enable-libcue --enable-playlist
-PLIST_SUB+= AUDIO_MINERS=""
-.else
-CONFIGURE_ARGS+= --disable-libvorbis --disable-libflac \
- --disable-taglib --disable-mp3 \
- --disable-libcue --disable-playlist
-PLIST_SUB+= AUDIO_MINERS="@comment "
-.endif
+DOCUMENT_MINERS_CONFIGURE_ENABLE= libgxps poppler libxml2 libgsf \
+ abiword dvi ps exempi text
+DOCUMENT_MINERS_LIB_DEPENDS= libpoppler-glib.so:${PORTSDIR}/graphics/poppler-glib \
+ libgxps.so:${PORTSDIR}/graphics/libgxps \
+ libgsf-1.so:${PORTSDIR}/devel/libgsf \
+ libexempi.so:${PORTSDIR}/textproc/exempi \
+ libwv.so:${PORTSDIR}/textproc/wv
-.if ${PORT_OPTIONS:MDOCUMENT_MINERS}
-LIB_DEPENDS+= libpoppler-glib.so:${PORTSDIR}/graphics/poppler-glib \
- libgxps.so:${PORTSDIR}/graphics/libgxps \
- libgsf-1.so:${PORTSDIR}/devel/libgsf \
- libexempi.so:${PORTSDIR}/textproc/exempi \
- libwv.so:${PORTSDIR}/textproc/wv
-CONFIGURE_ARGS+= --enable-libgxps --enable-poppler \
- --enable-libxml2 --enable-exif \
- --enable-libgsf --enable-abiword \
- --enable-dvi --enable-ps \
- --enable-exempi --enable-text
-PLIST_SUB+= DOCUMENT_MINERS=""
-.else
-CONFIGURE_ARGS+= --disable-libgxps --disable-poppler \
- --disable-libxml2 --disable-exif \
- --disable-libgsf --disable-abiword \
- --disable-dvi --disable-ps \
- --disable-exempi --disable-text
-PLIST_SUB+= DOCUMENT_MINERS="@comment "
-.endif
+GRAPHIC_MINERS_CONFIGURE_ENABLE= libexif libgif libjpeg libtiff icon libpng
+GRAPHIC_MINERS_LIB_DEPENDS= libexif.so:${PORTSDIR}/graphics/libexif \
+ libgif.so:${PORTSDIR}/graphics/giflib \
+ libpng.so:${PORTSDIR}/graphics/png \
+ libtiff.so:${PORTSDIR}/graphics/tiff
-.if ${PORT_OPTIONS:MGRAPHIC_MINERS}
-LIB_DEPENDS+= libexif.so:${PORTSDIR}/graphics/libexif \
- libgif.so:${PORTSDIR}/graphics/giflib \
- libpng.so:${PORTSDIR}/graphics/png \
- libtiff.so:${PORTSDIR}/graphics/tiff
-CONFIGURE_ARGS+= --enable-libgif \
- --enable-libjpeg \
- --enable-libtiff \
- --enable-icon \
- --enable-libpng15
-PLIST_SUB+= GRAPHIC_MINERS=""
-.else
-CONFIGURE_ARGS+= --disable-libgif \
- --disable-libjpeg \
- --disable-libtiff \
- --disable-icon \
- --disable-libpng15
-PLIST_SUB+= GRAPHIC_MINERS="@comment "
-.endif
+NAUTILUS_CONFIGURE_ENABLE= nautilus-extension
+NAUTILUS_USE= GNOME=nautilus3
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/tracker/distinfo b/sysutils/tracker/distinfo
index 1416456e92f2..6cb9d709d522 100644
--- a/sysutils/tracker/distinfo
+++ b/sysutils/tracker/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tracker-1.2.6.tar.xz) = 09851691d527b505ed96987c08142f4dbe4f511ea155b66e99b83f73da7c93c4
-SIZE (tracker-1.2.6.tar.xz) = 6049860
+SHA256 (tracker-1.4.1.tar.xz) = 94ecf25a64f4502664e0c45ec25dae0a91f00ad893fb85dd1c2ffe336563e328
+SIZE (tracker-1.4.1.tar.xz) = 5937232
diff --git a/sysutils/tracker/files/patch-configure b/sysutils/tracker/files/patch-configure
index c10f3193af0e..6c7ff680fefa 100644
--- a/sysutils/tracker/files/patch-configure
+++ b/sysutils/tracker/files/patch-configure
@@ -1,14 +1,15 @@
---- configure.orig 2014-07-10 16:14:37.471040624 +0000
-+++ configure 2014-07-10 16:20:50.072015231 +0000
-@@ -19531,7 +19531,6 @@
+--- configure.orig 2015-03-16 09:35:17.635124000 +0100
++++ configure 2015-03-16 09:36:55.795920000 +0100
+@@ -21333,8 +21333,6 @@
# First test for 3_3_5
TRACKER_MINER_EVOLUTION_3_3_5_REQUIRED="glib-2.0 >= $GLIB_REQUIRED
evolution-shell-3.0 >= 3.1
- evolution-plugin-3.0
- libemail-utils
+- libemail-utils
libemail-engine
evolution-data-server-1.2 >= $EDS_REQUIRED
-@@ -19626,7 +19625,6 @@
+ camel-1.2 >= $CAMEL_REQUIRED"
+@@ -21428,7 +21426,6 @@
# Second test for 3_2
TRACKER_MINER_EVOLUTION_3_2_REQUIRED="glib-2.0 >= $GLIB_REQUIRED
evolution-shell-3.0 >= 3.1
@@ -16,7 +17,7 @@
evolution-data-server-1.2 >= $EDS_REQUIRED
camel-1.2 >= $CAMEL_REQUIRED"
-@@ -19716,7 +19714,6 @@
+@@ -21518,7 +21515,6 @@
# Third test for 2_91
TRACKER_MINER_EVOLUTION_2_91_REQUIRED="glib-2.0 >= $GLIB_REQUIRED
evolution-shell-3.0
@@ -24,7 +25,7 @@
evolution-data-server-1.2 >= $EDS_REQUIRED
camel-1.2 >= $CAMEL_REQUIRED"
-@@ -19802,7 +19799,6 @@
+@@ -21604,7 +21600,6 @@
# Fourth test others (do we really want support for anything < 3.2)?
TRACKER_MINER_EVOLUTION_LAST_REQUIRED="glib-2.0 >= $GLIB_REQUIRED
evolution-shell >= $EVO_SHELL_REQUIRED
@@ -32,7 +33,7 @@
evolution-data-server-1.2 >= $EDS_REQUIRED
camel-1.2 >= $CAMEL_REQUIRED"
-@@ -24340,14 +24336,14 @@
+@@ -24317,14 +24312,14 @@
elif test -n "$PKG_CONFIG"; then
if test -n "$PKG_CONFIG" && \
{ { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"dbus-1 >= \$DBUS_REQUIRED
@@ -50,7 +51,7 @@
test "x$?" != "x0" && pkg_failed=yes
else
pkg_failed=yes
-@@ -24360,14 +24356,16 @@
+@@ -24337,14 +24332,16 @@
elif test -n "$PKG_CONFIG"; then
if test -n "$PKG_CONFIG" && \
{ { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"dbus-1 >= \$DBUS_REQUIRED
@@ -70,7 +71,7 @@
test "x$?" != "x0" && pkg_failed=yes
else
pkg_failed=yes
-@@ -24389,10 +24387,12 @@
+@@ -24366,10 +24363,12 @@
fi
if test $_pkg_short_errors_supported = yes; then
HAL_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "dbus-1 >= $DBUS_REQUIRED
@@ -85,3 +86,11 @@
fi
# Put the nasty error message in config.log where it belongs
echo "$HAL_PKG_ERRORS" >&5
+@@ -25567,7 +25566,6 @@
+ if test "${with_evolution_plugin_dir+set}" = set; then :
+ withval=$with_evolution_plugin_dir;
+ fi
+-,
+ tracker_miner_evolution_install_dir=$withval,
+ tracker_miner_evolution_install_dir=`$PKG_CONFIG $evolution_plugin_name --variable=plugindir`,
+
diff --git a/sysutils/tracker/files/patch-src_tracker-extract_tracker-extract-gstreamer.c b/sysutils/tracker/files/patch-src_tracker-extract_tracker-extract-gstreamer.c
new file mode 100644
index 000000000000..687809913cc9
--- /dev/null
+++ b/sysutils/tracker/files/patch-src_tracker-extract_tracker-extract-gstreamer.c
@@ -0,0 +1,13 @@
+--- src/tracker-extract/tracker-extract-gstreamer.c.orig
++++ src/tracker-extract/tracker-extract-gstreamer.c
+@@ -1647,7 +1647,9 @@ tracker_extract_gstreamer (const gchar *uri,
+ graph);
+
+ #ifdef HAVE_LIBMEDIAART
+- if (extractor->media_art_type != MEDIA_ART_NONE) {
++ if (extractor->media_art_type != MEDIA_ART_NONE &&
++ (extractor->media_art_artist != NULL ||
++ extractor->media_art_title != NULL)) {
+ GError *error = NULL;
+ gboolean success = TRUE;
+
diff --git a/sysutils/tracker/pkg-plist b/sysutils/tracker/pkg-plist
index f15cf95ea58b..19dcd910ad2c 100644
--- a/sysutils/tracker/pkg-plist
+++ b/sysutils/tracker/pkg-plist
@@ -1,3 +1,4 @@
+bin/tracker
bin/tracker-control
bin/tracker-import
bin/tracker-info
@@ -19,7 +20,6 @@ include/tracker-%%TRACKER_VER%%/libtracker-miner/tracker-decorator-fs.h
include/tracker-%%TRACKER_VER%%/libtracker-miner/tracker-decorator.h
include/tracker-%%TRACKER_VER%%/libtracker-miner/tracker-enumerator.h
include/tracker-%%TRACKER_VER%%/libtracker-miner/tracker-indexing-tree.h
-include/tracker-%%TRACKER_VER%%/libtracker-miner/tracker-miner-common.h
include/tracker-%%TRACKER_VER%%/libtracker-miner/tracker-miner-enum-types.h
include/tracker-%%TRACKER_VER%%/libtracker-miner/tracker-miner-enums.h
include/tracker-%%TRACKER_VER%%/libtracker-miner/tracker-miner-fs.h
@@ -27,6 +27,7 @@ include/tracker-%%TRACKER_VER%%/libtracker-miner/tracker-miner-object.h
include/tracker-%%TRACKER_VER%%/libtracker-miner/tracker-miner-online.h
include/tracker-%%TRACKER_VER%%/libtracker-miner/tracker-miner.h
include/tracker-%%TRACKER_VER%%/libtracker-sparql/tracker-generated.h
+include/tracker-%%TRACKER_VER%%/libtracker-sparql/tracker-ontologies.h
include/tracker-%%TRACKER_VER%%/libtracker-sparql/tracker-sparql.h
include/tracker-%%TRACKER_VER%%/libtracker-sparql/tracker-version.h
%%WEB_MINERS%%lib/firefox-addons/extensions/trackerfox@bustany.org
@@ -37,15 +38,17 @@ lib/girepository-%%TRACKER_VER%%/TrackerMiner-1.0.typelib
lib/libtracker-control-%%TRACKER_VER%%.a
lib/libtracker-control-%%TRACKER_VER%%.so
lib/libtracker-control-%%TRACKER_VER%%.so.0
-lib/libtracker-control-%%TRACKER_VER%%.so.0.203.3
+lib/libtracker-control-%%TRACKER_VER%%.so.0.%%LIBVER%%.1
lib/libtracker-miner-%%TRACKER_VER%%.a
lib/libtracker-miner-%%TRACKER_VER%%.so
lib/libtracker-miner-%%TRACKER_VER%%.so.0
-lib/libtracker-miner-%%TRACKER_VER%%.so.0.203.3
+lib/libtracker-miner-%%TRACKER_VER%%.so.0.%%LIBVER%%.1
lib/libtracker-sparql-%%TRACKER_VER%%.a
lib/libtracker-sparql-%%TRACKER_VER%%.so
lib/libtracker-sparql-%%TRACKER_VER%%.so.0
-lib/libtracker-sparql-%%TRACKER_VER%%.so.0.203.3
+lib/libtracker-sparql-%%TRACKER_VER%%.so.0.%%LIBVER%%.1
+%%NAUTILUS%%lib/nautilus/extensions-3.0/libnautilus-tracker-tags.a
+%%NAUTILUS%%lib/nautilus/extensions-3.0/libnautilus-tracker-tags.so
%%DOCUMENT_MINERS%%lib/tracker-%%TRACKER_VER%%/extract-modules/libextract-abw.a
%%DOCUMENT_MINERS%%lib/tracker-%%TRACKER_VER%%/extract-modules/libextract-abw.so
%%GRAPHIC_MINERS%%lib/tracker-%%TRACKER_VER%%/extract-modules/libextract-bmp.a
@@ -119,108 +122,113 @@ libexec/tracker-miner-fs
libexec/tracker-miner-user-guides
libexec/tracker-store
libexec/tracker-writeback
-man/man1/tracker-control.1.gz
+man/man1/tracker-daemon.1.gz
man/man1/tracker-extract.1.gz
-man/man1/tracker-import.1.gz
+man/man1/tracker-index.1.gz
man/man1/tracker-info.1.gz
man/man1/tracker-miner-fs.1.gz
man/man1/tracker-needle.1.gz
man/man1/tracker-preferences.1.gz
+man/man1/tracker-reset.1.gz
man/man1/tracker-search.1.gz
man/man1/tracker-sparql.1.gz
-man/man1/tracker-stats.1.gz
+man/man1/tracker-sql.1.gz
+man/man1/tracker-status.1.gz
man/man1/tracker-store.1.gz
man/man1/tracker-tag.1.gz
man/man1/tracker-writeback.1.gz
+man/man5/tracker-db.cfg.5.gz
+man/man5/tracker-extract.cfg.5.gz
+man/man5/tracker-fts.cfg.5.gz
+man/man5/tracker-miner-fs.cfg.5.gz
+man/man5/tracker-store.cfg.5.gz
+man/man5/tracker-writeback.cfg.5.gz
share/appdata/tracker-needle.appdata.xml
share/appdata/tracker-preferences.appdata.xml
share/applications/tracker-needle.desktop
share/applications/tracker-preferences.desktop
%%WEB_MINERS%%share/applications/trackerbird-launcher.desktop
+share/bash-completion/completions/tracker
share/dbus-1/services/org.freedesktop.Tracker1.Miner.Applications.service
share/dbus-1/services/org.freedesktop.Tracker1.Miner.Extract.service
share/dbus-1/services/org.freedesktop.Tracker1.Miner.Files.service
share/dbus-1/services/org.freedesktop.Tracker1.Miner.Userguides.service
share/dbus-1/services/org.freedesktop.Tracker1.Writeback.service
share/dbus-1/services/org.freedesktop.Tracker1.service
-share/doc/libtracker-control/TrackerMinerManager.html
-share/doc/libtracker-control/annotation-glossary.html
-share/doc/libtracker-control/ch01.html
-share/doc/libtracker-control/home.png
-share/doc/libtracker-control/index.html
-share/doc/libtracker-control/index.sgml
-share/doc/libtracker-control/left-insensitive.png
-share/doc/libtracker-control/left.png
-share/doc/libtracker-control/libtracker-control.devhelp2
-share/doc/libtracker-control/libtracker-miner-reference.html
-share/doc/libtracker-control/right-insensitive.png
-share/doc/libtracker-control/right.png
-share/doc/libtracker-control/style.css
-share/doc/libtracker-control/up-insensitive.png
-share/doc/libtracker-control/up.png
-share/doc/libtracker-miner/TrackerDataProvider.html
-share/doc/libtracker-miner/TrackerDecorator.html
-share/doc/libtracker-miner/TrackerDecoratorFS.html
-share/doc/libtracker-miner/TrackerIndexingTree.html
-share/doc/libtracker-miner/TrackerMiner.html
-share/doc/libtracker-miner/TrackerMinerFS.html
-share/doc/libtracker-miner/TrackerMinerOnline.html
-share/doc/libtracker-miner/annotation-glossary.html
-share/doc/libtracker-miner/ch02.html
-share/doc/libtracker-miner/ch03.html
-share/doc/libtracker-miner/ch04.html
-share/doc/libtracker-miner/ch05.html
-share/doc/libtracker-miner/home.png
-share/doc/libtracker-miner/index.html
-share/doc/libtracker-miner/index.sgml
-share/doc/libtracker-miner/left-insensitive.png
-share/doc/libtracker-miner/left.png
-share/doc/libtracker-miner/libtracker-miner-Enumerations.html
-share/doc/libtracker-miner/libtracker-miner-Media-art-management.html
-share/doc/libtracker-miner/libtracker-miner-TrackerEnumerator.html
-share/doc/libtracker-miner/libtracker-miner-TrackerFileDataProvider.html
-share/doc/libtracker-miner/libtracker-miner-TrackerFileEnumerator.html
-share/doc/libtracker-miner/libtracker-miner-TrackerThumbnailer.html
-share/doc/libtracker-miner/libtracker-miner-tracker-miner-common.html
-share/doc/libtracker-miner/libtracker-miner-reference.html
-share/doc/libtracker-miner/libtracker-miner.devhelp2
-share/doc/libtracker-miner/right-insensitive.png
-share/doc/libtracker-miner/right.png
-share/doc/libtracker-miner/style.css
-share/doc/libtracker-miner/tracker-overview-compiling.html
-share/doc/libtracker-miner/tracker-overview.html
-share/doc/libtracker-miner/up-insensitive.png
-share/doc/libtracker-miner/up.png
-share/doc/libtracker-sparql/TrackerSparqlBuilder.html
-share/doc/libtracker-sparql/TrackerSparqlConnection.html
-share/doc/libtracker-sparql/TrackerSparqlCursor.html
-share/doc/libtracker-sparql/annotation-glossary.html
-share/doc/libtracker-sparql/home.png
-share/doc/libtracker-sparql/index.html
-share/doc/libtracker-sparql/index.sgml
-share/doc/libtracker-sparql/left-insensitive.png
-share/doc/libtracker-sparql/left.png
-share/doc/libtracker-sparql/libtracker-sparql-Utilities.html
-share/doc/libtracker-sparql/libtracker-sparql-Version-Information.html
-share/doc/libtracker-sparql/libtracker-sparql-reference.html
-share/doc/libtracker-sparql/libtracker-sparql.devhelp2
-share/doc/libtracker-sparql/right-insensitive.png
-share/doc/libtracker-sparql/right.png
-share/doc/libtracker-sparql/style.css
-share/doc/libtracker-sparql/tracker-examples-builder.html
-share/doc/libtracker-sparql/tracker-examples-readonly.html
-share/doc/libtracker-sparql/tracker-examples-writeonly-with-blank-nodes.html
-share/doc/libtracker-sparql/tracker-examples-writeonly.html
-share/doc/libtracker-sparql/tracker-examples.html
-share/doc/libtracker-sparql/tracker-overview-compiling.html
-share/doc/libtracker-sparql/tracker-overview-connection-methods.html
-share/doc/libtracker-sparql/tracker-overview-environment-variables.html
-share/doc/libtracker-sparql/tracker-overview.html
-share/doc/libtracker-sparql/up-insensitive.png
-share/doc/libtracker-sparql/up.png
share/gir-%%TRACKER_VER%%/Tracker-1.0.gir
share/gir-%%TRACKER_VER%%/TrackerControl-1.0.gir
share/gir-%%TRACKER_VER%%/TrackerMiner-1.0.gir
+share/gtk-doc/html/libtracker-control/libtracker-miner-reference.html
+share/gtk-doc/html/libtracker-control/home.png
+share/gtk-doc/html/libtracker-control/ch01.html
+share/gtk-doc/html/libtracker-control/style.css
+share/gtk-doc/html/libtracker-control/right-insensitive.png
+share/gtk-doc/html/libtracker-control/up.png
+share/gtk-doc/html/libtracker-control/libtracker-control.devhelp2
+share/gtk-doc/html/libtracker-control/up-insensitive.png
+share/gtk-doc/html/libtracker-control/left-insensitive.png
+share/gtk-doc/html/libtracker-control/TrackerMinerManager.html
+share/gtk-doc/html/libtracker-control/right.png
+share/gtk-doc/html/libtracker-control/left.png
+share/gtk-doc/html/libtracker-control/annotation-glossary.html
+share/gtk-doc/html/libtracker-control/index.html
+share/gtk-doc/html/libtracker-miner/libtracker-miner-TrackerFileEnumerator.html
+share/gtk-doc/html/libtracker-miner/libtracker-miner-TrackerEnumerator.html
+share/gtk-doc/html/libtracker-miner/up-insensitive.png
+share/gtk-doc/html/libtracker-miner/TrackerDecorator.html
+share/gtk-doc/html/libtracker-miner/libtracker-miner-TrackerFileDataProvider.html
+share/gtk-doc/html/libtracker-miner/ch02.html
+share/gtk-doc/html/libtracker-miner/left-insensitive.png
+share/gtk-doc/html/libtracker-miner/libtracker-miner-reference.html
+share/gtk-doc/html/libtracker-miner/home.png
+share/gtk-doc/html/libtracker-miner/libtracker-miner-TrackerThumbnailer.html
+share/gtk-doc/html/libtracker-miner/ch03.html
+share/gtk-doc/html/libtracker-miner/index.html
+share/gtk-doc/html/libtracker-miner/right.png
+share/gtk-doc/html/libtracker-miner/libtracker-miner-Media-art-management.html
+share/gtk-doc/html/libtracker-miner/libtracker-miner-Enumerations.html
+share/gtk-doc/html/libtracker-miner/right-insensitive.png
+share/gtk-doc/html/libtracker-miner/ch05.html
+share/gtk-doc/html/libtracker-miner/style.css
+share/gtk-doc/html/libtracker-miner/tracker-overview-compiling.html
+share/gtk-doc/html/libtracker-miner/TrackerMiner.html
+share/gtk-doc/html/libtracker-miner/left.png
+share/gtk-doc/html/libtracker-miner/TrackerMinerFS.html
+share/gtk-doc/html/libtracker-miner/annotation-glossary.html
+share/gtk-doc/html/libtracker-miner/libtracker-miner.devhelp2
+share/gtk-doc/html/libtracker-miner/TrackerMinerOnline.html
+share/gtk-doc/html/libtracker-miner/tracker-overview.html
+share/gtk-doc/html/libtracker-miner/ch04.html
+share/gtk-doc/html/libtracker-miner/TrackerDecoratorFS.html
+share/gtk-doc/html/libtracker-miner/up.png
+share/gtk-doc/html/libtracker-miner/TrackerIndexingTree.html
+share/gtk-doc/html/libtracker-miner/TrackerDataProvider.html
+share/gtk-doc/html/libtracker-sparql/tracker-examples-readonly.html
+share/gtk-doc/html/libtracker-sparql/left-insensitive.png
+share/gtk-doc/html/libtracker-sparql/tracker-examples-builder.html
+share/gtk-doc/html/libtracker-sparql/up.png
+share/gtk-doc/html/libtracker-sparql/tracker-overview-compiling.html
+share/gtk-doc/html/libtracker-sparql/tracker-examples.html
+share/gtk-doc/html/libtracker-sparql/left.png
+share/gtk-doc/html/libtracker-sparql/libtracker-sparql-Version-Information.html
+share/gtk-doc/html/libtracker-sparql/tracker-overview-environment-variables.html
+share/gtk-doc/html/libtracker-sparql/style.css
+share/gtk-doc/html/libtracker-sparql/tracker-overview-connection-methods.html
+share/gtk-doc/html/libtracker-sparql/index.html
+share/gtk-doc/html/libtracker-sparql/tracker-examples-writeonly-with-blank-nodes.html
+share/gtk-doc/html/libtracker-sparql/TrackerSparqlBuilder.html
+share/gtk-doc/html/libtracker-sparql/libtracker-sparql-Utilities.html
+share/gtk-doc/html/libtracker-sparql/annotation-glossary.html
+share/gtk-doc/html/libtracker-sparql/TrackerSparqlCursor.html
+share/gtk-doc/html/libtracker-sparql/right.png
+share/gtk-doc/html/libtracker-sparql/up-insensitive.png
+share/gtk-doc/html/libtracker-sparql/libtracker-sparql-reference.html
+share/gtk-doc/html/libtracker-sparql/home.png
+share/gtk-doc/html/libtracker-sparql/right-insensitive.png
+share/gtk-doc/html/libtracker-sparql/tracker-overview.html
+share/gtk-doc/html/libtracker-sparql/TrackerSparqlConnection.html
+share/gtk-doc/html/libtracker-sparql/tracker-examples-writeonly.html
+share/gtk-doc/html/libtracker-sparql/libtracker-sparql.devhelp2
share/icons/hicolor/16x16/apps/tracker.png
share/icons/hicolor/22x22/apps/tracker.png
share/icons/hicolor/24x24/apps/tracker.png
@@ -230,6 +238,7 @@ share/icons/hicolor/scalable/apps/tracker.svg
share/locale/ar/LC_MESSAGES/tracker.mo
share/locale/as/LC_MESSAGES/tracker.mo
share/locale/be@latin/LC_MESSAGES/tracker.mo
+share/locale/bg/LC_MESSAGES/tracker.mo
share/locale/bs/LC_MESSAGES/tracker.mo
share/locale/ca/LC_MESSAGES/tracker.mo
share/locale/ca@valencia/LC_MESSAGES/tracker.mo
@@ -282,7 +291,7 @@ share/locale/zh_TW/LC_MESSAGES/tracker.mo
%%DATADIR%%/tracker-backup.xml
%%DATADIR%%/tracker-extract-priority.xml
%%DATADIR%%/tracker-extract.xml
-%%DATADIR%%/tracker-miner-web.xml
+%%DATADIR%%/tracker-miner-files-index.xml
%%DATADIR%%/tracker-miner.xml
%%DATADIR%%/tracker-needle.ui
%%DATADIR%%/tracker-preferences.ui
@@ -320,23 +329,10 @@ share/locale/zh_TW/LC_MESSAGES/tracker.mo
%%DATADIR%%/extract-rules/90-gstreamer-image-generic.rule
%%DATADIR%%/extract-rules/90-gstreamer-video-generic.rule
%%DOCUMENT_MINERS%%%%DATADIR%%/extract-rules/90-text-generic.rule
-%%DATADIR%%/languages/stopwords.da
-%%DATADIR%%/languages/stopwords.de
-%%DATADIR%%/languages/stopwords.en
-%%DATADIR%%/languages/stopwords.es
-%%DATADIR%%/languages/stopwords.fi
-%%DATADIR%%/languages/stopwords.fr
-%%DATADIR%%/languages/stopwords.hu
-%%DATADIR%%/languages/stopwords.it
-%%DATADIR%%/languages/stopwords.nb
-%%DATADIR%%/languages/stopwords.nl
-%%DATADIR%%/languages/stopwords.pt
-%%DATADIR%%/languages/stopwords.ru
-%%DATADIR%%/languages/stopwords.sv
-%%DATADIR%%/miners/tracker-miner-applications.desktop
-%%DATADIR%%/miners/tracker-miner-extract.desktop
-%%DATADIR%%/miners/tracker-miner-files.desktop
-%%DATADIR%%/miners/tracker-miner-userguides.desktop
+%%DATADIR%%/miners/org.freedesktop.Tracker1.Miner.Applications.service
+%%DATADIR%%/miners/org.freedesktop.Tracker1.Miner.Extract.service
+%%DATADIR%%/miners/org.freedesktop.Tracker1.Miner.Files.service
+%%DATADIR%%/miners/org.freedesktop.Tracker1.Miner.Userguides.service
%%DATADIR%%/ontologies/10-xsd.description
%%DATADIR%%/ontologies/10-xsd.ontology
%%DATADIR%%/ontologies/11-rdf.description
@@ -377,6 +373,19 @@ share/locale/zh_TW/LC_MESSAGES/tracker.mo
%%DATADIR%%/ontologies/92-slo.ontology
%%DATADIR%%/ontologies/93-libosinfo.description
%%DATADIR%%/ontologies/93-libosinfo.ontology
+%%DATADIR%%/stop-words/stopwords.da
+%%DATADIR%%/stop-words/stopwords.de
+%%DATADIR%%/stop-words/stopwords.en
+%%DATADIR%%/stop-words/stopwords.es
+%%DATADIR%%/stop-words/stopwords.fi
+%%DATADIR%%/stop-words/stopwords.fr
+%%DATADIR%%/stop-words/stopwords.hu
+%%DATADIR%%/stop-words/stopwords.it
+%%DATADIR%%/stop-words/stopwords.nb
+%%DATADIR%%/stop-words/stopwords.nl
+%%DATADIR%%/stop-words/stopwords.pt
+%%DATADIR%%/stop-words/stopwords.ru
+%%DATADIR%%/stop-words/stopwords.sv
%%DATADIR%%-tests/01-writeback.py
share/vala/vapi/tracker-control-%%TRACKER_VER%%.deps
share/vala/vapi/tracker-control-%%TRACKER_VER%%.vapi