aboutsummaryrefslogtreecommitdiff
path: root/sysutils/tree
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2012-11-02 17:20:55 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2012-11-02 17:20:55 +0000
commit1356fcd32b17c44d45edc6acf7911abb70312146 (patch)
tree3a361ad87070727b4ab7281938da28e4b7830cdc /sysutils/tree
parent1446804ad6352f64e57acbe0086fa5a714ca46e9 (diff)
downloadports-1356fcd32b17c44d45edc6acf7911abb70312146.tar.gz
ports-1356fcd32b17c44d45edc6acf7911abb70312146.zip
- update to 1.6.0
- pass maintainership to submitter while here - install license via license framework, not manually - convert to optionsng - remove deprecated Author field in pkg-descr - whitespace fixes in pkg-descr PR: 171723 Submitted by: Guy Brand <gb at unistra dot fr> Feature safe: yes
Notes
Notes: svn path=/head/; revision=306874
Diffstat (limited to 'sysutils/tree')
-rw-r--r--sysutils/tree/Makefile13
-rw-r--r--sysutils/tree/distinfo4
-rw-r--r--sysutils/tree/files/patch-Makefile34
-rw-r--r--sysutils/tree/files/patch-tree.c38
-rw-r--r--sysutils/tree/pkg-descr5
5 files changed, 31 insertions, 63 deletions
diff --git a/sysutils/tree/Makefile b/sysutils/tree/Makefile
index 8ee2c208fd7a..7585883c33ae 100644
--- a/sysutils/tree/Makefile
+++ b/sysutils/tree/Makefile
@@ -2,24 +2,29 @@
# $FreeBSD$
PORTNAME= tree
-PORTVERSION= 1.5.3
+PORTVERSION= 1.6.0
CATEGORIES= sysutils
MASTER_SITES= ftp://mama.indstate.edu/linux/tree/ \
CENKES
EXTRACT_SUFX= .tgz
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= gb@unistra.fr
COMMENT= Display a tree-view of directories with optional color or HTML output
+LICENSE= GPLv2
+
MAKE_ENV+= MKDIR="${MKDIR}"
+USE_GMAKE= yes
MAN1= tree.1
PLIST_FILES= bin/tree
-PORTDOCS= CHANGES LICENSE README
+PORTDOCS= CHANGES README
+
+.include <bsd.port.options.mk>
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_MAN} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
.endif
diff --git a/sysutils/tree/distinfo b/sysutils/tree/distinfo
index 2e891649620c..2e5c949c636b 100644
--- a/sysutils/tree/distinfo
+++ b/sysutils/tree/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tree-1.5.3.tgz) = 1128755ea9455615188212bb04319cf103114fb78f687aa887ce29ef184ffb8d
-SIZE (tree-1.5.3.tgz) = 34494
+SHA256 (tree-1.6.0.tgz) = 4dc470a74880338b01da41701d8db90d0fb178877e526d385931a007d68d7591
+SIZE (tree-1.6.0.tgz) = 42706
diff --git a/sysutils/tree/files/patch-Makefile b/sysutils/tree/files/patch-Makefile
index 8eb80ae2c6c6..22e1eeecb2ec 100644
--- a/sysutils/tree/files/patch-Makefile
+++ b/sysutils/tree/files/patch-Makefile
@@ -1,8 +1,8 @@
---- ./Makefile.orig 2010-01-14 14:04:12.000000000 +0100
-+++ ./Makefile 2010-01-14 14:08:21.000000000 +0100
-@@ -6,27 +6,27 @@
- # warranties, including, without limitation, the implied warranties
- # of merchant-ability and fitness for a particular purpose.
+--- ./Makefile.orig 2011-06-24 16:25:27.000000000 +0200
++++ ./Makefile 2012-09-17 13:38:44.926563330 +0200
+@@ -16,14 +16,14 @@
+ # along with this program; if not, write to the Free Software
+ # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-prefix = /usr
+prefix = ${PREFIX}
@@ -10,32 +10,34 @@
-CC=gcc
+CC?=gcc
- VERSION=1.5.3
+ VERSION=1.6.0
TREE_DEST=tree
BINDIR=${prefix}/bin
-MAN=tree.1
-+MAN=man/tree.1
++MAN=doc/tree.1
MANDIR=${prefix}/man/man1
+ OBJS=tree.o unix.o html.o xml.o hash.o color.o
- # Uncomment options below for your particular OS:
+@@ -31,13 +31,13 @@
# Linux defaults:
--CFLAGS=-ggdb -Wall -DLINUX -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
-+#CFLAGS=-ggdb -Wall -DLINUX -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
- #CFLAGS=-O2 -Wall -fomit-frame-pointer -DLINUX -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
- #LDFLAGS=-s
+ #CFLAGS=-ggdb -Wall -DLINUX -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
+-CFLAGS=-O4 -Wall -DLINUX -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
+-LDFLAGS=-s
++#CFLAGS=-O4 -Wall -DLINUX -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
++#LDFLAGS=-s
# Uncomment for FreeBSD:
-#CFLAGS=-O2 -Wall -fomit-frame-pointer
-#LDFLAGS=-s
--#XOBJS=strverscmp.o
+-#OBJS+=strverscmp.o
+CFLAGS?=-O2 -Wall -fomit-frame-pointer
+LDFLAGS?=-s
-+XOBJS?=strverscmp.o
++OBJS+=strverscmp.o
# Uncomment for Solaris:
#CC=cc
-@@ -82,13 +82,11 @@
+@@ -93,13 +93,11 @@
if [ -f tree.o ]; then rm *.o; fi
rm -f *~
@@ -45,7 +47,7 @@
- if [ -e $(TREE_DEST) ]; then \
- install -s $(TREE_DEST) $(BINDIR)/$(TREE_DEST); \
- fi
-- install man/$(MAN) $(MANDIR)/$(MAN)
+- install doc/$(MAN) $(MANDIR)/$(MAN)
+install: $(TREE_DEST)
+ @$(MKDIR) $(BINDIR)
+ @$(MKDIR) $(MANDIR)
diff --git a/sysutils/tree/files/patch-tree.c b/sysutils/tree/files/patch-tree.c
deleted file mode 100644
index d9cae4a344e4..000000000000
--- a/sysutils/tree/files/patch-tree.c
+++ /dev/null
@@ -1,38 +0,0 @@
---- ./tree.c.orig 2010-01-14 14:08:55.000000000 +0100
-+++ ./tree.c 2010-01-14 14:15:23.000000000 +0100
-@@ -682,7 +682,7 @@
- #ifdef __USE_FILE_OFFSET64
- if (inodeflag) sprintf(path," %7lld",(*dir)->inode);
- #else
-- if (inodeflag) sprintf(path," %7ld",(*dir)->inode);
-+ if (inodeflag) sprintf(path," %7u",(*dir)->inode);
- #endif
- if (devflag) sprintf(path+strlen(path), " %3d", (int)(*dir)->dev);
- #ifdef __EMX__
-@@ -1106,8 +1106,10 @@
- } else {
- if (Hflag) fprintf(outfile,"<br>\t\t\t\t ");
- for(i=0; dirs[i] && i <= maxlevel; i++) {
-+ if (dirs[i] <= 0)
-+ break;
- fprintf(outfile,"%s ",
-- dirs[i+1] ? (dirs[i]==1 ? linedraw->vert : (Hflag? "&nbsp;&nbsp;&nbsp;" : " ") )
-+ dirs[i+1] > 0 ? (dirs[i]==1 ? linedraw->vert : (Hflag? "&nbsp;&nbsp;&nbsp;" : " ") )
- : (dirs[i]==1 ? linedraw->vert_left:linedraw->corner));
- }
- }
-@@ -1294,8 +1296,12 @@
- {
- char *unit="BKMGTPEZY";
- int idx;
--
-- if (!hflag) sprintf(buf, sizeof(off_t) == sizeof(long long)? " %11lld" : " %9ld", size);
-+ if (!hflag) {
-+ if (sizeof(off_t) == sizeof(__int64_t))
-+ sprintf(buf, sizeof(long) == sizeof(long long) ? " %11ld" : " %11lld", size);
-+ else
-+ sprintf(buf, sizeof(long) == sizeof(long long) ? " %9ld" : " %9lld", size);
-+ }
- else {
- for (idx=size<1024?0:1; size >= (1024*1024); idx++,size>>=10);
- if (!idx) sprintf(buf, " %4d", (int)size);
diff --git a/sysutils/tree/pkg-descr b/sysutils/tree/pkg-descr
index 9ec89705a805..ac5a4a0d21f2 100644
--- a/sysutils/tree/pkg-descr
+++ b/sysutils/tree/pkg-descr
@@ -1,6 +1,5 @@
-Tree is a simple utility that displays a tree-view of directories
-and files. It has options to use ANSI color escape-sequences or ASCII
+Tree is a simple utility that displays a tree-view of directories
+and files. It has options to use ANSI color escape-sequences or ASCII
graphic characters, and can also output in HTML format.
-Author: Steve Baker <ice+tree@mama.indstate.edu>
WWW: http://mama.indstate.edu/users/ice/tree/