aboutsummaryrefslogtreecommitdiff
path: root/sysutils/u-boot-chip
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2017-06-25 22:51:23 +0000
committerMark Linimon <linimon@FreeBSD.org>2017-06-25 22:51:23 +0000
commit7c486bd2ed3c70b35ab98507acdbcc7d7e56f9ad (patch)
treeb73954776b07d97f920b8c523766dde32200caed /sysutils/u-boot-chip
parent753482114b8d7e166176bc26b128be43d57d5e9d (diff)
downloadports-7c486bd2ed3c70b35ab98507acdbcc7d7e56f9ad.tar.gz
ports-7c486bd2ed3c70b35ab98507acdbcc7d7e56f9ad.zip
Add u-boot-chip, uboot port customized for the CHIP $9 computer.
PR: 213251 Submitted by: manu
Notes
Notes: svn path=/head/; revision=444326
Diffstat (limited to 'sysutils/u-boot-chip')
-rw-r--r--sysutils/u-boot-chip/Makefile14
-rw-r--r--sysutils/u-boot-chip/pkg-descr19
2 files changed, 33 insertions, 0 deletions
diff --git a/sysutils/u-boot-chip/Makefile b/sysutils/u-boot-chip/Makefile
new file mode 100644
index 000000000000..f8439d8d881d
--- /dev/null
+++ b/sysutils/u-boot-chip/Makefile
@@ -0,0 +1,14 @@
+# $FreeBSD$
+
+PKGNAMESUFFIX= -chip
+
+COMMENT= Cross-build U-Boot loader for NextThingCo CHIP
+
+LICENSE= GPLv2
+
+MASTERDIR= ${.CURDIR}/../u-boot-olimex-a20-som-evb
+DESCR= ${.CURDIR}/pkg-descr
+MODEL= sun5i-r8-chip
+BOARD_CONFIG= CHIP_defconfig
+
+.include "${MASTERDIR}/Makefile"
diff --git a/sysutils/u-boot-chip/pkg-descr b/sysutils/u-boot-chip/pkg-descr
new file mode 100644
index 000000000000..f2436e976395
--- /dev/null
+++ b/sysutils/u-boot-chip/pkg-descr
@@ -0,0 +1,19 @@
+U-Boot loader for NextThingCo CHIP.
+
+To install this bootloader on an sdcard just do :
+dd if=/usr/local/share/u-boot/u-boot-chip/u-boot-sunxi-with-spl.bin of=/path/to/sdcarddevice bs=1k seek=8 conv=notrunc,sync
+
+This version is patched so that:
+ * ELF and API features are enabled.
+ * The default environment is trimmed to just what's needed to boot.
+ * The saveenv command writes to the file u-boot.env on the FAT partition.
+ * The DTB file name is chosen based on the board model and passed to ubldr.bin
+ using the fdtfile env variable. ubldr.bin loads the DTB from /boot/dtb/ on
+ the FreeBSD partition.
+ * By default, it loads PIE ubldr.bin from file ubldr.bin on the FAT partition
+ to address 0x42000000, and launches it.
+
+For information about running FreeBSD on Allwinner boards, see
+ https://wiki.freebsd.org/FreeBSD/arm/Allwinner
+
+For general information about U-Boot see WWW: http://www.denx.de/wiki/U-Boot