aboutsummaryrefslogtreecommitdiff
path: root/sysutils/u-boot-master/Makefile
diff options
context:
space:
mode:
authorWarner Losh <imp@FreeBSD.org>2017-01-12 22:49:08 +0000
committerWarner Losh <imp@FreeBSD.org>2017-01-12 22:49:08 +0000
commit1907015066bf9a3000bb4b9f2d32a3c38ae4c87b (patch)
treef8b977acfe275d2ed296890873e90290c66e9e79 /sysutils/u-boot-master/Makefile
parentb480c8f41765ad7191e4ae88f25ce303c8e82e8b (diff)
downloadports-1907015066bf9a3000bb4b9f2d32a3c38ae4c87b.tar.gz
ports-1907015066bf9a3000bb4b9f2d32a3c38ae4c87b.zip
Notes
Diffstat (limited to 'sysutils/u-boot-master/Makefile')
-rw-r--r--sysutils/u-boot-master/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/sysutils/u-boot-master/Makefile b/sysutils/u-boot-master/Makefile
index 20c381f76fa3..2bbb547e7207 100644
--- a/sysutils/u-boot-master/Makefile
+++ b/sysutils/u-boot-master/Makefile
@@ -14,7 +14,11 @@ COMMENT= Cross-build das u-boot for ${MODEL}
LICENSE= GPLv2
-BUILD_DEPENDS= arm-none-eabi-gcc:devel/arm-none-eabi-gcc
+BUILD_DEPENDS= arm-none-eabi-gcc:devel/arm-none-eabi-gcc \
+ gsed:textproc/gsed \
+ swig3.0:devel/swig30 \
+ python:lang/python2 \
+ ${PREFIX}/bin/dtc:sysutil/dtc
USES= gmake
@@ -27,7 +31,7 @@ UBOOT_DIR= share/u-boot/${PORTNAME}${PKGNAMESUFFIX}
INST= ${PREFIX}/${UBOOT_DIR}
DESCR?= ${.CURDIR}/pkg-descr
-MAKE_ARGS+= ARCH=${UBOOT_ARCH} CROSS_COMPILE=${UBOOT_ARCH}-none-eabi-
+MAKE_ARGS+= V=1 ARCH=${UBOOT_ARCH} CROSS_COMPILE=${UBOOT_ARCH}-none-eabi-
NO_ARCH= yes
@@ -46,6 +50,10 @@ IGNORE+= "FAMILY is not defined"
UBOOT_PLIST_OMAP=u-boot.img MLO
UBOOT_VERSION_OMAP=2017.01
+# Defines for ALLWINNER family
+UBOOT_PLIST_ALLWINNER=u-boot.img u-boot-sunxi-with-spl.bin
+UBOOT_VERSION_ALLWINNER=2017.01
+
# Uboot variables
.if !defined(UBOOT_VERSION) && defined(UBOOT_VERSION_${FAMILY:tu})
UBOOT_VERSION=${UBOOT_VERSION_${FAMILY:tu}}