aboutsummaryrefslogtreecommitdiff
path: root/sysutils/u-boot-master
diff options
context:
space:
mode:
authorEmmanuel Vadot <manu@FreeBSD.org>2019-07-19 19:00:04 +0000
committerEmmanuel Vadot <manu@FreeBSD.org>2019-07-19 19:00:04 +0000
commit014cb40dae3b476c96e0c96e7c4ff1be8cc3dad4 (patch)
tree9e88cdc8541a51c54c33ae7c90b6af6c1c5361b6 /sysutils/u-boot-master
parent8fc3e5accca6cdbf04600be40de704308534897d (diff)
downloadports-014cb40dae3b476c96e0c96e7c4ff1be8cc3dad4.tar.gz
ports-014cb40dae3b476c96e0c96e7c4ff1be8cc3dad4.zip
sysutils/u-boot: Update to 2019.07
Remove one patch for RockChip RK3399 that was upstream. Add a patch for storage api to remove SCSI. Allwinner A20 was converted to DM_SCSI upstream and we don't have a good way to do what the api code was doing (only had a brief look). This patch will probably be upstreamed once I've found a better way. For now this means that you cannot boot from SCSI drives using ubldr, using loader.efi will still work. Only Allwinner A20 boards are affected by this.
Notes
Notes: svn path=/head/; revision=506958
Diffstat (limited to 'sysutils/u-boot-master')
-rw-r--r--sysutils/u-boot-master/Makefile2
-rw-r--r--sysutils/u-boot-master/distinfo10
-rw-r--r--sysutils/u-boot-master/files/patch-api_api__storage.c25
3 files changed, 31 insertions, 6 deletions
diff --git a/sysutils/u-boot-master/Makefile b/sysutils/u-boot-master/Makefile
index 00a062c750a6..9357b66bea7b 100644
--- a/sysutils/u-boot-master/Makefile
+++ b/sysutils/u-boot-master/Makefile
@@ -104,7 +104,7 @@ UBOOT_METADATA_ARMADA38X_RAW_BS= 512
.if !defined(UBOOT_VERSION) && defined(UBOOT_VERSION_${FAMILY:tu})
UBOOT_VERSION=${UBOOT_VERSION_${FAMILY:tu}}
.endif
-UBOOT_VERSION?= 2019.04
+UBOOT_VERSION?= 2019.07
.if !defined(UBOOT_PLIST) && defined(UBOOT_PLIST_${FAMILY:tu})
UBOOT_PLIST=${UBOOT_PLIST_${FAMILY:tu}}
diff --git a/sysutils/u-boot-master/distinfo b/sysutils/u-boot-master/distinfo
index fff2275b646f..db6e58ba2c1a 100644
--- a/sysutils/u-boot-master/distinfo
+++ b/sysutils/u-boot-master/distinfo
@@ -1,7 +1,7 @@
-TIMESTAMP = 1554925366
-SHA256 (u-boot/u-boot-2019.04.tar.bz2) = 76b7772d156b3ddd7644c8a1736081e55b78828537ff714065d21dbade229bef
-SIZE (u-boot/u-boot-2019.04.tar.bz2) = 13601643
-SHA256 (u-boot/939129/raw) = 2a4ebf283aec8e74ec77b3cb071c6883f73807454ca94fea78361c7391187b97
-SIZE (u-boot/939129/raw) = 310
+TIMESTAMP = 1563557649
+SHA256 (u-boot/u-boot-2019.07.tar.bz2) = bff4fa77e8da17521c030ca4c5b947a056c1b1be4d3e6ee8637020b8d50251d0
+SIZE (u-boot/u-boot-2019.07.tar.bz2) = 13939667
SHA256 (u-boot/1036621/raw) = 28dbd66d14fab9dc782ce091d3c132a226b8425f6503c329ee8a7031b79b52f7
SIZE (u-boot/1036621/raw) = 480
+SHA256 (u-boot/939129/raw) = 2a4ebf283aec8e74ec77b3cb071c6883f73807454ca94fea78361c7391187b97
+SIZE (u-boot/939129/raw) = 310
diff --git a/sysutils/u-boot-master/files/patch-api_api__storage.c b/sysutils/u-boot-master/files/patch-api_api__storage.c
new file mode 100644
index 000000000000..2e5846fb9a5c
--- /dev/null
+++ b/sysutils/u-boot-master/files/patch-api_api__storage.c
@@ -0,0 +1,25 @@
+--- api/api_storage.c.orig 2019-07-08 19:23:28 UTC
++++ api/api_storage.c
+@@ -69,13 +69,6 @@ void dev_stor_init(void)
+ specs[ENUM_SATA].type = DEV_TYP_STOR | DT_STOR_SATA;
+ specs[ENUM_SATA].name = "sata";
+ #endif
+-#if defined(CONFIG_SCSI)
+- specs[ENUM_SCSI].max_dev = CONFIG_SYS_SCSI_MAX_DEVICE;
+- specs[ENUM_SCSI].enum_started = 0;
+- specs[ENUM_SCSI].enum_ended = 0;
+- specs[ENUM_SCSI].type = DEV_TYP_STOR | DT_STOR_SCSI;
+- specs[ENUM_SCSI].name = "scsi";
+-#endif
+ #if defined(CONFIG_CMD_USB) && defined(CONFIG_USB_STORAGE)
+ specs[ENUM_USB].max_dev = USB_MAX_STOR_DEV;
+ specs[ENUM_USB].enum_started = 0;
+@@ -281,7 +274,7 @@ int dev_enum_storage(struct device_info *di)
+ {
+ int i;
+
+- /* check: ide, usb, scsi, mmc */
++ /* check: ide, usb, mmc */
+ for (i = ENUM_IDE; i < ENUM_MAX; i ++) {
+ if (dev_enum_stor(i, di))
+ return 1;