aboutsummaryrefslogtreecommitdiff
path: root/sysutils/u-boot-master
diff options
context:
space:
mode:
authorEmmanuel Vadot <manu@FreeBSD.org>2019-07-27 14:55:59 +0000
committerEmmanuel Vadot <manu@FreeBSD.org>2019-07-27 14:55:59 +0000
commit593c6238a0435c832b3cd8c339f179fd7a8ac476 (patch)
treeb6010d3b02f7c15852207d199826d4f0a34b7537 /sysutils/u-boot-master
parent0565409a4365e84950b2e8d9da995763354a06bb (diff)
downloadports-593c6238a0435c832b3cd8c339f179fd7a8ac476.tar.gz
ports-593c6238a0435c832b3cd8c339f179fd7a8ac476.zip
sysutils/u-boot-rockpro64: Add new u-boot port for Pine64 RockPro64 board
This use the DDR blob and miniloader from RockChip + trust FW + ATF + u-boot proper.
Notes
Notes: svn path=/head/; revision=507459
Diffstat (limited to 'sysutils/u-boot-master')
-rw-r--r--sysutils/u-boot-master/Makefile17
1 files changed, 13 insertions, 4 deletions
diff --git a/sysutils/u-boot-master/Makefile b/sysutils/u-boot-master/Makefile
index ed2c5c37365e..a1dabbdb29e8 100644
--- a/sysutils/u-boot-master/Makefile
+++ b/sysutils/u-boot-master/Makefile
@@ -22,6 +22,10 @@ BUILD_DEPENDS+= gsed:textproc/gsed \
BUILD_DEPENDS+= ${COMPILER}:devel/${COMPILER}
USES= bison gmake python:2.7,build shebangfix tar:bz2
+.if defined(FAMILY) && ${FAMILY} == rk3399
+USES+= linux
+USE_LINUX+= base:build
+.endif
BINARY_ALIAS= bison=${LOCALBASE}/bin/bison dtc=${LOCALBASE}/bin/dtc sed=gsed swig=swig3.0 python2=python2.7
SHEBANG_FILES= tools/binman/binman.py arch/arm/mach-rockchip/make_fit_atf.py
@@ -94,7 +98,7 @@ UBOOT_PLIST_RK3328= idbloader.img u-boot.itb
UBOOT_ARCH_RK3328= aarch64
# Override for RK3399 family
-UBOOT_PLIST_RK3399= idbspl.img u-boot.itb
+UBOOT_PLIST_RK3399= idbloader.img trust.img uboot.img
UBOOT_ARCH_RK3399= aarch64
# Override for ARMADA38X family
@@ -146,13 +150,15 @@ MAKE_ENV+= BL31=${LOCALBASE}/share/atf-sun50i_a64/bl31.bin
.if defined(FAMILY) && ${FAMILY} == rk3328
BUILD_DEPENDS+= ${LOCALBASE}/share/atf-rk3328/bl31.elf:sysutils/atf-rk3328 \
- ${PYTHON_PKGNAMEPREFIX}pyelftools>0:devel/py-pyelftools@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}pyelftools>0:devel/py-pyelftools@${PY_FLAVOR} \
+ ${LOCALBASE}/bin/rk-trust_merger:sysutils/linux-rkbin
MAKE_ENV+= BL31=${LOCALBASE}/share/atf-rk3328/bl31.elf
.endif
.if defined(FAMILY) && ${FAMILY} == rk3399
BUILD_DEPENDS+= ${LOCALBASE}/share/atf-rk3399/bl31.elf:sysutils/atf-rk3399 \
- ${PYTHON_PKGNAMEPREFIX}pyelftools>0:devel/py-pyelftools@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}pyelftools>0:devel/py-pyelftools@${PY_FLAVOR} \
+ ${LOCALBASE}/bin/rk-trust_merger:sysutils/linux-rkbin
MAKE_ENV+= BL31=${LOCALBASE}/share/atf-rk3399/bl31.elf
.endif
@@ -219,7 +225,10 @@ post-build:
cat ${WRKSRC}/spl/u-boot-spl.bin >> ${WRKSRC}/idbloader.img
.endif
.if defined(FAMILY) && ${FAMILY} == rk3399
- mkimage -n rk3399 -T rksd -d ${WRKSRC}/spl/u-boot-spl.bin ${WRKSRC}/idbspl.img
+ mkimage -n rk3399 -T rksd -d ${LOCALBASE}/share/linux-rkbin/bin/rk33/rk3399_ddr_800MHz_v1.23.bin ${WRKSRC}/idbloader.img
+ cat ${LOCALBASE}/share/linux-rkbin/bin/rk33/rk3399_miniloader_v1.19.bin >> ${WRKSRC}/idbloader.img
+ (cd ${WRKSRC} && rk-trust_merger ${LOCALBASE}/share/linux-rkbin/rktrust/RK3399TRUST.ini)
+ (cd ${WRKSRC} && rk-loaderimage --pack --uboot u-boot-dtb.bin uboot.img)
.endif
# If we need to put anything into WRKSRC, do so now so we can build the PLIST
# in do-install